目次

1. 概要と特徴
2. 端子接続と回路構成
3. 端子機能
4. 特性
 4.1 絶対最大定格
 4.2 動作条件
 4.3 周波数特性･消費電流特性
 4.4 電気的特性(DC特性)
5. ｽｲｯﾁﾝｸﾞ特性
 5.1 80系
 5.2 68系
 5.3 ﾃﾞｰﾀ保持ﾀｲﾐﾝｸﾞ
6. ﾚｼﾞｽﾀ
 6.1 ﾚｼﾞｽﾀ･ﾃｰﾌﾞﾙ
 6.2 注意事項
 6.3 ﾘｱﾙﾀｲﾑ･ｱﾗｰﾑ･ﾚｼﾞｽﾀ
 6.4 ｺﾝﾄﾛｰﾙ･ﾚｼﾞｽﾀ･ﾋﾞｯﾄの役割
 6.5 定周期及びｱﾗｰﾑ出力ﾓｰﾄﾞの設定とﾀｲﾐﾝｸﾞ
 6.6 定周期及びｱﾗｰﾑ出力ﾓｰﾄﾞのﾘｾｯﾄ(復帰)とﾀｲﾐﾝｸﾞ
7. ﾚｼﾞｽﾀ説明
 7.1 時刻･ｶﾚﾝﾀﾞ･ﾚｼﾞｽﾀ
 7.2 CDﾚｼﾞｽﾀ (MASK1,MASK2,ｴT/PLS1,ｴT/PLS2)
 7.3 CEﾚｼﾞｽﾀ (IRQ FLAG1,ｴRQ FLAG2,RESET,ｴRQ FLAG0)
 7.4 CFﾚｼﾞｽﾀ (READ FLAG,30秒ADJ,ST0P,BANK1/0)
 7.5 ｱﾗｰﾑ時刻･ｶﾚﾝﾀﾞ･ﾚｼﾞｽﾀ
 7.6 A-ENBﾚｼﾞｽﾀ
 7.7 C'Cﾚｼﾞｽﾀ (TEST2,TEST1)
 7.8 C'Dﾚｼﾞｽﾀ (CY2,CY1,CY0)
 7.9 C'Eﾚｼﾞｽﾀ (D.P.,CAL,24/12,HD/SFT)
8. 使用方法
 8.1 電源投入時(初期設定)の手続き
 8.2 電源投入時(初期設定)とﾊﾞｯｸｱｯﾌﾟからの復帰の見分け方
 8.3 ﾚｼﾞｽﾀR-S1～R-Wの書き替え方法
 8.4 ﾚｼﾞｽﾀR-S1～R-Wの読み出し方法
 8.5 割り込み･ﾊﾟﾙｽ出力の設定方法
 8.6 ﾃﾞｰﾀﾌﾟﾛﾃｸﾄの設定/解除方法
 8.7 30秒ADJﾋﾞｯﾄの書き込み方法
 8.8 ｽﾀﾝﾊﾞｲ遷移と電源回路例
 8.9 ﾏｲｺﾝとの接続の注意
9.参考ﾃﾞｰﾀ
 9.1 周波数温度特性例(周波数安定度(時計精度)の求め方)
 9.2 周波数電圧特性
 9.3 消費電流電圧特性
10. 外形図
11. 表示方法
12. 使用上の注意事項


概要と特徴

1. 概要と特徴

■ 概要

 本ﾓｼﾞｭｰﾙは水晶振動子を内蔵した、ﾏｲｺﾝ直結可能なﾘｱﾙ･ﾀｲﾑ･ｸﾛｯｸで、時刻、ｶﾚﾝﾀﾞｰ機能の他にｱﾗｰﾑ割り込み、基準信号出力他、多彩な機能を有する時刻精度調整不要なﾓｼﾞｭｰﾙです。

 ﾌｧｸｼﾐﾘ、多機能電話、ﾊﾟｰｿﾅﾙ･ｺﾝﾋﾟｭｰﾀ、ﾜｰﾌﾟﾛ、ｼｰｹﾝｻ等、時間管理を要する機器には、欠かせないﾓｼﾞｭｰﾙです。

 ■ 特徴

◆ | 水晶振動子内蔵で無調整、合理化可能
◆ | CPUと直結可能 (ｱｸｾｽ･ﾀｲﾑ120nsec)
◆ | 68系E端子、85系ALE端子対応
◆ | 時刻(時･分･秒)、ｶﾚﾝﾀﾞｰ(年･月･日･曜日)のｶｳﾝﾀｰ内蔵
◆ | 秒～月、曜日のｱﾗｰﾑ機能
◆ | 周期的な割り込み機能 (定周期出力波形)
◆ | 計時範囲選択可能
◆ | ﾀｲﾑ･ﾚｼﾞｽﾀとｱﾗｰﾑ･ﾚｼﾞｽﾀの照合範囲を設定可能
◆ | 未使用ﾋﾟｯﾄをRAMとして(最大17×4ﾋﾟｯﾄ)使用可能
◆ | 30秒補正、STOP/START、RESET機能
◆ | ﾃﾞｰﾀ･ﾌﾟﾛﾃｸﾄ機能 (ﾊﾞｯｸｱｯﾌﾟ機能)
◆ | C-M0Sﾃﾞﾊﾞｲｽによる低消費電流
◆ | 汎用SMD ICと同等のﾊﾝﾀﾞ付け条件で実装可能

機種 | 対応CPU | ﾊﾟｯｹｰｼﾞ
RTC-63421 | 80系 | DlP18ﾋﾟﾝ
RTC-63421M | 68系 | DlP18ﾋﾟﾝ
RTC-63423 | 80/68系切替え | SOP24ﾋﾟﾝ
参考: MSM6512とﾋﾟﾝ及び機能ｺﾝﾊﾟﾁﾌﾞﾙ


端子接続と回路構成

2. 端子接続と回路構成

■ 端子接続

● RTC-63421/M | ● RTC-63423
 | ( )内は68系選択時
NCはVDDと同電位ですが、ﾀﾄ部接続しないで下さい。

 ■ 回路構成


端子機能

3. 端子機能

■ 端子機能
端子番号 | 端子記号(名称) | 入出力 | 機能
63421 | 63421M | 63423
11～14 11～14 14, 15, 16, 18 D3～0 (Data Bus) 双方向 ﾏｲｺﾝのﾃﾞｰﾀ･ﾊﾞｽに接続し、ﾚｼﾞｽﾀの読み書きに用います。
共通 |  | 80系 |  | 68系 |  | D3～0のﾓｰﾄﾞ
CS1 | /CS0 | /RD | /WR | E | R/W
H | L | L | H | H | H | 出力ﾓｰﾄﾞ (読み出しﾓｰﾄﾞ)
H | L | H | L | H | L | 入力ﾓｰﾄﾞ (書き込みﾓｰﾄﾞ)
L | - | - | - | - | - | ﾊｲ･ｲﾝﾋﾟｰﾀﾞﾝｽ (ﾃﾞｰﾀ保護ﾓｰﾄﾞ)
- | H | - | - | - | -
4～7 | 4～7 | 5, 7, 9, 10 | A3～0 (Address) | 入力 | ﾏｲｺﾝのｱﾄﾞﾚｽ･ﾊﾞｽに接続し、RTCのﾚｼﾞｽﾀ(ｱﾄﾞﾚｽ)選択に用います。85系で使用する場合は、次項のALEと組み合わせて用います。
3 3 4 ALE (Address Latch Enable) 入力 ｱﾄﾞﾚｽ及びCS0を読み込む端子です。
ALE | ｱﾄﾞﾚｽ及びCS0の状態
H | RTC内に続み込まれ、ｱﾄﾞﾚｽが設定されます。
L | RTC内に(ALEの立ち下がりで)保持されます。
ALE端子を持たないﾏｲｺﾝの場合には、RTCのALE端子を"H"に固定して用います。
10 - 13 /WR (Write) 入力 A3～0で指定されたﾚｼﾞｽﾀにD3～0のﾃﾞｰﾀを/WRの立ち上がりで書き込みます。/RD, /WRの同時Lは禁止です。
8 - 11 /RD (Read) 入力 A3～0で指定されたﾚｼﾞｽﾀよりﾃﾞｰﾀ内容を/RD=Lの間中D3～0に出力します。/RD, /WRの同時Lは禁止です。
- 10 13 R/W (Read / Write) 入力 指定されたﾚｼﾞｽﾀのﾃﾞｰﾀを次項のE端子と組み合わせて読み書きします。
R/W | ﾓｰﾄﾞ | 内容
H | READ | 指定されたﾚｼﾞｽﾀよりﾃﾞｰﾀ内容をE=Hの間中D3～0に出力します。
L | WRITE | 指定されたﾚｼﾞｽﾀにﾃﾞｰﾀをEの立ち下がりで書き込みます。
- 8 10 E (Enable) 入力 A3～0で指定されたﾚｼﾞｽﾀのﾃﾞｰﾀを読み書きする際、前項のR/W端子と組み合わせて使用します。
15, 2 | 15, 2 | 19, 2 | CS1･/CS0 (Chip Select) | 入力 | CS1=H, /CS0=Lの時のみALE, /RD, /WRまたはR/W, Eを有効にします。80系の場合、/CS0はALEと関連動作が必要です。CS1は電源電圧検出用として用います。CS1=LにするとSTOPﾋﾞｯﾄ及びRESETﾋﾞｯﾄは自動的にﾘｾｯﾄ(=0)されます。
1 1 1 INTERRUPT 出力 N-chｵｰﾌﾟﾝ･ﾄﾞﾚｲﾝで割り込み発生時にﾏｲｺﾝに割り込み要求(=L)を行う端子です。
機種 | 割り込みﾓｰﾄﾞ | 備考
63421 / 63421M | 定周期及びｱﾗｰﾑ割り込み | 定周期及びｱﾗｰﾑ割り込みがOR論理をとって出力されます。
63423 | 定周期割り込み | ｱﾗｰﾑ割り込みは次項のｱﾗｰﾑ端子より出力します。
CS1･/CS0により出力が禁止されることはありません。
- - 3 ALARM 出力 N-chｵｰﾌﾟﾝ･ﾄﾞﾚｲﾝでｱﾗｰﾑ発生時にﾏｲｺﾝに割り込み要求(=L)を行う端子です。CS1･/CS0により出力が禁止されることはありません。
- - 17 1Hz 出力 ﾃﾞｭｰﾃｨ50%のﾊﾟﾙｽを出力します。時計精度確認用として用いることができます。CS1･/CS0により出力が禁止されることはありません。
注意:
① | 時計ｶｳﾝﾀの1秒出力であるためRESET及び30秒ADJを行うと1Hz出力はLﾚﾍﾞﾙにｸﾘｱされます。また、STOPを行うと1Hz出力は、その時点のﾚﾍﾞﾙで停止します。
② | C-MOS出力となっていますので、本出力に負荷が接続されていますとｽﾀﾝﾊﾞｲ時であっても消費電流が増加(電池が消耗)します。
- - 6 30秒ADJ (30秒補正) 出力 ﾊｰﾄﾞｳｪｱにより30秒補正させる端子でHの立ち上がりで補正されます。HD/SFTﾋﾞｯﾄにより、本端子かｿﾌﾄｳｪｱの30秒ADJﾋﾞｯﾄを選択することができます。
補正前の秒桁の状態 | 補正後の秒桁の状態 | 条件
29秒以下 | 1分桁の桁上げ無しの00秒 | HD/SFT=1
30秒以上 | 1分桁の桁上げ有りの00秒
HD/SFTﾋﾞｯﾄ=0を選択する場合は、本端子をGNDに接続して下さい。
- - 20 STOP / START 出力 ﾊｰﾄﾞｳｪｱにより計時をｽﾄｯﾌﾟまたはｽﾀｰﾄさせる端子です。HD/SFTﾋﾞｯﾄにより、本端子かｿﾌﾄｳｪｱのSTOPﾋﾞｯﾄを選択することができます。
STOP/START | 計時 | 条件
H | 4096Hz以降のｶｳﾝﾄｱｯﾌﾟ停止 | HD/SFT=1
L | 計時開始
HD/SFTﾋﾞｯﾄ=0を選択する場合は、本端子をGNDに接続して下さい。
- - 8 68/80 入力 RTCを68系用として用いるか、80系として用いるかを選択する端子です。
68/80 | 対応CPU | ﾋﾟﾝ番号
 |  | 11 | 13
H | 68系 | E | R/W
L | 80系 | /RD | /WR
18 18 24 VDD
電源に接続します。電源投入時及びﾊﾞｽ･ｱｸｾｽ時には5V±10%の電圧を供給し、ﾊﾞｯﾃﾘｰ･ﾊﾞｯｸｱｯﾌﾟ時は、2V以上の電圧を供給します。
9 9 12 GND
ｸﾞﾗﾝﾄﾞに接続します。
16, 17 16, 17 22, 23 NC
VDDと内部接続されています。ｵｰﾌﾟﾝ状態で使用して下さい。
- - 21 NC
未接続端子です。GNDに接続して使用して下さい。


特性

4. 特性

■ 4.1 絶対最大定格

項目 | 記号 | 条件 | 仕様 | 単位
電源電圧 | VDD | Ta=25℃ | -0.3～7.0 | V
入力電圧 | Vin | Ta=25℃ | GND-0.3～VDD+0.3
保存温度 | TSTG | RTC63421･RTC63421M | -55～+85 | ℃
 |  | RTC63423 | -55～+125
ﾊﾝﾀﾞ付け条件 | TSOL | RTC63421･RTC63421M | ﾘｰﾄﾞ部:260℃以下×10秒以内、ﾊﾟｯｹｰｼﾞ部:150℃以下
 |  | RTC63423 | 260℃以下×10秒以内×2回以内、または230℃以下×3分以内

■ 4.2 動作条件
項目 | 記号 | 条件 | 仕様 | 単位
電源電圧 VDD
4.5～5.5 V
動作温度 VOPR 注1 -40～+85 ℃
ﾃﾞｰﾀ保持電圧 | VOH | 注2 | 2.0～6.0 | V
注1: | RTC-63421MとRTC-63423の68/80端子=H時のｽｨｯﾁﾝｸﾞ特性保証温度は0℃～70℃
注2: | RTC外部とのｲﾝﾀｰﾌｪｰｽは保証しないが、RTCの内部計時及びRAMﾃﾞｰﾀを保証する電源電圧

■ 4.3 周波数特性･消費電流特性
項目 | 記号 | 条件 | 仕様 | 単位
周波数精度 | Δf/f0 | Ta=25℃ VDD=5V | 63421A / 63421MA | +15/-5 (5±10) | ppm
63421A / 63421MB | +55/-45 (5±50)
63423A | +25/-15 (5±20)
63423 | +55/-45 (5±50)
周波数温度特性
-10～+70℃ (25℃基準) +10/-120
-30～+85℃ (25℃基準) | +10/-220
ｴｰｼﾞﾝｸﾞ量 | fa | Ta=25℃ VDD=5V 初年度 | ±5 max | ppm/y
耐衝撃性 S.R. 硬木上75cm×3回又は3000G×0.3ms×1/2sin波×3方向 ±10 max
消費電流 | IDD1 | CS1=0V | VDD=5V | 30 max | μA
IDD2 | VDD=2V | 1.8 max
注意: 特記なき場合、特性値は動作温度、動作電圧範囲内での規格です。

■ 4.4 電気的特性 (VDD=5V±0.5V、Ta=-40～+85℃)
項目 記号 条件 MIN TYP MAX 単位 適用端子
H入力電圧(1) VIH1
2.2 - - V STOP/START, 68/80, CS1を除く全入力
L入力電圧(1) VIL1 - - 0.8
H入力電圧(2) VIH2 VDD=2～5.5V 4/5VDD - - STOP/START, 68/80, CS1
L入力電圧(2) VIL2 - - 1/5VDD
入力ﾘｰｸ電流(1) ILK1 Vi=0V/VDD -1 - 1 μA D3～0, STOP/START以外の入力
入力ﾘｰｸ電流(2) ILK2 -10 - 10 D3～0, STOP/START
H入力電流 IHLK VIH=0.8VDD -100 - -20 STOP/START
L入力電流 ILLK VIH=0.2VDD 20 - 100
H出力電圧 VOH IOH=-400μA 2.4 - - V D3～0, 1Hz
L出力電圧(1) VOL1 IOL=2.5mA - - 0.4
L出力電圧(2) VOL2 - - 0.4 ALARM, INTERRUPTｵｰﾌﾟﾝ･ﾄﾞﾚｲﾝ出力
OFFﾘｰｸ電流 IOFLK Vi=0V/VDD - - 10 μA
入力容量(1) Ci1 入力周波数 1MHz - 3 - pF D3～0以外の入力
入力容量(2) Ci2 - 5 - D3～0
発振開始時間 TOSC Ta=25℃ VDD≧4.5V - - 1 sec INTERRUPT=1024Hzで測定


ｽｨｯﾁﾝｸﾞ特性

5. ｽｨｯﾁﾝｸﾞ特性

■ 5.1 80系 (ALE使用時) (VDD=5V±0.5V、Ta=-40～+85℃)
項目 記号 条件 MIN MAX 単位
CS1ｾｯﾄｱｯﾌﾟ時間 t C1S
1000 - ns
ｱﾄﾞﾚｽ･ｾｯﾄｱｯﾌﾟ時間 t AS
25 -
ｱﾄﾞﾚｽ･ﾎｰﾙﾄﾞ時間 t AH
25 -
ALEﾊﾟﾙｽ幅 t AW
40 -
ALE↓から/WR↓時間 t ALW
10 -
ALE↓から/RD↓時間 t ALR
10 -
/WR↑からALE↑時間 t WAL
20 -
/RD↑からALE↑時間 t RAL
20 -
/WRﾊﾟﾙｽ幅 t WW
120 -
/RD↓からﾃﾞｰﾀ遅延時間 t RD CL=150pF - 120
/RD↑からﾃﾞｰﾀ･ﾎｰﾙﾄﾞ時間 t DR
10 45
/WR↑からﾃﾞｰﾀ･ｾｯﾄｱｯﾌﾟ時間 t DS
100 -
/WR↑からﾃﾞｰﾀ･ﾎｰﾙﾄﾞ時間 t DH
10 -
CS1ﾎｰﾙﾄﾞ時間 t C1H
1000 -
/RD･/WRﾘｶﾊﾞﾘ時間 t ACV
100 -

■ 5.2 80系 (ALE=VDD固定時) (VDD=5V±0.5V、Ta=-40～+85℃)
項目 記号 条件 MIN MAX 単位
CS1ｾｯﾄｱｯﾌﾟ時間 t C1S
1000 - ns
/WR↓のｱﾄﾞﾚｽ･ｾｯﾄｱｯﾌﾟ時間 t AW
20 -
/WR↑のｱﾄﾞﾚｽ･ﾎｰﾙﾄﾞ時間 t WA
10 -
/RD↓のｱﾄﾞﾚｽ･ｾｯﾄｱｯﾌﾟ時間 t AR
20 -
/RD↑のｱﾄﾞﾚｽ･ﾎｰﾙﾄﾞ時間 t RA
20 -
/WRﾊﾟﾙｽ幅 t WW
120 -
/RD↓からﾃﾞｰﾀ遅延時間 t RD CL=150pF - 120
/RD↑からﾃﾞｰﾀ･ﾎｰﾙﾄﾞ時間 t DR
10 45
/WR↑からﾃﾞｰﾀ･ｾｯﾄｱｯﾌﾟ時間 t DS
100 -
/WR↑からﾃﾞｰﾀ･ﾎｰﾙﾄﾞ時間 t DH
10 -
CS1ﾎｰﾙﾄﾞ時間 t C1H
1000 -
/RD･/WRﾘｶﾊﾞﾘ時間 t ACV
100 -

■ 5.3 68系 (VDD=5V±0.5V、Ta=0～+70℃)
項目 記号 条件 MIN MAX 単位
R/W･ｱﾄﾞﾚｽ･ｾｯﾄｱｯﾌﾟ時間 t RWE
100 - ns
E Highﾊﾟﾙｽ幅 t EHW
220 -
R/W･ｱﾄﾞﾚｽ･ﾎｰﾙﾄﾞ時間 t ERW
20 -
E Lowﾊﾟﾙｽ幅 t ELW
220 -
Eｻｲｸﾙ時間 t EC
500 -
ﾃﾞｰﾀ･ｾｯﾄｱｯﾌﾟ時間 t DS
180 -
ﾃﾞｰﾀ･ﾎｰﾙﾄﾞ時間 t DH
20 -
Eからﾃﾞｰﾀ遅延時間 t RD CL=150pF 120 -
Eからﾃﾞｰﾀ･ﾎｰﾙﾄﾞ時間 t ED
10 -

■ ﾃﾞｰﾀ保持ﾀｲﾐﾝｸﾞ


ﾚｼﾞｽﾀ

6. ﾚｼﾞｽﾀ

■ 6.1 ﾚｼﾞｽﾀ･ﾃｰﾌﾞﾙ

ｱﾄﾞﾚｽ | A3～0 | BANK0 |  |  |  |  |  | BANK1
 |  | ﾚｼﾞｽﾀ記号 | D3 | D2 | D1 | D0 | 時刻ﾚｼﾞｽﾀ名 | ﾚｼﾞｽﾀ記号 | D3 | D2 | D1 | D0 | ｱﾗｰﾑ･ﾚｼﾞｽﾀ名
0 | 0000 | R-S1 | r-s8 | r-s4 | r-s2 | r-s1 | 1秒桁ﾚｼﾞｽﾀ | A-S1 | a-s8 | a-s4 | a-s2 | a-s1 | 1秒桁ﾚｼﾞｽﾀ
1 | 0001 | R-S10 | * | r-s40 | r-s20 | r-s10 | 10秒桁ﾚｼﾞｽﾀ | A-S10 | * | a-s40 | a-s20 | a-s10 | 10秒桁ﾚｼﾞｽﾀ
2 | 0010 | R-MI1 | r-mi8 | r-mi4 | r-mi2 | r-mi1 | 1分桁ﾚｼﾞｽﾀ | A-MI1 | a-mi8 | a-mi4 | a-mi2 | a-mi1 | 1分桁ﾚｼﾞｽﾀ
3 | 1100 | R-MI10 | * | r-mi40 | r-mi20 | r-mi10 | 10分桁ﾚｼﾞｽﾀ | A-MI10 | * | a-mi40 | a-mi20 | a-mi10 | 10分桁ﾚｼﾞｽﾀ
4 | 0100 | R-H1 | r-h8 | r-h4 | r-h2 | r-h1 | 1時桁ﾚｼﾞｽﾀ | A-H1 | a-h8 | a-h4 | a-h2 | a-h1 | 1時桁ﾚｼﾞｽﾀ
5 | 0101 | R-H10 | * | r-PM/AM | r-h20 | r-h10 | 10時桁ﾚｼﾞｽﾀ | A-H10 | * | a-PM/AM | a-h20 | a-h10 | 10時桁ﾚｼﾞｽﾀ
6 | 0110 | R-D1 | r-d8 | r-d4 | r-d2 | r-d1 | 1日桁ﾚｼﾞｽﾀ | A-D1 | a-d8 | a-d4 | a-d2 | a-d1 | 1日桁ﾚｼﾞｽﾀ
7 | 0111 | R-D10 | * | * | r-d20 | r-d10 | 10日桁ﾚｼﾞｽﾀ | A-D10 | * | * | a-d20 | a-d10 | 10日桁ﾚｼﾞｽﾀ
8 | 1000 | R-MO1 | r-mo8 | r-mo4 | r-mo2 | r-mo1 | 1月桁ﾚｼﾞｽﾀ | A-MO1 | a-mo8 | a-mo4 | a-mo2 | a-mo1 | 1月桁ﾚｼﾞｽﾀ
9 | 1001 | R-MO10 | * | * | * | r-mo10 | 10月桁ﾚｼﾞｽﾀ | A-MO10 | * | * | * | a-mo10 | 10月桁ﾚｼﾞｽﾀ
A | 1010 | R-Y1 | r-y8 | r-y4 | r-y2 | r-y1 | 1年桁ﾚｼﾞｽﾀ | A-W | * | a-w4 | a-w2 | a-w1 | 週ﾚｼﾞｽﾀ
B | 1011 | R-Y10 | r-y80 | r-y40 | r-y20 | r-y10 | 10年桁ﾚｼﾞｽﾀ | A-ENB | ae8 | ae4 | ae2 | ae1 | 範囲ﾚｼﾞｽﾀ
C | 1100 | R-W | * | r-w4 | r-w2 | r-w1 | 週ﾚｼﾞｽﾀ | C-C' | * | * | TEST2 | TEST1 | ﾃｽﾄ･ﾚｼﾞｽﾀ
D | 1101 | C-D | IT/PLS2 | IT/PLS1 | MASK2 | MASK1 | 制御ﾚｼﾞｽﾀD | C-D' | * | CY2 | CY1 | CY0 | 制御ﾚｼﾞｽﾀD'
E | 1110 | C-E | IRQ FLAG0 | RESET | IRQ FLAG2 | IRQ FLAG1 | 制御ﾚｼﾞｽﾀE | C-E' | HD/SFT | 24/12 | CAL | D.P. | 制御ﾚｼﾞｽﾀE'
F | 1111 | C-F | BANK1/0 | STOP | 30秒ADJ | READ FLAG | 制御ﾚｼﾞｽﾀF | C-F' | BANK1/0 | STOP | 30秒ADJ | READ FLAG | 制御ﾚｼﾞｽﾀF'

■ 6.2 注意事項

① | 正論理でﾃﾞｰﾀﾊﾞｽの"H"がﾚｼﾞｽﾀ内で"1"に相当します。
② | 時計として有り得ないﾃﾞｰﾀ設定は、計時ﾐｽの原因となりますので、設定しないで下さい。
③ | 電源投入時(初期設定前)の各ﾋﾞｯﾄの状態は不定です。書き込みを行い、値を設定して下さい。

■ 6.3 ﾘｱﾙﾀｲﾑ、ｱﾗｰﾑ･ﾚｼﾞｽﾀ
① *印はﾘｱﾙﾀｲﾑ･ﾚｼﾞｽﾀ及ぴｱﾗｰﾑ･ﾚｼﾞｽﾀとして用いる場合、読み出し時のﾃﾞｰﾀは"0"となります。しかし、RAMとして用いる場合は読み書きできます。
の部分がRAMとして使用可能な部分です。
② | ﾘｱﾙﾀｲﾑ、ｱﾗｰﾑ･ﾚｼﾞｽﾀともBCDｺｰﾄﾞです。
③ 週桁はﾘｱﾙﾀｲﾑ、ｱﾗｰﾑ･ﾚｼﾞｽﾀともｺｰﾄﾞ化して使用します。
例:
ﾃﾞｰﾀ | 0 | 1 | 2 | 3 | 4 | 5 | 6
曜日 | 日 | 月 | 火 | 水 | 木 | 金 | 土
④ | PM/AMﾋﾞｯﾄはﾘｱﾙﾀｲﾑ･ﾚｼﾞｽﾀ及ぴｱﾗｰﾑ･ﾚｼﾞｽﾀのr-PM/AM、a-PM/AMとも"1"でPM、"0"でAMとなります。
⑤ | RAMとして選択できるﾋﾞｯﾄは最大R-D1～R-Y10(4bit×6)とA-S1～A-W(4bit×11)の4bit×17です。

■ 6.4 ｺﾝﾄﾛｰﾙ･ﾚｼﾞｽﾀ･ﾋﾞｯﾄの役割

ﾋﾞｯﾄ名 | 役割
MASK1 | MASK1=1で定周期出力を禁止します。
MASK2 | MASK2=1でｱﾗｰﾑ出力を禁止します。
IT/PLS1 | IT/PLS1=1で定周期割り込みﾓｰﾄﾞ、IT/PLS1=0で定周期ﾊﾟﾙｽ･ﾓｰﾄﾞとなります。
IT/PLS2 | IT/PLS2=1でｱﾗｰﾑ割り込みﾓｰﾄﾞ、IT/PLS2=0でｱﾗｰﾑ･ﾊﾟﾙｽ･ﾓｰﾄﾞとなります。
IRQ FLAG1 | 定周期出力ﾀｲﾐﾝｸﾞで"1"になります。IRQ FLAG1をを読み書きすることにより、解除できます。
IRQ FLAG2 | ｱﾗｰﾑ出力ﾀｲﾐﾝｸﾞで"1"になります。IRQ FLAG2を読み書きすることにより、解除できます。
RESET | RESET=1で秒未満のｶｳﾝﾀをﾘｾｯﾄします。
IRQ FLAG0 | 割り込みｸﾘｱ禁止区間(割り込み発生ﾀｲﾐﾝｸﾞ後122μs)は"1"になります。
READ FLAG | 時刻ﾃﾞｰﾀを読み出す際に用い、1秒桁の桁上げ時に"1"になります。
30秒ADJ | 30秒ADJ=1で30秒補正がされます。
STOP | STOP=1で4096Hz以降の計時が止り、STOP=0で再開します。
BANK1/0 | BANK1/0=1でBANK1が選択され、BANK1/0=0でBANK0が選択されます。
TEST1,2 | ﾒｰｶｰ試験用ﾋﾞｯﾄで、必ずTEST1,2=0に設定して下さい。
CY0,1,2 | ﾊﾟﾙｽ･ﾓｰﾄﾞの周期の設定に用います。
D.P. | D.P.=1でﾃﾞｰﾀを保護します。読み出しを継続する場合はD.P.=1にしておきます。
CAL | ｶｸﾝﾀのｶｳﾝﾄｱｯﾌﾟ範囲を決めます。CAL=1でR-S1～R-Y10とR-W、CAL=0でR-S1～R-H10とR-W。
24/12 | 24/12=1で24時間制、24/12=0で12時間制となります。
HD/SFT | 30秒ADJとSTOP/START機能のﾊｰﾄﾞｳｪｱ(HD/SFT=1)、ｿﾌﾄｳｪｱ(HD/SFT=0)のどちらを使うかを決めます。(63423のみ)

■ 6.5 定周期及びｱﾗｰﾑ出力ﾓｰﾄﾞの設定とﾀｲﾐﾝｸﾞ

◆ 定周期出力ﾓｰﾄﾞの設定
ﾓｰﾄﾞ | MASK1 | IT/PLS1 | IRQ FLAG1 | INTERRUPT端子 | 出力ﾀｲﾐﾝｸﾞ設定ﾋﾞｯﾄ
定周期ﾊﾟﾙｽ･ﾓｰﾄﾞ | 0 | 0 | 周期ﾀｲﾐﾝｸﾞで1 | 周期ﾀｲﾐﾝｸﾞで0 | CY3～0 (1024Hz～10分)
定周期割り込みﾓｰﾄﾞ | 0 | 1
定周期出力の禁止 | 1 | Ｘ | 0 | OPEN

 RTC-63421/63421Mの場合、INTERRUPT端子にはｱﾗｰﾑ出力とORされたﾃﾞｰﾀが出力されますが、便宜上どちらか1つの出力を記載します。

 ◆ 定周期ﾊﾟﾙｽ･ﾓｰﾄﾞ時 (IT/PLS1=0)

◆ 定周期割り込みﾓｰﾄﾞ時 (IT/PLS1=1)

◆ ｱﾗｰﾑ出力ﾓｰﾄﾞの設定
ﾓｰﾄﾞ | MASK2 | IT/PLS2 | IRQ FLAG2 | 出力端子 注 | 出力ﾀｲﾐﾝｸﾞ設定ﾋﾞｯﾄ
ｱﾗｰﾑ･ﾊﾟﾙｽ･ﾓｰﾄﾞ | 0 | 0 | ｱﾗｰﾑﾀｲﾐﾝｸﾞで1 | ｱﾗｰﾑﾀｲﾐﾝｸﾞで0 | A-ENBとA-S1からA-W
ｱﾗｰﾑ割り込みﾓｰﾄﾞ | 0 | 1
ｱﾗｰﾑ出力の禁止 | 1 | Ｘ | 0 | OPEN
注: RTC-63421/63421MはINTERRUPT端子、RTC-63423はALARM端子。

RTC-63421/63421Mの場合、INTERRUPT端子にはｱﾗｰﾑ出力とORされたﾃﾞｰﾀが出力されますが、便宜上どちらか1つの出力を記載します。

 ◆ ｱﾗｰﾑ･ﾊﾟﾙｽ･ﾓｰﾄﾞ時 (IT/PLS2=0)

◆ ｱﾗｰﾑ割り込みﾓｰﾄﾞ時 (IT/PLS2=1)

■ 6.6 定周期及びｱﾗｰﾑ出力ﾓｰﾄﾞのﾘｾｯﾄ(復帰)とﾀｲﾐﾝｸﾞ

◆ 定周期出力ﾓｰﾄﾞのﾘｾｯﾄ(復帰)
ﾓｰﾄﾞ | D.P. | IRQ FLAG0 | IRQ FLAG1 | IRQ FLAG1の結果 | INTERRUPT端子
定周期ﾊﾟﾙｽ･ﾓｰﾄﾞ (MASK1=0、IT/PLS1=0) | 0 | 0のまま | 0を書き込み | 書き込み後即ﾘｾｯﾄ (1→0) | 書き込み後即ﾘｾｯﾄ (L→OPEN)
 | 1 | 0のまま | 書き込みできず | 設定周期により自動復帰 | 設定周期により自動復帰
 | Ｘ | 0のまま | 書き込み無し | 設定周期により自動復帰 | 設定周期により自動復帰
定周期割り込みﾓｰﾄﾞ (MASK1=0、IT/PLS1=1) | 0 | 0のまま | 読み出し | 読み出し後即ﾘｾｯﾄ (1→0) | 読み出し後即ﾘｾｯﾄ (L→OPEN)
 | 1 | 発生後122μs間1 | 読み出し | 周期ﾀｲﾐﾝｸﾞ後122μs間1 | 周期ﾀｲﾐﾝｸﾞ後122μs間L
 | Ｘ | 0のままか122μs間1 | 読み出し無し | ﾘｾｯﾄされないため次回割り込み無し | ﾘｾｯﾄされないため次回割り込み無し

◆ ｱﾗｰﾑ出力ﾓｰﾄﾞのﾘｾｯﾄ(復帰)
ﾓｰﾄﾞ | D.P. | IRQ FLAG0 | IRQ FLAG1 | IRQ FLAG1の結果 | INTERRUPTまたはALARM端子 注
ｱﾗｰﾑ･ﾊﾟﾙｽ･ﾓｰﾄﾞ (MASK2=0、IT/PLS2=0) | 0 | 0のまま | 0を書き込み | 書き込み後即ﾘｾｯﾄ (1→0) | 書き込み後即ﾘｾｯﾄ (L→OPEN)
 | 1 | 0のまま | 書き込みできず | ｱﾗｰﾑ･ﾀｲﾐﾝｸﾞ後61μsで自動復帰 | ｱﾗｰﾑ･ﾀｲﾐﾝｸﾞ後61μsで自動復帰
 | Ｘ | 0のまま | 書き込み無し | ｱﾗｰﾑ･ﾀｲﾐﾝｸﾞ後61μsで自動復帰 | ｱﾗｰﾑ･ﾀｲﾐﾝｸﾞ後61μsで自動復帰
定周期割り込みﾓｰﾄﾞ (MASK2=0、IT/PLS2=1) | 0 | 0のまま | 読み出し | 読み出し後即ﾘｾｯﾄ (1→0) | 読み出し後即ﾘｾｯﾄ (L→OPEN)
 | 1 | 発生後122μs間1 | 読み出し | ｱﾗｰﾑ･ﾀｲﾐﾝｸﾞ後122μs間1 | ｱﾗｰﾑ･ﾀｲﾐﾝｸﾞ後122μs間1
 | Ｘ | 0のままか122μs間1 | 読み出し無し | ﾘｾｯﾄされないため次回割り込み無し | ﾘｾｯﾄされないため次回割り込み無し
注: RTC-63421/63421MはINTERRUPT端子、RTC-63423はALARM端子。

◆ ﾊﾟﾙｽ･ﾓｰﾄﾞ時 (IT/PLS1,2=0)

自動復帰までの時間
定周期ﾊﾟﾙｽ･ﾓｰﾄﾞ | 設定した周期ﾀｲﾐﾝｸﾞ
ｱﾗｰﾑ･ﾊﾟﾙｽ･ﾓｰﾄﾞ | 61μs後
◆ 割り込みﾓｰﾄﾞ時 (IT/PLS1,2=1)

D.P.=1ではIRQFLAG1,2への書き込みができませんので、ﾊﾟﾙｽ･ﾓｰﾄﾞでの復帰は自動復帰のみとなります。
◆ D.P.=1での割り込みﾓｰﾄﾞ時 (IT/PLS1,2=1)


ﾚｼﾞｽﾀ説明

7. ﾚｼﾞｽﾀ説明

7.1 時刻･ｶﾚﾝﾀﾞ･ﾚｼﾞｽﾀ

 この関係のﾚｼﾞｽﾀには、R-S1, R-R10, R-MI1, R-MI10, R-H1, R-H10, R-D1, R-D10, RMO1, R-MO10, R-Y1, R-Y10, R-Wがあります。R-Wを除く、これらのﾚｼﾞｽﾀ値は正論理のBCDｺｰﾄﾞです。

 ■ R-W (週ﾚｼﾞｽﾀ)

 ｺｰﾄﾞ化して使用します。尚、年月日からの曜日判定は行っていませんので、曜日を必要とする場合は設定が必要です。
例:
ﾃﾞｰﾀ | 0 | 1 | 2 | 3 | 4 | 5 | 6
曜日 | 日 | 月 | 火 | 水 | 木 | 金 | 土

 ■ R-H1,R-H10 (時ﾚｼﾞｽﾀ)

24時間制/12時間制(C'Eﾚｼﾞｽﾀ)の設定により、存在し得る時間が異なります。また、12時間制を設定した場合は、r-PM/AMの設定が必要になります。24時間制を設定すると、r-PM/AMﾋﾞｯﾄは自動的に0になります。
24/12ﾋﾞｯﾄ | 存在し得る時間
0 (12時間制) | AM及びPM 12時00分～11時59分
1 (24時間制) | 00時00分～23時59分

 ■ R-Y1,R-Y10 (年ﾚｼﾞｽﾀ)

基本的には西暦専用ですが、平成年号においても閏年は自動判別されます。年が4の倍数であれば閏年と判定します。

 ■ ﾘｱﾙﾀｲﾑ･ﾚｼﾞｽﾀのRAM領域

 CAL(CEﾚｼﾞｽﾀ)=0に設定するとR-D1, R-D10, R-MO1, R-MO10, R-Y1, R-Y10をRAM領域として使用することができます。これらのﾚｼﾞｽﾀをRAM領域として設定した場合は、一覧表の*のﾋﾞｯﾄも読み書きが可能となります。

 ■ 注意事項

◆ | ﾘｱﾙﾀｲﾑ･ﾚｼﾞｽﾀとして使用するﾚｼﾞｽﾀに存在しない時刻、ｶﾚﾝﾀﾞを設定しますと、計時ﾐｽとなります。
◆ | ﾘｱﾙﾀｲﾑ･ﾚｼﾞｽﾀとして使用した(CAL=1)場合の一覧表での*のﾋﾞｯﾄは、1を書き込んでも、読み出し時には自動的に0となります。

7.2 CDﾚｼﾞｽﾀ (ｺﾝﾄﾛｰﾙDﾚｼﾞｽﾀ)

■ MASK1 (D0)

 時計ｶｳﾝﾀの桁上げをﾄﾘｶﾞにした定周期出力を制御するﾋﾞｯﾄで、周期はCY2, CY1, CY0で設定します。
MASK1と定周期出力の関係
MASK1 | IT/PLS1 | INTERRUPT端子 | 備考
0 | 1 | 定周期割り込みﾓｰﾄﾞ | 周期はCY2, CY1, CY0で設定します。
 | 0 | 定周期ﾊﾟﾙｽ･ﾓｰﾄﾞ
1 | × | OPEN

 ■ MASK2 (D1)

 ｱﾗｰﾑ指定日時と時計ｶｳﾝﾀの一致をﾄﾘｶﾞとしたｱﾗｰﾑ出力を制御するﾋﾞｯﾄで、ｱﾗｰﾑ指定はA･ENBﾚｼﾞｽﾀで設定します。
MASK2とｱﾗｰﾑ出力の関係
MASK2 | IT/PLS2 | INTERRUPTまたはALARM端子 | 備考
0 | 1 | ｱﾗｰﾑ割り込みﾓｰﾄﾞ | RTC63421(M)のｱﾗｰﾑ出力はINTERRUPT端子から、RTC63423はALARM端子から出力されます。
 | 0 | ｱﾗｰﾑ･ﾊﾟﾙｽ･ﾓｰﾄﾞ
1 | × | OPEN

 ■ IT/PLS1 (D2)

 定周期出力の出力ﾓｰﾄﾞを決めるﾋﾞｯﾄで、1で割り込みﾓｰﾄﾞ、0でﾊﾟﾙｽ･ﾓｰﾄﾞとなります。

 ■ IT/PLS2 (D3)

 ｱﾗｰﾑ出力の出力ﾓｰﾄﾞを決めるﾋﾞｯﾄで、1で割り込みﾓｰﾄﾞ、0でﾊﾟﾙｽ･ﾓｰﾄﾞとなります。

 7.3 CEﾚｼﾞｽﾀ (ｺﾝﾄﾛｰﾙEﾚｼﾞｽﾀ)

■ IRQFLAG1 (D0)

 IRQFLAG1ﾋﾞｯﾄは定周期出力のINTERRUPT出力と同期しており、次の関係があります。
IRQFLAG1 | INTERRUPT出力
1 | L
0 | OPEN
IRQFLAG1ﾋﾞｯﾄの操作でINTERRUPT出力のﾘｾｯﾄができますが、出力ﾓｰﾄﾞにより次のように操作が異なります。
IT/PLS1 | 操作 | IRQFLAG1 | 備考
1 (定周期割り込みﾓｰﾄﾞ) | IRQFLAG1の読み出し | 1→0 (ｸﾘｱ) | D.P.ﾋﾞｯﾄ=1の場合、割り込み発生後122μs間のﾘｾｯﾄ操作は122μs経過後にﾘｾｯﾄとなります。
0 (定周期ﾊﾟﾙｽ･ﾓｰﾄﾞ) | IRQFLAG1への0書き込み |  | 設定した周期ﾀｲﾐﾝｸﾞで自動復帰(ﾘｾｯﾄ)も行われます。

 ■ IRQFLAG2 (D1)

 IRQFLAG2ﾋﾞｯﾄはｱﾗｰﾑ出力で、RTC63421/63421MではINTERRUPT出力、RTC63423ではALARM出力と同期しており、次の関係があります。
IRQFLAG1 | INTERRUPTまたはALARM出力
1 | L
0 | OPEN
IRQFLAG2ﾋﾞｯﾄの操作でINTERRUPTまたはALARM出力のﾘｾｯﾄができますが、出力ﾓｰﾄﾞにより次のように操作が異なります。
IT/PLS2 | 操作 | IRQFLAG2 | 備考
1 (ｱﾗｰﾑ割り込みﾓｰﾄﾞ) | IRQFLAG2の読み出し | 1→0 (ｸﾘｱ) | D.P.ﾋﾞｯﾄ=1の場合、割り込み発生後122μs間のﾘｾｯﾄ操作は122μs経過後にﾘｾｯﾄとなります。
0 (ｱﾗｰﾑ･ﾊﾟﾙｽ･ﾓｰﾄﾞ) | IRQFLAG2への0書き込み |  | 発生後61μs後に自動復帰(ﾘｾｯﾄ)も行われます。

 ■ RESET (D2)

 秒未満のｶｳﾝﾀをﾘｾｯﾄするﾋﾞｯﾄで、RESET=1の間中ﾘｾｯﾄされ続けます。0を書き込むことで解除されます。CS1がH→Lで自動的に解除されます。

 ■ IRQFLAG0 (D3)

 D.P.ﾋﾞｯﾄ=1での割り込み出力の延長時間(122μs)を示すﾋﾞｯﾄで、この時間中1となります。ただし、IT/PLS1=1またはIT/PLS2=1の割り込みﾓｰﾄﾞでかつD.P.ﾋﾞｯﾄ=1の時のみで、その他の場合は常に0となります。

 7.4 CFﾚｼﾞｽﾀ (ｺﾝﾄﾛｰﾙFﾚｼﾞｽﾀ)

■ READ FLAG (D0)

 1秒桁の桁上げを示すﾋﾞｯﾄで、時刻ﾃﾞｰﾀを読み出す時に使用します。桁上げ発生時に1になり、本ﾋﾞｯﾄの読み出しで0(ﾘｾｯﾄ)となります。また、30秒補正時も1になります。通常、時刻ﾃﾞｰﾀ読み出し後に本ﾋﾞｯﾄを検査し、1ならば読み出し中に桁上げがあったことを意味するので、再度時刻ﾃﾞｰﾀを読み直します。

 ■ 30秒ADJ (D1)

 1を書き込むことで30秒補正を行います。
補正前の秒桁 | 補正後の結果
29秒以下 | 1分桁の桁上げ無しの00秒
30秒以上 | 1分桁の桁上げ有りの00秒
30秒ADJ=1設定後の125μs間はS1～Wﾚｼﾞｽﾀへのｱｸｾｽは禁止です。250μs後に自動復帰(=0)となりますので、30秒ADJ=0を確認後、ﾀｲﾑ･ﾚｼﾞｽﾀへのｱｸｾｽを行って下さい。R-D1～R-Y10をRAMとして使用している場合は、この限りではありません。30秒補正を行うと、READ FLAGも1となります。RTC63423で、ﾊｰﾄﾞｳｪｱによる30秒補正を行った場合にも本ﾋﾞｯﾄは1になります。

 ■ STOP (D2)

 1の書き込みで4096Hz以降の計時が停止し、0の書き込みで計時を再開します。RTC63423では、HD/SFTﾋﾞｯﾄ(C'EﾚｼﾞｽﾀのD3)により、ﾊｰﾄﾞｳｪｱによるSTOPを選択(HD/SFT=1)することもできます。

 ■ BANK1/BANK0 (D3)

 ﾚｼﾞｽﾀ･ﾊﾞﾝｸの選択ﾋﾞｯﾄで、0でBANK0、1でBANK1となります。ﾃﾞｰﾀ･ﾌﾟﾛﾃｸﾄ中(D.P.=1)でもｱｸｾｽ可能です。

 7.5 ｱﾗｰﾑ･ﾚｼﾞｽﾀ

 この関係のﾚｼﾞｽﾀには、A-S1, A-R10, A-MI1, A-MI10, A-H1, A-H10, A-D1, A-D10, AMO1, A-MO10, A-Wがあります。A-Wを除く、これらのﾚｼﾞｽﾀ値は正論理のBCDｺｰﾄﾞです。A-ENABLEﾚｼﾞｽﾀで16種類のｱﾗｰﾑ設定範囲を指定することができます。

 ■ A-H1,A-H10

 24時間制の設定でもa-PM/AMﾋﾞｯﾄはｱｸｾｽ可能ですが、その値に係わらずr-PM/AMﾋﾞｯﾄと一致しているとみなされます。

 ■ ﾘｱﾙﾀｲﾑ･ﾚｼﾞｽﾀのRAM領域

 A-ENABLEﾚｼﾞｽﾀで指定するｱﾗｰﾑ設定範囲以外の各ﾚｼﾞｽﾀはRAM領域として使用することができます。これらのﾚｼﾞｽﾀでは、一覧表の*のﾋﾞｯﾄも読み書きが可能となります。

 ■ 注意事項

 ｱﾗｰﾑ･ﾚｼﾞｽﾀとして使用するﾚｼﾞｽﾀに存在しない時刻、ｶﾚﾝﾀﾞを設定しますと、計時ﾐｽとなります。

 7.6 A-ENB (A-ENABLEﾚｼﾞｽﾀ)

ﾘｱﾙﾀｲﾑ･ｶｳﾝﾀとｱﾗｰﾑ･ﾚｼﾞｽﾀとの照合範囲を指定するﾚｼﾞｽﾀです。照合範囲外のｱﾗｰﾑ･ﾚｼﾞｽﾀは全ﾋﾞｯﾄRAMとして使用できます。
設定値 ｱﾗｰﾑ照合範囲
0 | 0000 | 無し
1 | 0001 | A-S1
2 | 0010 | A-S1～A-S10
3 | 0011 | A-S1～A-MI1
4 | 0100 | A-S1～A-MI10
5 | 0101 | A-S1～A-H1
6 | 0110 | A-S1～A-H10
7 | 0111 | A-S1～A-D1
8 | 1000 | A-S1～A-D10
9 | 1001 | A-S1～A-MO1
A | 1010 | A-S1～A-MO10
B | 1011 | A-S1～A-H10, A-W
C | 1100 | A-S1～A-D1, A-W
D | 1101 | A-S1～A-D10, A-W
E | 1110 | A-S1～A-MO1, A-W
F | 1111 | A-S1～A-MO10, A-W

7.7 C'Cﾚｼﾞｽﾀ (ｺﾝﾄﾛｰﾙC'ﾚｼﾞｽﾀ)

ﾒｰｶｰ試験用のﾚｼﾞｽﾀで、使用する際はTEST1(D0)、TEST2(D1)共に0の状態で使用して下さい。他の状態では動作の保証がされません。このﾚｼﾞｽﾀのｸﾘｱはこのﾚｼﾞｽﾀの読み出し、RESETﾋﾞｯﾄ(CEのD2)=1の書き込みで行います。このﾚｼﾞｽﾀ読み出し時の値は不定です。

 7.8 C'Dﾚｼﾞｽﾀ (ｺﾝﾄﾛｰﾙD'ﾚｼﾞｽﾀ)

定周期出力の周期を設定します。
CY2 | CY1 | CY0 | 周期 | ﾊﾟﾙｽ出力時のLﾚﾍﾞﾙ時間 (Duty)
0 | 0 | 0 | 1/1024秒 | 約0.5ms (約1/2)
0 | 0 | 1 | 1/128秒 | 約3.9ms (約1/2)
0 | 1 | 0 | 1/64秒 | 約7.8ms (約1/2)
0 | 1 | 1 | 1/16秒 | 約31.3ms (約1/2)
1 | 0 | 0 | 1/2秒 | 約250ms (約1/2)
1 | 0 | 1 | 1秒 | 約61ms (約1/16.39)
1 | 1 | 0 | 1分 | 約61ms (約1/983.6)
1 | 1 | 1 | 10分 | 約61ms (約1/9836)

 7.9 C'Eﾚｼﾞｽﾀ (ｺﾝﾄﾛｰﾙE'ﾚｼﾞｽﾀ)

■ D.P. (DATA PROTECT) (D0)

1の場合、ﾚｼﾞｽﾀへの書き込みは、BANK1/0(CFﾚｼﾞｽﾀのD3)を除き禁止されます。このﾋﾞｯﾄは、外来ﾉｲｽﾞやｽﾀﾝﾊﾞｲへの以降、復帰時に発生する誤書き込みからﾃﾞｰﾀを保護することを目的としています。読み出し動作しか行わないｱﾌﾟﾘｹｰｼｮﾝの場合は常に1とします。
また、本ﾋﾞｯﾄ=1での割り込みﾓｰﾄﾞ時の割り込み発生から122μs間のIRQFLAG1,2の読み出しによるﾘｾｯﾄ操作は、122μs経過後に引き伸ばされます。これは割り込みを使用してｽﾀﾝﾊﾞｲ制御を行う場合の切り換え時のﾉｲｽﾞなどによる誤読み出しでﾌﾗｸﾞがｸﾘｱされないようにするためです。
注意: 本ﾋﾞｯﾄへの1書き込みは次の条件では成立しません。
◆ | CS1=L
◆ | 本ﾋﾞｯﾄを1→0へ書き換え後65μs間
本ﾋﾞｯﾄへの0書き込みは次の条件では成立しません。
◆ | CS1=L及びCS1=L→H後2ms間
◆ | 本ﾋﾞｯﾄへ0書き込み後11ms間

 ■ CAL (CALENDER) (D1)

 ﾘｱﾙﾀｲﾑ･ｶｳﾝﾀの計時範囲を指定します。
CAL | 計時範囲
1 | R-S1～R-Y10, R-W
0 | R-S1～R-H10, R-W
本ﾋﾞｯﾄ=0の場合、R-D1～R-Y10をRAMとして使用できます。また、ｱﾗｰﾑ照合時のこの範囲は常に一致しているものとみなされます。

 ■ 24/12 (24時間制/12時間制) (D2)

24時間制、12時間制を指定します。
24/12 | 時間制
1 | 24時間制 (PM/AMは自動的に0)
0 | 12時間制 (PM/AMの設定が必要)
注意: 本ﾋﾞｯﾄの書き換えを行うとR-H1以上のﾃﾞｰﾀが壊れる場合がありますので、R-H1以上のﾃﾞｰﾀを再書き込みを行って下さい。

■ HD/SFT (HARDWARE/SOFTWARE) (D3)

STOP/START及び30秒補正をﾊｰﾄﾞｳｪｱ(STOP/START端子、30秒ADJ端子)とｿﾌﾄｳｪｱ(STOPﾋﾞｯﾄ、30秒ADJﾋﾞｯﾄ)のどちらを有効とするかを指定します。
HD/SFT | 有効
1 | ﾊｰﾄﾞｳｪｱ (STOP/START端子、30秒ADJ端子)
0 | ｿﾌﾄｳｪｱ (STOPﾋﾞｯﾄ、30秒ADJﾋﾞｯﾄ)
注意: RTC63421/63421Mはﾊｰﾄﾞｳｪｱによる使用はできません。本ﾋﾞｯﾄのｱｸｾｽは可能ですが、内部的には常に0とみなします。
ﾊｰﾄﾞｳｪｱとｿﾌﾄｳｪｱの同時使用はできません。


使用方法

2. 使用方法

8.1 電源投入時の初期設定例

注1: 電源投入時の全ﾚｼﾞｽﾀ、INTERRUPT, ALARM, 1Hz出力は不定です。
注2: TESTﾋﾞｯﾄのﾘｾｯﾄを行うﾀﾞﾐｰ読み込みです。
注3: CS1がHに遷移後2msはD.P.ﾋﾞｯﾄの設定ができないための待ち時間です。
注4: D.P.=0の書き込み後、実際にD.P.=0となるまでに9～11msかかります。
注意: D.P.=0の設定は、発振していることが前提です。通常、ﾊﾞｯｸｱｯﾌﾟ無しの初期電源投入時は、投入後発振開始までに0.2～1秒程度の時間を要します。
注5: RTC63423以外はHD/SFTﾋﾞｯﾄ設定の必要はありません。
注6: 発生しているかもしれない桁上げの完了待ち時間です。
注7: 以降、読み出しのみの場合は、D.P.=1を設定します。
注8: 各ﾚｼﾞｽﾀ内容の確認は、より多くのﾚｼﾞｽﾀを対象とする方が偶然の誤認を防げます。
注9: D.P.=1であってもBANK1/0とD.P.ﾋﾞｯﾄは変更可能です。そのために5V印加時の不安定な時にD.P.=0が書き込まれ、異常な状態になる可能性を防ぐために、このような複雑な処理を行います。

8.2 初回電源投入とﾊﾞｯｸｱｯﾌﾟからの復帰の判別例
注意: 通常、各ﾚｼﾞｽﾀ確認はBANK1の各ﾚｼﾞｽﾀで行います。

8.3 ﾚｼﾞｽﾀR-S1～R-Wの書き替え方法例

注1: | READ FLAGﾋﾞｯﾄのﾘｾｯﾄを行うﾀﾞﾐｰ読み込みです。
注2: | READ FLAGﾋﾞｯﾄのﾘｾｯﾄ待ち時間です。
注3: | 桁上げﾊﾟﾙｽによる内部動作完了待ち時間です。
注4: | D.P.=0の書き込み後、実際にD.P.=0となるまでに9～11msかかります。
注5: | RESET=1またはSTOP=1の設定以前に発生したかもしれない桁上げの完了待ち時間です。
注意:
■ | READ FLAGを使用する例の場合、次の桁上げ以前に書き換えを完了しなければなりません。(READ FLAG読み出しから書き換え完了までが1秒以内に終了する必要があります。)
■ | RESETまたはSTOPを使用する例の場合、秒未満ｶｳﾝﾀのﾘｾｯﾄ分または計時ｽﾄｯﾌﾟ分が計時の遅れとなります。

8.4 ﾚｼﾞｽﾀR-S1～R-Wの読み出し方法例
注1: READ FLAGﾋﾞｯﾄのﾘｾｯﾄを行うﾀﾞﾐｰ読み込みです。
注2: ﾘﾌﾟﾙｶｳﾝﾀの桁上げ待ち時間です。
注3: 読み出し中に桁上げが発生した場合、再度読み込みを行います。
注4: CY2～0での周期は必要とする最小周期を設定します。
必要な最小単位 | CY2 | CY1 | CY0
1秒 | 1 | 0 | 1
1分 | 1 | 1 | 0
10分 | 1 | 1 | 1
通常、これらの設定は初回電源投入時のみで、ﾊﾞｯｸｱｯﾌﾟが有効な場合は必要ありません。
注5: 多重割り込み対処のため、INTERRUPT出力のOPEN待ち時間です。

8.5 割り込み･ﾊﾟﾙｽ出力の設定方法例

注1: | RTC63421/63421Mでは割り込み出力とｱﾗｰﾑ出力のORされた結果がINTERRUPT端子にLﾚﾍﾞﾙで出力されるので、割り込み出力またはｱﾗｰﾑ出力を単独で使用する場合、他方の出力を禁止(ﾏｽｸ)しておく必要があります。
注2: | IRQ FLAGﾋﾞｯﾄのﾘｾｯﾄ(ｸﾘｱ)を行います。
注3: | MASK2=1設定以前に発生しているかもしれないﾊﾟﾙｽ出力の消滅待ち時間です。
注意: 設定前にD.P.=0でﾃﾞｰﾀ･ﾌﾟﾛﾃｸﾄを解除しておく必要があります。

8.6 ﾃﾞｰﾀﾌﾟﾛﾃｸﾄの設定/解除方法例
注1: D.P.=0書き込みはIC内部で実際にD.P.=0となるまでに9から11msかかります。

8.7 30秒ADJﾋﾞｯﾄの書き込み方法例
注1: 250μsはIC内部での30秒補正完了までの最大所要時間です。

8.8 ｽﾀﾝﾊﾞｲ遷移と電源回路例

 ■ ｽﾀﾝﾊﾞｲ遷移

 ｽﾀﾝﾊﾞｲ状態とは、動作電源電圧の最小値までの2～4.5Vの電源電圧が印加されている状態を意味し、計時動作は継続されていますが、IC外部とのｲﾝﾀｰﾌｪｰｽが保証されていない状態です。通常、ｽﾀﾝﾊﾞｲ時には、CS1を制御します。CS1の制御により次の項目の対処を行います。
対処項目 | CS1の制御
5V使用時の外部ｲﾝﾀｰﾌｪｰｽの有効化。 | CS1=4/5VDD
ｽﾀﾝﾊﾞｲ時の消費電力削減。(C-MOS入力特有の貫通電流防止) | CS1を限りなく0Vに近づけます。
ｽﾀﾝﾊﾞｲ時のﾃﾞｰﾀ保護。 | 次に示すﾀｲﾐﾝｸﾞで制御します。
ｽﾀﾝﾊﾞｲ状態との遷移における誤書き込みを防止するために、書き込み動作時以外はD.P.=1とすることが望まれます。ｽﾀﾝﾊﾞｲ遷移時に必ずD.P.=1が保証される場合は、次のﾀｲﾐﾝｸﾞでのCS1制御も可能ですが、理想的には前図のﾀｲﾐﾝｸﾞを推奨します。

■ 電源回路例

C: | 電源がONからOFFになる時にﾄﾗﾝｼﾞｽﾀのｺﾚｸﾀからｴﾐｯﾀへ逆電流が瞬間的に流れますので、この影響をできるだけ少なくするために、このｺﾝﾃﾞﾝｻ容量をできるだけ大きくします。
D: | 一次電池を使用する場合に必要です。二次電池を使用する場合、このﾀﾞｲｵｰﾄﾞを削除します。
R: | 具体的な抵抗値は使用する電池に依存します。電池ﾒｰｶｰにお問い合わせ下さい。

8.9 ﾏｲｺﾝとの接続の注意

 基本的にﾏﾙﾁﾌﾟﾚｸｽ･ﾊﾞｽのCPUでは、ALEを使用して接続をします。非ﾏﾙﾁﾌﾟﾚｸｽ･ﾊﾞｽのCPUではALEをVDDに接続します。RTCを配置するﾒﾓﾘまたはI/O空間が他のﾒﾓﾘまたはI/Oと明らかに分離された構造の場合は、ｱﾄﾞﾚｽ･ﾃﾞｺｰﾀﾞは不要となります。CPU動作停止などの命令を持つCPUで、停止状態でRTCの入力に接続される信号線がﾌﾛｰﾃｨﾝｸﾞとなる場合は、対象となる信号線をVDDなどへ抵抗を介してﾌﾟﾙｱｯﾌﾟして下さい。これは貫通電流による消費電力の増加、ﾉｲｽﾞなどによる誤書き込みでの誤動作などを防止するためです。


参考ﾃﾞｰﾀ

9. 参考ﾃﾞｰﾀ

9.1 周波数温度特性例 (周波数安定度, 時計精度)

 周波数安定度(時計誤差)は以下にように求めます。
① 周波数温度特性は次の式で近似できます。
Δfr (ppm) = a (θT－θX)2
Δfr (ppm) | 任意の温度における周波数偏差
a (ppm/℃2) | 2次温度係数 (-0.035±0.005ppm/℃2)
θT (℃) | 頂点温度 (25±5℃)
θX (℃) | 任意の温度
② 時計誤差(精度)を求めるには、更に周波数精度と電圧特性を加えます。
Δf/f (ppm) = Δf/fo＋ΔfT＋ΔfV
Δf/f (ppm) | 任意の温度･電圧の時計精度 (周波数安定度)
Δf/fo (ppm) | 周波数精度
ΔfT (ppm) | 任意の温度における周波数偏差
ΔfV (ppm) | 任意の電圧における周波数偏差
③ 日差は次の式で求めます。
日差 (秒) = Δf/f×10-6 (秒) ×86400 (秒)
時計誤差が11.574ppmの場合が約1秒/日の誤差となります。

■ 周波数温度特性

■ 周波数電圧特性

■ 消費電流電圧特性


外形図

10. 外形図


表示方法

11. 表示方法

機種 | 表示 | 精度
RTC63421 RTC63421M | A | 5±10ppm
 | B | 5±50ppm
RTC63423 | A | 5±20ppm
 | 無表示 | 5±50ppm
注意: 表示内容は文字の意味と表示位置の概略を示すもので、字形、大きさ、位置の詳細を規定するものではありません。


使用上の注意事項

12. 使用上の注意事項

■ 一般的な注意事項

 本ICは低消費電力を実現するためにC-MOSﾌﾟﾛｾｽを用いていますので、特に以下の点に注意して下さい。
◆ 静電気
耐静電気破壊保護回路は内蔵していますが、過大な静電気が加わるとICが破壊されることがありますので、梱包及び運搬容器は導電性のものを使用して下さい。また、ﾊﾝﾀﾞｺﾞﾃや測定回路などは高電圧ﾘｰｸのないものを使用し、作業時にはｱｰｽを取って下さい。
◆ ﾉｲｽﾞ
電源及び入力端子に過大な外来ﾉｲｽﾞが印加されると、ﾗｯﾁｱｯﾌﾟ現象やｽﾌﾟﾘｱｽ現象を引き起こし、誤動作及び破壊の原因となることがあります。安定動作のため、本ICの電源端子(VDDとGND間)のなるべく近い場所に0.1μF以上の(できればｾﾗﾐｯｸ･ｺﾝﾃﾞﾝｻ)ﾊﾟｽｺﾝを付けて下さい。また、本ICの近くに高ﾉｲｽﾞを発生するものを置かないようにして下さい。
◆ 入力端子の電位
入力端子の中間電位設定は消費電流の増加、ﾉｲｽﾞﾏｰｼﾞﾝの減少、素子の劣化につながりますので、CS1以外の入力端子もできるだけVDD, GND電位に近い電位設定として下さい。CS1のVIHは4/5VDD、VILは1/5VDDで、VIL～VIHの電位設定は、消費電流の著しい増加及び動作の保証ができませんので、ﾘｯﾌﾟﾙ、ﾉｲｽﾞなどを考慮の上、設計を行って下さい。TTL ICでのﾄﾞﾗｲﾌﾞは不可能ですので、HC-MOSやC-MOSのﾘｾｯﾄICなどでﾄﾞﾗｲﾌﾞして下さい。
◆ 未使用入力端子処理 (NCを除く)
入力端子の入力ｲﾝﾋﾟｰﾀﾞﾝｽは非常に高いので、ｵｰﾌﾟﾝ状態での使用は不定電位やﾉｲｽﾞによる誤動作の原因につながりますので、未使用の入力端子は必ずﾌﾟﾙｱｯﾌﾟまたはﾌﾟﾙﾀﾞｳﾝ処理を行って下さい。NC端子もﾉｲｽﾞを避けるためVDDまたはGNDに接続して下さい。ALE端子が未使用の場合は直接VDDに接続して下さい。

■ 実装上の注意事項
◆ ﾊﾝﾀﾞ付け温度条件
RTC63421/53421M
内蔵の水晶振動子にﾊﾝﾀﾞを用いていますので、ﾊﾟｯｹｰｼﾞ内部が150℃を超えますと、水晶振動子の特性劣化や破壊をまねく場合があります。ﾊﾝﾀﾞ付け条件はﾘｰﾄﾞ部で260℃以下×10秒以内ですので、ﾃﾞｨｯﾌﾟ槽か手ﾊﾝﾀﾞによるﾊﾝﾀﾞ付けをお願い致します。ﾍﾟｰﾊﾟｰ、ﾘﾌﾛｰ、赤外線などによるﾊﾝﾀﾞ付けは御遠慮下さい。
RTC63421/53421M
ﾊﾟｯｹｰｼﾞ内部が260℃を超えますと、水晶振動子の特性劣化や破壊をまねく場合がありますので、ﾊﾝﾀﾞ付け条件を厳守して下さい。ﾊﾝﾀﾞ付け条件は260℃以下×10秒以内×2回以内または230℃以下×3分以内のいずれかです。次にﾊﾝﾀﾞ付け条件例を示します。
◆ 自動実装機
汎用自動実装機の使用は可能ですが、実装時の衝撃力は機械、条件によっては内蔵の水晶振動子の破壊をまねく場合がありますので、使用前に実機にて御確認下さい。
◆ 超音波洗浄
超音波洗浄は使用条件により水晶振動子が共振破壊される場合があります。このため超音波洗浄での保証ができませんので、御遠慮下さい。
◆ 実装方向
逆向きに実装しますと破壊の原因となりますので、方向を確認の上で実装して下さい。
◆ 端子間ﾘｰｸ
汚れた状態で通電しますと、端子間ﾘｰｸをまねく場合がありますので、洗浄後に通電して下さい。