目次

Windowsｲﾝｽﾄｰﾙ目次 Ver 1.32

1 | はじめに
1.1 |  | 必要条件
2 | 一般的なｲﾝｽﾄｰﾙ手順
2.1 |  | 起動ﾃﾞｨｽｸの作成
3 | TinkPad530CSのｲﾝｽﾄｰﾙ
3.1 |  | 固有ﾄﾞﾗｲﾊﾞ、ﾕｰﾃｨﾘﾃｨの保存/入手
4 | Libretto20,30のｲﾝｽﾄｰﾙ
4.1 |  | 固有ﾄﾞﾗｲﾊﾞの保存
4.2 |  | 起動ﾃﾞｨｽｸの作成
5 | TinkPad560のｲﾝｽﾄｰﾙ
6 | Let's note mini AL-N4のｲﾝｽﾄｰﾙ
3.1 |  | 関係ﾌｧｲﾙの入手と注意
追補
 | Disk Manager
 | ｲﾝｽﾄｰﾙの自動化
 | 1ｿｹｯﾄでのﾄﾞﾗｲﾊﾞ追加


はじめに

1. はじめに

Windowsのｸﾘｰﾝ ｲﾝｽﾄｰﾙを行う場合の一般的手順とﾋﾝﾄを、Windows98/98SEとWindows2000のｲﾝｽﾄｰﾙを例に説明します。

また、製造業者ｻﾎﾟｰﾄ外でﾏｼﾝ固有のﾊｰﾄﾞｳｪｱ構成が問題となるﾉｰﾄ型ﾊﾟｿｺﾝについても、Libretto20とThinkPad530CSへのWindows98ｲﾝｽﾄｰﾙ、Let's note mini AL-N4とThinkPad560へのWindows98SE/Windows2000ｲﾝｽﾄｰﾙを取り上げ、具体的な手順を示します。他のﾏｼﾝでも参考になると思います。ただし、すべての機能について完全に解決している訳ではありませんので御了承ください。大筋の機能は満たされているという条件です。

また、機種の条件によっては、そのままの状態でｲﾝｽﾄｰﾙ不可能な場合があります。 これについては1.1 必要条件をご覧ください。

by HERO


必要条件

1.1 必要条件

Windowsが正常にｲﾝｽﾄｰﾙされ、動作するためには、ﾒﾓﾘ容量とHDD容量が満たされていなければなりません。 Windows98ではﾒﾓﾘ容量16Mﾊﾞｲﾄ以上、HDD容量約300Mﾊﾞｲﾄ以上、Windows98SEではﾒﾓﾘ容量24Mﾊﾞｲﾄ以上、HDD容量約400Mﾊﾞｲﾄ以上、Windows2000ではﾒﾓﾘ容量32Mﾊﾞｲﾄ以上、HDD容量約1.5Gﾊﾞｲﾄ以上が必要です。 HDD容量はｲﾝｽﾄｰﾙする内容に依存しますので、これ以下でもｲﾝｽﾄｰﾙできる場合があります。 ｲﾝｽﾄｰﾙ完了時点で、これらのHDD容量の殆どを消費する訳ではありません。 ｲﾝｽﾄｰﾙ中の一時ﾌｧｲﾙなどが領域を使用するため、上記程度の容量が必要です。 ｲﾝｽﾄｰﾙ直後の使用済み容量はWindows98SEで約300Mﾊﾞｲﾄ、Windows2000で約800Mﾊﾞｲﾄ程度になります。

HDD容量については、ﾌｧｲﾙ圧縮やﾄﾞﾗｲﾌﾞ圧縮を利用する方法も可能ですが、一般的にHDｱｸｾｽ速度が低下すると思われているため、あまり利用されていないようです。 CPU速度が高速なわりにHDｼｰｸ時間が低速な場合、ﾌｧｲﾙ圧縮やﾄﾞﾗｲﾌﾞ圧縮による速度低下の影響が軽減されます。 極端な場合、圧縮時の方が速い場合も有り得ます。 これは圧縮によりｸﾗｽﾀ数が減少し、本来の場合と比較してｼｰｸ回数が減り、減った分の時間が圧縮/解凍時間より長くなった場合です。

ﾒﾓﾘ増設

ﾒﾓﾘ容量が不足している場合は、ﾒﾓﾘ増設を行なう必要があります。 一般的に製造業者が仕様で定義している最大ﾒﾓﾘ容量は自社が供給する増設用ﾒﾓﾘを装着した場合の値です。 殆どﾊﾟｿｺﾝがﾊｰﾄﾞ的にはそれ以上の容量を許容します。 けれどもﾉｰﾄ型ﾊﾟｿｺﾝの場合、増設の具合によって、仕様を越えるﾒﾓﾘ増設が電源容量不足を引き起こすかもしれません。 とは言え、特別大消費電力の物をﾌﾙ装着しなければ、通常は問題がないようです。

HDD交換

HDD容量が不足している場合には、HDDの交換が必要です。 しかし、大容量HDDでの交換で問題になるのが、BIOSでの認識です。 旧型のﾊﾟｿｺﾝの場合、例えば8Gﾊﾞｲﾄの制限などが存在します。 これらの制限を解消したBIOSが製造業者から供給されているならば、BIOSを更新することで問題はなくなります。 しかし、ここで扱う旧型機の場合、これらの更新されたBIOS供給がありません。 そこでDisk Managerを利用します。 これは電源投入時だけ、BIOSが正常認識可能なHDD容量にし、その後に本来のHDD容量として扱う機能を提供します。 この仕組みについてはDisk Managerの概要をご覧ください。

Disk Managerによる操作手順

Disk Managerのｲﾝｽﾄｰﾙ(操作)は以下の手順です。 以下は既に目的ﾊﾟｿｺﾝに対象HDDが装着され、Disk Managerの起動FDが作成されている前提です。

  1. 予めBIOS設定内で起動順がFD⇒HDであることを確認します。
  2. Disk Manager起動FDからﾊﾟｿｺﾝを起動します(Disk Manegerの起動参照)。
  3. Disk Managerを実行し、(A)dvanced Options⇒(M)aintanance Options⇒(U)tilitiesと選択して、対象のHDDを選択します。
  4. 次に表示されるﾒﾆｭｰからSet Drive Sizeを選択し、BIOSが認識できる適当な値でHDD容量を変更します。
  5. Disk Managerを終了し、ﾊﾟｿｺﾝの電源を一旦OFFにした後、ONにして再度Disk Manager起動FDから起動します。 このときの起動でHDDがBIOSで正常に認識されていることを確認します。 正常に認識されない場合、HDD容量変更値がまだ大きすぎることが考えられますんので、再度小さな値に変更します。
  6. Disk Managerを実行し、(E)asy Disk Instationまたは(A)dvanced Options⇒(A)dvanced Disk installationでHDDにDisk Manager機能をｲﾝｽﾄｰﾙします。 任意にﾊﾟﾃｨｰｼｮﾝ設定を行いたい場合は、(A)dvanced Options⇒(A)dvanced Disk installationを使用します。
  7. Disk Managerを終了し、ﾊﾟｿｺﾝの電源を一旦OFFにした後、ONにすると、BIOS画面語にDisk Manager起動画面が表示されます。
この状態でHDDの全容量が利用可能になっていますが、一般的な再起動は全て電源のOFF/ONで行なわなければなりません。 これは応用ﾌﾟﾛｸﾞﾗﾑのｲﾝｽﾄｰﾙ時などの再起動も含む、全ての再起動動作が当て嵌まります。 従って、OSｲﾝｽﾄｰﾙ作業での再起動も、この電源OFF/ONが必要とされます。


Windowsｸﾘｰﾝ ｲﾝｽﾄｰﾙ手順

2. Windowsｸﾘｰﾝ ｲﾝｽﾄｰﾙ手順

一般的(FDとWindowsｲﾝｽﾄｰﾙ ﾃﾞｨｽｸが同時に使用可能)なﾏｼﾝで、ｸﾘｰﾝ ｲﾝｽﾄｰﾙを行う手順を次に示します。FDがA:、Windowsｲﾝｽﾄｰﾙ ﾃﾞｨｽｸはCD-ROMでD:とする例です。

1. | 起動ﾃﾞｨｽｸを作成します。
2. | 起動ﾃﾞｨｽｸから立ち上げます。
3.必要ならば、ﾊﾟｰﾃｨｼｮﾝの切り直しを行います。
A:\>FDISK
4.ﾊｰﾄﾞ ﾃﾞｨｽｸをﾌｫｰﾏｯﾄします。
A:\>FORMAT C:
5.Windows98/98SEの場合、Windows98ｲﾝｽﾄｰﾙ ﾃﾞｨｽｸの\Win98ﾌｫﾙﾀﾞに切り替えます。
A:\>D:
D:\>CD WIN98
Windows2000の場合、Windows2000ｲﾝｽﾄｰﾙ ﾃﾞｨｽｸの\i386ﾌｫﾙﾀﾞに切り替えます。
A:\>D:
D:\>CD I386
6.Windows98/98SEの場合、Setup.exeを起動します。
D:\Win98>SETUP /IE
以下に代表的なSETUPｵﾌﾟｼｮﾝを示しますので、状況に応じて使用します。
/C
ｷｬｯｼｭを行いません。MOなどで使用する必要がある場合があります。(ﾄﾞﾗｲﾊﾞのﾏﾆｭｱﾙ参照)
/IE
ｲﾝｽﾄｰﾙ中の起動ﾃﾞｨｽｸ(FD)作成を行いません。
/IS
ｲﾝｽﾄｰﾙ開始時のｽｷｬﾝ ﾃﾞｨｽｸを行いません。ﾒﾓﾘ不足でｽｷｬﾝ ﾃﾞｨｽｸがｴﾗｰとなった場合に使用します。
Windows2000の場合、Winnt.exe(16ﾋﾞｯﾄ環境)またはWinnt32.exe(32ﾋﾞｯﾄ環境)を起動します。
D:\I386>WINNTまたはWINNT32
32ﾋﾞｯﾄ環境(例えばWindows9x)でのWinnt32.exeには以下の代表的なｵﾌﾟｼｮﾝがあります。
/makelocalsource
全ｲﾝｽﾄｰﾙ ﾌｧｲﾙをCD-ROMからﾊｰﾄﾞ ﾃﾞｨｽｸにｺﾋﾟｰします。
7. | 指示に従い、必要な入力を行います。
8.Windows本体のｲﾝｽﾄｰﾙ終了後、必要に応じてﾏｼﾝ固有ﾄﾞﾗｲﾊﾞなどをｲﾝｽﾄｰﾙします。

注:特にWindows2000のｲﾝｽﾄｰﾙ用CD-ROMがｱｯﾌﾟｸﾞﾚｰﾄﾞ版の場合、いきなり新規ｲﾝｽﾄｰﾙが出来ません。 以前のWindowsのCD-ROM確認が必要ですが、その時点でCDﾄﾞﾗｲﾌﾞが利用不能の場合、そのｲﾝｽﾄｰﾙは失敗します。 従って、予めWindows9xなどをｲﾝｽﾄｰﾙし、そこから WINNT32 /makelocalsource でｲﾝｽﾄｰﾙを開始しなければなりません。 ｲﾝｽﾄｰﾙ中の問い合わせに、ｱｯﾌﾟｸﾞﾚｰﾄﾞを選択すれば、Windows2000単体のｲﾝｽﾄｰﾙに、新規ｲﾝｽﾄｰﾙを選択すれば、ﾃﾞｭｱﾙ ﾌﾞｰﾄになります。 新規ｲﾝｽﾄｰﾙ指定の場合、既存Windowsと異なるﾄﾞﾗｲﾌﾞへｲﾝｽﾄｰﾙしなければなりません。


起動ﾃﾞｨｽｸの作成

2.1 起動ﾃﾞｨｽｸの作成

ｸﾘｰﾝ ｲﾝｽﾄｰﾙを行う場合、ﾊｰﾄﾞ ﾃﾞｨｽｸをﾌｫｰﾏｯﾄしますので、必ず起動ﾃﾞｨｽｸが必要になります。起動ﾃﾞｨｽｸはBIOSがｻﾎﾟｰﾄするﾌﾞｰﾄ可能なﾃﾞﾊﾞｲｽでなければなりません。各ﾏｼﾝで共通のﾌﾞｰﾄ ﾃﾞﾊﾞｲｽとしては、FDD,HDがあります。この他にもCD-ROM,SCSI HDなどをｻﾎﾟｰﾄしているBIOSもあります。

ここでは、共通性、利便性を考慮し、起動ﾃﾞｨｽｸとしてﾌﾛｯﾋﾟｰ ﾃﾞｨｽｸを選択します。

以下の例はWindows98/98SEから起動FDを作成する場合です。 例えばMS-DOSからでも同様に作成することができますが、FAT16しか扱えないため、論理ﾄﾞﾗｲﾌﾞ容量が2Gﾊﾞｲﾄに制限されます。

1. | 現在動作中のWindowsで3.5ｲﾝﾁFDのﾌｫｰﾏｯﾄを行います。
① | ﾏｲ ｺﾝﾋﾟｭｰﾀから3.5ｲﾝﾁ FDを右ｸﾘｯｸし、ﾌｫｰﾏｯﾄを選択します。
② | ﾌｫｰﾏｯﾄの種類欄からｸｨｯｸ･ﾌｫｰﾏｯﾄか標準ﾌｫｰﾏｯﾄを選択します。
③ | ｵﾌﾟｼｮﾝ欄からｼｽﾃﾑ ﾌｧｲﾙのｺﾋﾟｰを選択します。
④ | 開始ﾎﾞﾀﾝをｸﾘｯｸします。
2. | ﾒﾓ帳(NOTEPAD)などを使用して、CONFIG.SYSを作成します。
1
DEVICE=\DOS\HIMEM.SYS /TESTMEM:OFF
2
DEVICEHIGH=\DOS\EMM386.EXE RAM 512 FRAME=D000 X=CE00-CFFF
3
FILES=10
4
BUFFERS=10
5
DOS=HIGH,UMB
6
STACKS=9,256
7
DEVICEHIGH=\DOS\BILING.SYS
8
DEVICEHIGH=\DOS\JFONT.SYS /P=\DOS\ /MSG=OFF
9
DEVICEHIGH=\DOS\JDISP.SYS /HS=LC
10
DEVICEHIGH=\DOS\JKEYB.SYS /106 \DOS\JKEYBRD.SYS
11
DEVICEHIGH=\DOS\xxxxSS.SYS
ｿｹｯﾄ ｻｰﾋﾞｽ
12
DEVICEHIGH=\DOS\xxxxCS.SYS
ｶｰﾄﾞ ｻｰﾋﾞｽ
13
DEVICEHIGH=\DOS\ASPIxx.SYS
SCSIﾄﾞﾗｲﾊﾞ
14
DEVICEHIGH=\DOS\ASPICD.SYS /D:CD001
CD-ROMﾄﾞﾗｲﾊﾞ
15
DEVICEHIGH=\DOS\ASPIDISK.SYS
HD,MOﾄﾞﾗｲﾊﾞ
16
LASTDRIVE=Z
10,11行のｿｹｯﾄ ｻｰﾋﾞｽとｶｰﾄﾞ ｻｰﾋﾞｽは、ﾉｰﾄ型などでPCMCIAのSCSIを使用する場合に必要で、通常、ﾉｰﾄ ﾊﾟｿｺﾝ本体に付属しています。また、多くの場合、他機種のものでも使用可能です。ﾃﾞｽｸﾄｯﾌﾟ型のSCSI使用では、この2行は不要です。13,14,15は、SCSIｶｰﾄﾞに付属しています。14,15は、実際に使用するﾃﾞﾊﾞｲｽにより、どちらかのみを記述します。SCSIｶｰﾄﾞによっては、2のEMM386.EXEのﾊﾟﾗﾒｰﾀ変更が必要になる場合もあります。これらについては、SCSIｶｰﾄﾞのﾏﾆｭｱﾙを参照してください。SCSIを使用しない場合、この3行は不要ですが、IDEのCD-ROMを使用する場合には、この3行に替わるATAPIﾄﾞﾗｲﾊﾞが必要です。
参考 XMS,EMS,DEVICEHIGHなどは、ｺﾝﾍﾞﾝｼｮﾅﾙ ﾒﾓﾘ領域の拡大に寄与します。Windowsｲﾝｽﾄｰﾙの最初にｽｷｬﾝ ﾃﾞｨｽｸが行われますが、ｺﾝﾍﾞﾝｼｮﾅﾙ ﾒﾓﾘ領域が不足している場合、ここでｴﾗｰとなります。
3. | ﾒﾓ帳(NOTEPAD)などを使用して、AUTOEXEC.BATを作成します。
1
@ECHO OFF
2
SET TEMP=\DOS
3
SET TMP=\DOS
4
PATH=\;\DOS
5
PROMPT $p$g
6
SET COMSPEC=\COMMAND.COM
7
@ECHO ON
8
LH \DOS\MSCDEX.EXE /D:CD001 /L:D
8のMSCDEX.EXEは、CD-ROMを使用する場合のみ必要です。ﾊｰﾄﾞ ﾃﾞｨｽｸ、MOなどの場合、この行は必要ありません。
参考 CD-ROMのﾄﾞﾗｲﾌﾞ番号は、MSCDEX.EXEﾊﾟﾗﾒｰﾀ/L:Dで示されます。必要に応じてDを変更します。
4. | 起動ﾃﾞｨｽｸにDOSﾌｫﾙﾀﾞを作成します。
5. | 起動ﾃﾞｨｽｸのDOSﾌｫﾙﾀﾞに以下のﾌｧｲﾙをｺﾋﾟｰします。
1
\Windows\Ank16.fnt
2
\Windows\Ank19.fnt
3
\Windows\Biling.sys
4
\Windows\Command\Fdisk.exe
5
\Windows\Command\Format.com
6
\Windows\Himem.sys
7
\Windows\Jdisp.sys
8
\Windows\Jfont.sys
9
\Windows\Jkeyb.sys
10
\Windows\Jkeybrd.sys
11
\Windows\Kanji16.fnt
12
\Windows\Command\Mscdex.exe
13
\Windows\Command\Sys.com
14
xxxxSS.SYS
ｿｹｯﾄ ｻｰﾋﾞｽ
15
xxxxCS.SYS
ｶｰﾄﾞ ｻｰﾋﾞｽ
16
ASPIxx.SYS
SCSIﾄﾞﾗｲﾊﾞ
17
ASPICD.SYS
CD-ROMﾄﾞﾗｲﾊﾞ
18
ASPIDISK.SYS
HD,MOﾄﾞﾗｲﾊﾞ
14,15は、ﾉｰﾄ型などでPCMCIAのSCSIを使用する場合に必要で、通常、ﾉｰﾄ ﾊﾟｿｺﾝ本体の\Windows\Options以下などにあります。16,17,18は、SCSIｶｰﾄﾞに附属しています。


ThinkPad530CSのｲﾝｽﾄｰﾙ

3. ThinkPad530CSのｲﾝｽﾄｰﾙ

ThinkPad530CSにWindows98をｲﾝｽﾄｰﾙする場合、ﾒﾓﾘ容量が問題になります。 ﾒﾓﾘ容量はWindows98の場合、最低でも16Mﾊﾞｲﾄのﾒﾓﾘが必要です。 12Mﾊﾞｲﾄの場合は増設が必要です。

ｲﾝｽﾄｰﾙ自体は一般的なｲﾝｽﾄｰﾙで問題ありませんが、Windows98標準ｲﾝｽﾄｰﾙ ﾃﾞｨｽｸでは、ｻｳﾝﾄﾞ関係に若干問題が残ります。 ThinkPad530CSのｻｳﾝﾄﾞ関係はMwave(DSP)で行っており、標準ｲﾝｽﾄｰﾙ ﾃﾞｨｽｸでも最低限のｻﾎﾟｰﾄが行われるのですが、特に次の2点に不満が残ります。

  • 内臓ﾓﾃﾞﾑ速度が33.6Kbpsではなく28.8Kbpsとなる。
  • MIDI音源用Waveﾃﾞｰﾀが少なく、貧弱な音しか出ない。
また、標準Windows98以外のﾄﾞﾗｲﾊﾞ、ﾕｰﾃｨﾘﾃｨの問題もあります。 これらの点を踏まえたｲﾝｽﾄｰﾙを次に示します。

1. | ThinkPad530CS固有のﾄﾞﾗｲﾊﾞ、ﾕｰﾃｨﾘﾃｨを保存(入手)します。
2.起動ﾃﾞｨｽｸを作成します。
起動ﾃﾞｨｽｸは一般的な方法と同一です。
  • ｶｰﾄﾞ ｻｰﾋﾞｽはIBMDSS01.SYSです。
  • ｿｹｯﾄ ｻｰﾋﾞｽはIBMDOSCS.SYSです。
IBMDSS01.SYS,IBMDOSCS.SYSはﾃﾞｨｽｹｯﾄ ﾌｧｸﾄﾘのThinkPad PCMCIAｻﾎﾟｰﾄで作成したFD内にあります。
3. | 起動ﾃﾞｨｽｸから立ち上げます。
4.必要ならば、ﾊﾟｰﾃｨｼｮﾝの切り直しを行います。
A:\>FDISK
5.ﾊｰﾄﾞ ﾃﾞｨｽｸをﾌｫｰﾏｯﾄします。
A:\>FORMAT C:
6.Windows98ｲﾝｽﾄｰﾙ ﾃﾞｨｽｸの\Win98ﾌｫﾙﾀﾞに切り替えます。
A:\>D:
D:\>CD WIN98
7.Setup.exeを起動します。
D:\Win98>SETUP /IE
8.途中でｶｰﾄﾞ(PCMCIA)経由でｲﾝｽﾄｰﾙを行いますかのﾒｯｾｰｼﾞが現れますので、以下の処理を行います。
① | はいを選択して、次へをｸﾘｯｸします。
② | 続いてDOSﾄﾞﾗｲﾊﾞの削除を行いますかのﾒｯｾｰｼﾞが現れます。いいえを選択して、次へをｸﾘｯｸします。
9.Windows98のSetup終了後、Mwave関係のｲﾝｽﾄｰﾙを行います。
① | FAX 33.6をｲﾝｽﾄｰﾙします。 最後の再起動しますかにはいいえをｸﾘｯｸします。
② | FAX 33.6 Updateを行います。 これはﾀﾞｳﾝﾛｰﾄﾞしたT30.dspﾌｧｲﾙを\Mww\ModemﾌｫﾙﾀﾞのT30.dspに上書きするだけです。
③ | 保存しておいたMwavethi.grpをﾀﾞﾌﾞﾙｸﾘｯｸし、Mwave関係をｽﾀｰﾄ ﾒﾆｭｰに登録します。
④ | Mwave MIDI samplesをｲﾝｽﾄｰﾙします。
⑤ | 再起動すると新しいﾊｰﾄﾞｳｪｱの検出となり、必要なﾄﾞﾗｲﾊﾞがWindowsｲﾝｽﾄｰﾙ ﾃﾞｨｽｸからｲﾝｽﾄｰﾙされます。
⑥ | ﾓﾃﾞﾑは既定で28.8Kbpsです。 33.6Kbpsにするには、ｽﾀｰﾄ ﾒﾆｭｰ⇒ﾌﾟﾛｸﾞﾗﾑ⇒Mwave ThinkPad⇒Mwave ﾓﾃﾞﾑを起動し、ﾒﾆｭｰﾊﾞｰからｵﾌﾟｼｮﾝ⇒設定を起動して行ってください。
10.必要ならばThinkPadﾕｰﾃｨﾘﾃｨをｲﾝｽﾄｰﾙします。
① | ThinkPadﾕｰﾃｨﾘﾃｨ ﾃﾞｨｽｸ(FD)のINSTALLW.EXEを実行します。
② | 以降、起動時にFuelﾒｰﾀが表示されるようになります。 これを行わないようにするには、ｽﾀｰﾄ ﾒﾆｭｰ⇒ﾌﾟﾛｸﾞﾗﾑ⇒ｱｸｾｻﾘ⇒ｼｽﾃﾑ ﾂｰﾙ⇒ｼｽﾃﾑ情報を起動し、ﾒﾆｭｰﾊﾞｰからﾂｰﾙ⇒ｼｽﾃﾑ設定ﾕｰﾃｨﾘﾃｨを起動して、ｽﾀｰﾄ ｱｯﾌﾟﾀﾌﾞからload= c:\thinkpad\fuelwin.exeのﾁｪｯｸを外します。

参考 音量調整はWindows附属のものでも行えますが、全項目を表示しようとすると画面範囲を超えてしまいますので、Mwave附属の音量調整を使用する方が便利です。 Mwave附属の音量調整は、ｽﾀｰﾄ ﾒﾆｭｰ⇒ﾌﾟﾛｸﾞﾗﾑ⇒Mwave ThinkPad⇒ｵｰﾃﾞｨｵ制御で起動します。


ThinkPad固有ﾄﾞﾗｲﾊﾞ、ﾕｰﾃｨﾘﾃｨの保存と入手

3.1 ThinkPad530CS固有ﾄﾞﾗｲﾊﾞ、ﾕｰﾃｨﾘﾃｨの保存と入手

■ ﾄﾞﾗｲﾊﾞ、ﾕｰﾃｨﾘﾃｨの保存

元のWindows95上では、ﾃﾞｨｽｹｯﾄ ﾌｧｸﾄﾘで、これらのﾄﾞﾗｲﾊﾞ、ﾕﾃｨﾘﾃｨのｲﾝｽﾄｰﾙ ﾃﾞｨｽｸ(FD)の作成ができます。 ﾃﾞｨｽｹｯﾄ ﾌｧｸﾄﾘのﾌﾟﾛｸﾞﾗﾑ自体はWindows3.xﾍﾞｰｽですが、Windows98でも一部表示上の問題を除いて動作します。 また、この問題も実際の機能には影響ありません。

そこでﾃﾞｨｽｹｯﾄ ﾌｧｸﾄﾘ自体を他のﾏｼﾝに複写して使用する方が便利です。 \Factoryﾌｫﾙﾀﾞと\Diskettsﾌｫﾙﾀﾞを丸ごと複写します。 この2つのﾌｫﾙﾀﾞの相対的な位置関係を保つようにしてください。 実際に起動するには、FactoryﾌｫﾙﾀﾞのFactory.exeを起動します。

上記の方法が不可能な場合は、ﾃﾞｨｽｹｯﾄ ﾌｧｸﾄﾘでﾄﾞﾗｲﾊﾞ、ﾕｰﾃｨﾘﾃｨのｲﾝｽﾄｰﾙ ﾃﾞｨｽｸを作成し、FDで保存します。

参考 これらの殆どはFD以外からのｲﾝｽﾄｰﾙが可能です。 例えば、ﾊｰﾄﾞ ﾃﾞｨｽｸからｲﾝｽﾄｰﾙを行う場合、適当なﾌｫﾙﾀﾞ内に作成したFDの内容を全て複写し、Setup.exeなどのｲﾝｽﾄｰﾗｰを起動します。

ﾃﾞｨｽｹｯﾄ ﾌｧｸﾄﾘで作成したMwave for Windows95でMwaveをｲﾝｽﾄｰﾙせずに、FAX 33.6でｲﾝｽﾄｰﾙを行う場合、ｽﾀｰﾄ ﾒﾆｭｰの登録がありません。 元のｽﾀｰﾄ ﾒﾆｭｰと同一にするには、元のWindows95上のMwavethi.grpﾌｧｲﾙをﾌﾛｯﾋﾟｰ ﾃﾞｨｽｸなどに保存しておく必要があります。

■ ﾄﾞﾗｲﾊﾞ、ﾕｰﾃｨﾘﾃｨの入手

附属のﾄﾞﾗｲﾊﾞ、ﾕｰﾃｨﾘﾃｨが古く機能的に劣る場合などは、IBMのｻｲﾄからﾀﾞｳﾝﾛｰﾄﾞ ｻｰﾋﾞｽで最新のものを入手することが可能です。 現在のﾓﾃﾞﾑが28.8Kbpsの場合、FAX 33.6とそのUpdateの2つが必要です。音源ﾃﾞｰﾀはMwave MIDI samplesが必要です。


Libretto20,30のｲﾝｽﾄｰﾙ

4. Libretto20,30のｲﾝｽﾄｰﾙ

Libretto20,30にWindows98をｲﾝｽﾄｰﾙする場合、ﾒﾓﾘ容量とHDD容量が問題になります。 ﾒﾓﾘ容量はWindows98の場合、最低でも16Mﾊﾞｲﾄのﾒﾓﾘが必要です。 8Mﾊﾞｲﾄの場合は増設が必要です。

270MﾊﾞｲﾄのHDDでは、そのままｲﾝｽﾄｰﾙすると容量不足となりますので、ﾄﾞﾗｲﾌﾞｽﾍﾟｰｽ3などで圧縮ﾄﾞﾗｲﾌﾞとしてｲﾝｽﾄｰﾙする必要があります。 また、Windows98へのｱｯﾌﾟｸﾞﾚｰﾄﾞとしてｲﾝｽﾄｰﾙを行う場合でも、状況によっては圧縮ﾄﾞﾗｲﾌﾞとする必要があります。 目安としてﾃﾞｨｽｸの空き容量が、ｱｯﾌﾟｸﾞﾚｰﾄﾞの場合で200Mﾊﾞｲﾄ、ｸﾘｰﾝ ｲﾝｽﾄｰﾙの場合で220Mﾊﾞｲﾄ程度必要になります。 これは最小構成のｲﾝｽﾄｰﾙを行う場合で、ｵﾌﾟｼｮﾝ ｺﾝﾎﾟｰﾈﾝﾄを選択するほど、必要な空き容量が増します。 ｵﾌﾟｼｮﾝ ｺﾝﾎﾟｰﾈﾝﾄはｲﾝｽﾄｰﾙ後でも[ｺﾝﾄﾛｰﾙ ﾊﾟﾈﾙ]⇒[ｱﾌﾟﾘｹｰｼｮﾝの追加と削除]の[Windowsﾌｧｲﾙ]ﾀﾌﾞで追加できますので、ｲﾝｽﾄｰﾙ時は最小構成としておき、ｲﾝｽﾄｰﾙ後に必要に応じて追加します。 実際に必要なﾃﾞｨｽｸの空き容量は、ｱﾌﾟﾘｹｰｼｮﾝのｲﾝｽﾄｰﾙやｽﾜｯﾌﾟ用領域としても必要ですので、上記以上の空き容量が必要になります。

Libretto20,30では、PCMCIAｿｹｯﾄが1つしかありませんので、一般的なｸﾘｰﾝ ｲﾝｽﾄｰﾙの方法と異なり、起動ﾃﾞｨｽｸ(FD)からﾊｰﾄﾞ ﾃﾞｨｽｸに起動用のDOSｼｽﾃﾑを作成し、ﾊｰﾄﾞ ﾃﾞｨｽｸを起動ﾃﾞｨｽｸとしてｲﾝｽﾄｰﾙします。 この結果、以前のｼｽﾃﾑ(DOS)を保存してのｲﾝｽﾄｰﾙとなりますので、完全なｸﾘｰﾝ ｲﾝｽﾄｰﾙと言う訳にはいきません。 またﾄﾞﾗｲﾊﾞも個別に提供されていませんので、ｲﾝｽﾄｰﾙ前にﾄﾞﾗｲﾊﾞの保存が必要になります。

1. | Libretto固有のﾄﾞﾗｲﾊﾞを保存します。
2. | 起動ﾃﾞｨｽｸを作成します。
3. | 起動ﾃﾞｨｽｸから立ち上げます。
4.必要ならば、ﾊﾟｰﾃｨｼｮﾝの切り直しを行います。
A:\>FDISK
5.ﾊｰﾄﾞ ﾃﾞｨｽｸをﾌｫｰﾏｯﾄします。
A:\>FORMAT C:
6.ﾊｰﾄﾞ ﾃﾞｨｽｸにｼｽﾃﾑを作成します。
A:\>SYS C:
7.ﾊｰﾄﾞ ﾃﾞｨｽｸにHD用のCONFIG.SYSとAUTOEXEC.BATをｺﾋﾟｰします。
A:\>COPY CONFIG.HD C:CONFIG.SYS /V
A:\>COPY AUTOEXEC.HD C:AUTOEXEC.BAT /V
8.ﾊｰﾄﾞ ﾃﾞｨｽｸにDOSﾌｫﾙﾀﾞを作成します。
A:\>C:
C:\>MD DOS
9.ﾊｰﾄﾞ ﾃﾞｨｽｸのDOSﾌｫﾙﾀﾞにﾌﾛｯﾋﾟｰ ﾃﾞｨｽｸのDOSﾌｫﾙﾀﾞの内容をｺﾋﾟｰします。
C:\>CD DOS
C:\DOS>COPY A:\DOS\*.* C: /V
10.ﾊｰﾄﾞ ﾃﾞｨｽｸにDRIVERﾌｫﾙﾀﾞを作成します。
C:\DOS>CD \
C:\>MD DRIVER
11. | FDを保存ﾄﾞﾗｲﾊﾞ ﾃﾞｨｽｸに入れ替えます。
12.ﾊｰﾄﾞ ﾃﾞｨｽｸのDRIVERﾌｫﾙﾀﾞにﾌﾛｯﾋﾟｰ ﾃﾞｨｽｸの内容をｺﾋﾟｰします。
C:\>CD DRIVER
C:\DRIVER>COPY A:\*.* C: /V
13. | FDDを外し、SCSI経由のCD-ROMなどのﾄﾞﾗｲﾌﾞに付け替え、ﾊｰﾄﾞ ﾃﾞｨｽｸから立ち上げます。
14.Windows98ｲﾝｽﾄｰﾙ ﾃﾞｨｽｸの\Win98ﾌｫﾙﾀﾞに切り替えます。
C:\>D:
D:\>CD WIN98
15.Setup.exeを起動します。
D:\Win98>SETUP /IE
16.途中でｶｰﾄﾞ(PCMCIA)経由でｲﾝｽﾄｰﾙを行いますかのﾒｯｾｰｼﾞが現れますので、以下の処理を行います。
① | はいを選択して、次へをｸﾘｯｸします。
② | 続いてDOSﾄﾞﾗｲﾊﾞの削除を行いますかのﾒｯｾｰｼﾞが現れます。 はいを選択して、次へをｸﾘｯｸします。
③ | CONFIG.SYSの内容編集画面が表示されますので、PCMCIA関係のﾄﾞﾗｲﾊﾞ(例ではASP36530.SYS, REXCD.SYS, REXDISK.SYS)を含む行が存在する場合、その行を選択 (ｸﾘｯｸ) し、次へをｸﾘｯｸします。
④ | AUTOEXEC.BATの内容編集画面が表示されますので、同様にEMM386.EXEを含む行が存在する場合、その行を選択して次へをｸﾘｯｸします。
⑤ | 以降は完了まで、次へをｸﾘｯｸします。
17.WindowsのSetup終了後、FD関係ﾄﾞﾗｲﾊﾞの登録を行います。
① | \DriverﾌｫﾙﾀﾞのTsbfdc.infを\Windows\infﾌｫﾙﾀﾞにｺﾋﾟｰします。
②\WindowsﾌｫﾙﾀﾞのSystem.iniﾌｧｲﾙの[386Enh]ｾｸｼｮﾝに次の1行を追加します。
device=fdcmon.vxd
③ | 以降、初めてFDDが接続されたときに、実際のｲﾝｽﾄｰﾙが行われます。
18.ﾃﾞｨｽﾌﾟﾚｲ ﾄﾞﾗｲﾊﾞの更新(仮想画面ｻﾎﾟｰﾄ)をします。
① | ﾏｲ ｺﾝﾋﾟｭｰﾀ⇒ｺﾝﾄﾛｰﾙ ﾊﾟﾈﾙ⇒ｼｽﾃﾑを選択し、ﾃﾞﾊﾞｲｽ ﾏﾈｰｼﾞｬﾀﾌﾞを選択します。
② | ﾃﾞｨｽﾌﾟﾚｲ ｱﾀﾞﾌﾟﾀをﾀﾞﾌﾞﾙｸﾘｯｸすると、直下にCirrus Logicが表示されます。
③ | Cirrus Logicをﾀﾞﾌﾞﾙｸﾘｯｸし、ﾌﾟﾛﾊﾟﾃｨを表示させ、ﾄﾞﾗｲﾊﾞﾀﾌﾞを選択します。
④ | ﾄﾞﾗｲﾊﾞの更新ﾎﾞﾀﾝをｸﾘｯｸし、ﾃﾞﾊﾞｲｽ ﾄﾞﾗｲﾊﾞの更新ｳｨｻﾞｰﾄﾞを表示させます。
⑤ | 次へ>ﾎﾞﾀﾝをｸﾘｯｸします。
⑥ | 特定の場所にあるすべてのﾄﾞﾗｲﾊﾞの一覧を作成し、ｲﾝｽﾄｰﾙするﾄﾞﾗｲﾊﾞを選択するを選択し、 次へ>ﾎﾞﾀﾝをｸﾘｯｸします。
⑦ | ﾃﾞｨｽｸ使用(H)...ﾎﾞﾀﾝをｸﾘｯｸし、ﾃﾞｨｽｸからｲﾝｽﾄｰﾙﾀﾞｲｱﾛｸﾞを表示させます。
⑧ | 配布ﾌｧｲﾙのｺﾋﾟｰ元:にC:\DRIVERを指定します。
⑨ | OKﾎﾞﾀﾝをｸﾘｯｸし、ﾃﾞﾊﾞｲｽの選択ﾀﾞｲｱﾛｸﾞを表示させます。
⑩ | Cirrus Logic 7548 1.21t (Cirrus)を選択し、OKﾎﾞﾀﾝをｸﾘｯｸします。
⑪ | 正常に動作しないかも・・・ﾒｯｾｰｼﾞが表示されますが、はいﾎﾞﾀﾝをｸﾘｯｸしてください。
⑫ | ｲﾝｽﾄｰﾙが終了すると再起動のﾀﾞｲｱﾛｸﾞが表示されますので、再起動を行います。 再起動後に新ﾄﾞﾗｲﾊﾞが有効となります。
⑬ | ﾃﾞｨｽｸ ﾄｯﾌﾟでの右ｸﾘｯｸ ﾒﾆｭｰのﾌﾟﾛﾊﾟﾃｨ画面の設定ﾀﾌﾞで色数、解像度を設定します。


Libretto固有ﾄﾞﾗｲﾊﾞの保存

4.1 Libretto固有ﾄﾞﾗｲﾊﾞの保存

Libretto固有ﾄﾞﾗｲﾊﾞ関係を次の手順でﾌﾛｯﾋﾟｰ ﾃﾞｨｽｸなどへ保存します。

1.現在のWindows95上の以下のﾌｧｲﾙを保存します。

\Windows\Inf\Tsbfdc.inf
FD用ｲﾈｰﾌﾞﾗ
\Windows\System\Fdcmon.vxd
FD仮想ﾄﾞﾗｲﾊﾞ
\Tosutils\Fd12.sys
1.2/1.4FDﾃﾞﾊﾞｲｽ ﾄﾞﾗｲﾊﾞ
\Windows\Inf\754x.inf
ﾃﾞｨｽﾌﾟﾚｲ ｲﾈｰﾌﾞﾗ
\Windows\System\Cirl.drv
ﾃﾞｨｽﾌﾟﾚｲ ﾄﾞﾗｲﾊﾞ
\Windows\System\Cirl.vxd
ﾃﾞｨｽﾌﾟﾚｲ仮想ﾄﾞﾗｲﾊﾞ
\Windows\System\Cldd16.dll
ﾃﾞｨｽﾌﾟﾚｲ用ﾀﾞｲﾅﾐｯｸ ﾘﾝｸ ﾗｲﾌﾞﾗﾘ
\Windows\System\Cldd32.dll
ﾃﾞｨｽﾌﾟﾚｲ用ﾀﾞｲﾅﾐｯｸ ﾘﾝｸ ﾗｲﾌﾞﾗﾘ

\Windowsﾌｫﾙﾀﾞ以下の各ﾌｧｲﾙは、\Windows\Options\Cabsﾌｫﾙﾀﾞにも存在します。


Libretto用起動ﾃﾞｨｽｸ作成

4.2 Libretto用起動ﾃﾞｨｽｸ作成

Libretto用起動ﾃﾞｨｽｸも基本的には、一般の起動ﾃﾞｨｽｸ作成手順と同じですが、次の2点が異なります。

① | DOS用のPCMCIAﾄﾞﾗｲﾊﾞは、ﾎﾟｲﾝﾄ ｲﾈｰﾌﾞﾗ形式が無難です。 ｿｹｯﾄ ｻｰﾋﾞｽ、ｶｰﾄﾞ ｻｰﾋﾞｽ形式では、動作しないものやﾊﾟﾗﾒｰﾀ設定が必要なものなどもあり、ﾄﾗﾌﾞﾙの可能性が大きくなります。
② | FD起動用とHD起動用のCONFIG.SYSとAUTOEXEC.BATが各々必要です。

②は最終的にﾊｰﾄﾞ ﾃﾞｨｽｸからの起動状態でｲﾝｽﾄｰﾙを行いますので、ﾌﾛｯﾋﾟｰ ﾃﾞｨｽｸとﾊｰﾄﾞ ﾃﾞｨｽｸ用の2種類が必要になります。

1. | 現在動作中のWindows95で3.5ｲﾝﾁFDのｼｽﾃﾑ ﾃﾞｨｽｸを作成します。
2. | ﾒﾓ帳(NOTEPAD)などを使用して、HD用のCONFIG.SYSをﾌｧｲﾙ名CONFIG.HDで作成します。
1
DEVICE=\DOS\HIMEM.SYS /TESTMEM:OFF
2
DEVICEHIGH=\DOS\EMM386.EXE RAM 512 FRAME=D000 X=CE00-CFFF
3
FILES=10
4
BUFFERS=10
5
DOS=HIGH,UMB
6
STACKS=9,256
7
DEVICEHIGH=\DOS\BILING.SYS
8
DEVICEHIGH=\DOS\JFONT.SYS /P=\DOS\ /MSG=OFF
9
DEVICEHIGH=\DOS\JDISP.SYS /HS=LC
10
DEVICEHIGH=\DOS\JKEYB.SYS /106 \DOS\JKEYBRD.SYS
11
DEVICEHIGH=\DOS\IBMDSS01.SYS
ｿｹｯﾄ ｻｰﾋﾞｽ
12
DEVICEHIGH=\DOS\IBMDOSCS.SYS
ｶｰﾄﾞ ｻｰﾋﾞｽ
13
DEVICEHIGH=\DOS\ASPI9530.SYS
ASPIﾏﾈｰｼﾞｬ
14
DEVICEHIGH=\DOS\ASP36530.SYS
ASPIﾏﾈｰｼﾞｬｰ/ﾎﾟｲﾝﾄ ｲﾈｰﾌﾞﾗ
15
DEVICEHIGH=\DOS\REXCD.SYS /D:CD001
CD-ROMﾄﾞﾗｲﾊﾞ
16
DEVICEHIGH=\DOS\REXDISK.SYS
HD,MOﾄﾞﾗｲﾊﾞ
17
LASTDRIVE=Z
11～13行は、ｿｹｯﾄ ｻｰﾋﾞｽ、ｶｰﾄﾞ ｻｰﾋﾞｽ形式の場合に記述し、14行目は記述しません。 同様に、ﾎﾟｲﾝﾄ ｲﾈｰﾌﾞﾗ形式の場合は、14行目を記述し、11～13行は記述しません。
11のｿｹｯﾄ ｻｰﾋﾞｽと12行のｶｰﾄﾞ ｻｰﾋﾞｽは、基本的に本体付属ですが、Librettoの場合、付属していませんので、SCSIｶｰﾄﾞやCD-ROMなどに付属していない限りは別途入手(購入)することになります。
13行のASPIﾏﾈｰｼﾞｬｰ、14行のASPIﾏﾈｰｼﾞｬｰ/ﾎﾟｲﾝﾄ ｲﾈｰﾌﾞﾗ、15,16行のﾄﾞﾗｲﾊﾞは、SCSIｶｰﾄﾞに附属していますが、ﾎﾟｲﾝﾄ ｲﾈｰﾌﾞﾗが附属していないSCSIｶｰﾄﾞもあります。 上記はRATOCのREX9530の例です。
15,16行のﾄﾞﾗｲﾊﾞは、実際に使用するﾃﾞﾊﾞｲｽに対応している方のみ記述します。
3. | 同様にFD用のCONFIG.SYSをﾌｧｲﾙ名CONFIG.SYSで作成します。
内容はHD用のCONFIG.SYS(CONFIG.HD)の11～16行目を削除したものです。
4. | ﾒﾓ帳(NOTEPAD)などを使用して、HD用のAUTOEXEC.BATをﾌｧｲﾙ名AUTOEXEC.HDで作成します。
1
@ECHO OFF
2
SET TEMP=\DOS
3
SET TMP=\DOS
4
PATH=\;\DOS
5
PROMPT $p$g
6
SET COMSPEC=\COMMAND.COM
7
@ECHO ON
8
LH \DOS\MSCDEX.EXE /D:CD001 /L:D
8のMSCDEX.EXEは、CD-ROMを使用する場合のみ必要です。 SCSI経由のﾊｰﾄﾞ ﾃﾞｨｽｸ、MOなどの場合、この行は必要ありません。
5. | 同様にFD用のAUTOEXEC.BATをﾌｧｲﾙ名AUTOEXEC.BATで作成します。
内容はHD用のAUTOEXEC.BAT(AUTOEXEC.HD)の8行目を削除したものです。
6. | 起動ﾃﾞｨｽｸにDOSﾌｫﾙﾀﾞを作成します。
7. | 起動ﾃﾞｨｽｸのDOSﾌｫﾙﾀﾞに以下のﾌｧｲﾙをｺﾋﾟｰします。
1
\Windows\Ank16.fnt
2
\Windows\Ank19.fnt
3
\Windows\Biling.sys
4
\Windows\Command\Fdisk.exe
5
\Windows\Command\Format.com
6
\Windows\Himem.sys
7
\Windows\Jdisp.sys
8
\Windows\Jfont.sys
9
\Windows\Jkeyb.sys
10
\Windows\Jkeybrd.sys
11
\Windows\Kanji16.fnt
12
\Windows\Command\Mscdex.exe
13
\Windows\Command\Sys.com
11
IBMDSS01.SYS
ｿｹｯﾄ ｻｰﾋﾞｽ
12
IBMDOSCS.SYS
ｶｰﾄﾞ ｻｰﾋﾞｽ
13
ASPI9530.SYS
ASPIﾏﾈｰｼﾞｬ
14
ASP36530.SYS
ASPIﾏﾈｰｼﾞｬｰ/ﾎﾟｲﾝﾄ ｲﾈｰﾌﾞﾗ
15
REXCD.SYS
CD-ROMﾄﾞﾗｲﾊﾞ
16
REXDISK.SYS
HD,MOﾄﾞﾗｲﾊﾞ
下部の11～16は、2.で使用する(記述した)ﾌｧｲﾙのみが必要です。


ThinkPad560のｲﾝｽﾄｰﾙ

5. ThinkPad560のｲﾝｽﾄｰﾙ

ThinkPad560にWindows98SEやWindows2000をｲﾝｽﾄｰﾙする場合、ﾒﾓﾘ容量が問題になります。 Windows2000をｲﾝｽﾄｰﾙする場合は、HDD容量も問題になります。 各Windowsに対する必要条件については、必要条件をご覧ください。

Windows98SEとWindows2000共、ｲﾝｽﾄｰﾙ自体は一般的なｲﾝｽﾄｰﾙで問題なくｲﾝｽﾄｰﾙできますが、HD(IDE)ﾄﾞﾗｲﾊﾞが機種固有のﾄﾞﾗｲﾊﾞではなく、汎用ﾄﾞﾗｲﾊﾞがｲﾝｽﾄｰﾙされます。 これによる動作障害はありませんが、HDがPIO4ﾓｰﾄﾞでの動作になります。

Windows98SEのｲﾝｽﾄｰﾙ

Windows98SEのｲﾝｽﾄｰﾙは一般的な起動FDからのｲﾝｽﾄｰﾙです。
1.起動ﾃﾞｨｽｸを作成します。
起動ﾃﾞｨｽｸは一般的な方法と同一です。
  • ｶｰﾄﾞ ｻｰﾋﾞｽはIBMDSS01.SYSです。
  • ｿｹｯﾄ ｻｰﾋﾞｽはIBMDOSCS.SYSです。
IBMDSS01.SYS,IBMDOSCS.SYSはﾃﾞｨｽｹｯﾄ ﾌｧｸﾄﾘのThinkPad PCMCIAｻﾎﾟｰﾄで作成したFD内にあります。
2. | 起動ﾃﾞｨｽｸから立ち上げます。
3.必要ならば、ﾊﾟｰﾃｨｼｮﾝの切り直しを行います。
A:\>FDISK
4.ﾊｰﾄﾞ ﾃﾞｨｽｸをﾌｫｰﾏｯﾄします。
A:\>FORMAT C:
5.Windows98ｲﾝｽﾄｰﾙ ﾃﾞｨｽｸの\Win98ﾌｫﾙﾀﾞに切り替えます。
A:\>D:
D:\>CD WIN98
6.Setup.exeを起動します。
D:\Win98>SETUP /IE
7.途中でｶｰﾄﾞ(PCMCIA)経由でｲﾝｽﾄｰﾙを行いますかのﾒｯｾｰｼﾞが現れますので、以下の処理を行います。
① | はいを選択して、次へをｸﾘｯｸします。
② | 続いてDOSﾄﾞﾗｲﾊﾞの削除を行いますかのﾒｯｾｰｼﾞが現れます。いいえを選択して、次へをｸﾘｯｸします。
8. | Windows98SEのSetup終了後、画面のﾌﾟﾛﾊﾟﾃｨで解像度(800×600)と色数(16ﾋﾞｯﾄ)を設定します。
9. | 必要ならばPCｶｰﾄﾞ類のﾄﾞﾗｲﾊﾞ ｲﾝｽﾄｰﾙを行います。

注:HDDに対してDisk Managerを導入している場合、上記手順の 3.と4.は、Disk Manager導入時に行なってください。

この方法以外にも、例えば以下のWindows2000ｲﾝｽﾄｰﾙと同様な方法も可能です。 この場合は、WIN98ﾌｫﾙﾀﾞ内容を複写し、Setup.exeを実行します。

Windows2000のｲﾝｽﾄｰﾙ

使用するCDﾄﾞﾗｲﾌﾞ環境に関係する機材について、ｲﾝｽﾄｰﾙ用ﾄﾞﾗｲﾊﾞが製造業者から供給されていれば、Windows98SEと同様な方法でｲﾝｽﾄｰﾙを行なうことができます。 しかし、これらが入手できない場合には、別の方法で行なわなければなりません。 SCSI経由のCDﾄﾞﾗｲﾌﾞなどの場合、ｲﾝｽﾄｰﾙ中にCDﾄﾞﾗｲﾌﾞがｱｸｾｽできなくなり、ｲﾝｽﾄｰﾙが中断してしまいますので、これを避けるために、予め必要なｲﾝｽﾄｰﾙ用ﾌｧｲﾙをﾊｰﾄﾞ ﾃﾞｨｽｸに複写し、それでｲﾝｽﾄｰﾙを行います。

1.起動ﾃﾞｨｽｸを作成します。
起動ﾃﾞｨｽｸは一般的な方法と同一です。
  • ｶｰﾄﾞ ｻｰﾋﾞｽはIBMDSS01.SYSです。
  • ｿｹｯﾄ ｻｰﾋﾞｽはIBMDOSCS.SYSです。
IBMDSS01.SYS,IBMDOSCS.SYSはﾃﾞｨｽｹｯﾄ ﾌｧｸﾄﾘのThinkPad PCMCIAｻﾎﾟｰﾄで作成したFD内にあります。
2. | 起動ﾃﾞｨｽｸから立ち上げます。
3.必要ならば、ﾊﾟｰﾃｨｼｮﾝの切り直しを行います。
A:\>FDISK
4.ﾊｰﾄﾞ ﾃﾞｨｽｸをﾌｫｰﾏｯﾄします。
A:\>FORMAT C:
5.ﾊｰﾄﾞ ﾃﾞｨｽｸにｲﾝｽﾄｰﾙ ﾌｧｲﾙ保存ﾌｫﾙﾀﾞ(WIN2000)を作成します。
A:\>C:
C:\>MD WIN2000
6.作成したWIN2000ﾌｫﾙﾀﾞ下に元の保存ﾌｧﾙﾀﾞを作成します。
C:\>CD WIN2000
C:\WIN2000>MD I386
7.ﾊｰﾄﾞ ﾃﾞｨｽｸのI386ﾌｫﾙﾀﾞにｲﾝｽﾄｰﾙCDのI386ﾌｫﾙﾀﾞ下のﾌｧｲﾙを複写します。
C:\WIN2000>CD I386
C:\WIN2000\I386>D:
D:\>CD I386
D:\I386>COPY D:*.* C: /V
8. | 複写が終了したなら、PCｶｰﾄﾞを取り外します。 これはｲﾝｽﾄｰﾙ中の停止/中断を避けるためです。
9.ﾊｰﾄﾞ ﾃﾞｨｽｸのI386ﾌｫﾙﾀﾞからWINNT.EXEを起動します。
D:\I386>C:
C:\WIN2000\I386>WINNT
10. | Windows2000のｲﾝｽﾄｰﾙ終了後、画面のﾌﾟﾛﾊﾟﾃｨで解像度(800×600)と色数(16ﾋﾞｯﾄ)を設定します。
11. | 必要ならばPCｶｰﾄﾞ類のﾄﾞﾗｲﾊﾞ ｲﾝｽﾄｰﾙを行います。

注:HDDに対してDisk Managerを導入している場合、上記手順の 3.と4.は、Disk Manager導入時に行なってください。

既にWindows9x系が動作している場合には、上記手順の殆どが省略できます。

1. | ｲﾝｽﾄｰﾙCDのI386ﾌｫﾙﾀﾞでｺﾏﾝﾄﾞ行から WINNT32 /makelocalsource でｲﾝｽﾄｰﾙを開始します。
2. | ｲﾝｽﾄｰﾙ中の停止/中断を避けるため、最初の再起動でPCｶｰﾄﾞ類を全て取り去ります。
3. | 必要ならばPCｶｰﾄﾞ類のﾄﾞﾗｲﾊﾞ ｲﾝｽﾄｰﾙを行います。

ｲﾝｽﾄｰﾙ中に新規ｲﾝｽﾄｰﾙを選択すれば、現在のWindows9x系とのﾃﾞｭｱﾙﾌﾞｰﾄになります。 ﾃﾞｭｱﾙﾌﾞｰﾄ時の各OS起動方法や一般的な制限事項はPCｶｰﾄﾞ ｲﾝﾀｰﾌｪｰｽ変更を除いて、Let's note mini AL-N4の注意事項と同じです。

固有の制限事項として、ｽﾀﾝﾊﾞｲ動作がｻﾎﾟｰﾄされません。


Let's note mini AL-N4のｲﾝｽﾄｰﾙ

6. Let's note mini AL-N4のｲﾝｽﾄｰﾙ

Let's note mini AL-N4にWindows98SEやWindows2000をｲﾝｽﾄｰﾙする場合、ﾒﾓﾘ容量が問題になります。 Windows2000をｲﾝｽﾄｰﾙする場合は、HDD容量も問題になります。 各Windowsに対する必要条件については、必要条件をご覧ください。

Windows98SEのｲﾝｽﾄｰﾙではPCｶｰﾄﾞ(PCMCIA)が若干問題になります。 一般的なｲﾝｽﾄｰﾙでも一応動作するのですが、2枚使用時に問題が起きます。 この問題に対しては、製造業者が供給しているWindows98ｱｯﾌﾟｸﾞﾚｰﾄﾞ ｷｯﾄ(Type1)内のﾊﾞｯﾁ ﾌｧｲﾙ実行で対処できます。 Windows2000では問題ありません。

Windows98SEとWindows2000共、HD(IDE)ﾄﾞﾗｲﾊﾞが機種固有のﾄﾞﾗｲﾊﾞではなく、汎用ﾄﾞﾗｲﾊﾞがｲﾝｽﾄｰﾙされます。 これによる動作障害はありませんが、HDがPIO4ﾓｰﾄﾞでの動作になります。

Windows98SEのｲﾝｽﾄｰﾙ

Windows98SEのｲﾝｽﾄｰﾙは一般的な起動FDからのｲﾝｽﾄｰﾙです。 このｲﾝｽﾄｰﾙはDOSから行いますが、DOSのPCMCIA関係ﾄﾞﾗｲﾊﾞがCardBusに対応していないため、予めﾊﾟｿｺﾝ起動時の F1 で、[PCIC互換]設定にしておく必要があります。

1.起動ﾃﾞｨｽｸを作成します。
この段階での起動ﾃﾞｨｽｸは一般的な方法と同一です。
  • ｶｰﾄﾞ ｻｰﾋﾞｽはIBMDSS01.SYSです。
  • ｿｹｯﾄ ｻｰﾋﾞｽはIBMDOSCS.SYSです。
2. | PCｶｰﾄﾞ用ﾊﾞｯﾁ関係ﾌｧｲﾙを入手/保存します。
3. | 起動ﾃﾞｨｽｸから立ち上げます。
4.必要ならば、ﾊﾟｰﾃｨｼｮﾝの切り直しを行います。
A:\>FDISK
5.ﾊｰﾄﾞ ﾃﾞｨｽｸをﾌｫｰﾏｯﾄします。
A:\>FORMAT C:
5.起動FD内のPCCARD98ﾌｫﾙﾀﾞをﾊｰﾄﾞ ﾃﾞｨｽｸ(C:)に複写します。
A:\>CD PCCARD98
A:\PCCARD98>C:
C:\>MD UTIL
C:\>CD UTIL
C:\UTIL>MD PCCARD98
C:\UTIL>CD PCCARD98
C:\UTIL\PCCARD98>COPY A:*.* /V
6.Windows98SE CDのWIN98ﾌｫﾙﾀﾞをﾊｰﾄﾞ ﾃﾞｨｽｸ(C:)に複写します。
C:\UTIL\PCCARD98>CD \
C:\>MD WIN98
C:\>CD WIN98
C:\WIN98>COPY D:WIN98\*.* /V
7. | ｲﾝｽﾄｰﾙ中に[ﾃﾞﾊﾞｲｽの設定]で停止する可能性があるため、全PCｶｰﾄﾞを一旦抜きます。
8.Windows98SEのｲﾝｽﾄｰﾙを開始します。
C:\WIN98>SETUP /IE
9.[PCｶｰﾄﾞ(PCMCIA)ｳｨｻﾞｰﾄﾞ]が表示されたなら、以下に従います。
① | [いいえ]を選択して、[次へ>]をｸﾘｯｸします。
② | [はい]を選択して、[次へ>]をｸﾘｯｸします。
③ | CONFIG.SYS内容表示で、下端のPCｶｰﾄﾞ関係ﾄﾞﾗｲﾊﾞ行を選択して、[次へ>]をｸﾘｯｸします。
④ | AUTOEXEC.BAT内容表示で、LH \DOS\MSCDEX.EXE /D:MSCD001 /L:D行を選択して、[次へ>]をｸﾘｯｸします。
⑤ | SYSTEM.INI内容表示で、[次へ>]をｸﾘｯｸします。
⑥ | [完了]をｸﾘｯｸします。
10. | ｲﾝｽﾄｰﾙが終了したなら、 ﾀｽｸﾊﾞｰに音量ｱｲｺﾝを表示するために、ｺﾝﾄﾛｰﾙ ﾊﾟﾈﾙのﾏﾙﾁﾒﾃﾞｨｱを開き、[OK]で終了します。
11.PCｶｰﾄﾞ ｲﾝﾀｰﾌｪｰｽを以下に従って設定します。
① | 再起動し、Press F1 for SetupでPCｶｰﾄﾞI/Fを[Card Bus]にしてWindows98SEを起動します。
② | C:\UTIL\PCCARD98ﾌｫﾙﾀﾞのChgcb.batを実行し、[Y]で答えます。
③ | 再起動します。
12. | Windows98SEのSetup終了後、画面のﾌﾟﾛﾊﾟﾃｨで解像度(800×600)と色数(16ﾋﾞｯﾄ)を設定します。
13. | 必要ならばPCｶｰﾄﾞ類のﾄﾞﾗｲﾊﾞ ｲﾝｽﾄｰﾙを行います。

注:HDDに対してDisk Managerを導入している場合、上記手順の 4.と5.は、Disk Manager導入時に行なってください。

Windows2000のｲﾝｽﾄｰﾙ

使用するCDﾄﾞﾗｲﾌﾞ環境に関係する機材について、ｲﾝｽﾄｰﾙ用ﾄﾞﾗｲﾊﾞが製造業者から供給されていれば、起動FDから直接ｲﾝｽﾄｰﾙを行なうことができます。 しかし、これらが入手できない場合には、別の方法で行なわなければなりません。 SCSI経由のCDﾄﾞﾗｲﾌﾞなどの場合、ｲﾝｽﾄｰﾙ中にCDﾄﾞﾗｲﾌﾞがｱｸｾｽできなくなり、ｲﾝｽﾄｰﾙが中断してしまいますので、これを避けるために、予め必要なｲﾝｽﾄｰﾙ用ﾌｧｲﾙをﾊｰﾄﾞ ﾃﾞｨｽｸに複写し、それでｲﾝｽﾄｰﾙを行います。

1.起動ﾃﾞｨｽｸを作成します。
起動ﾃﾞｨｽｸは一般的な方法と同一です。
  • ｶｰﾄﾞ ｻｰﾋﾞｽはIBMDSS01.SYSです。
  • ｿｹｯﾄ ｻｰﾋﾞｽはIBMDOSCS.SYSです。
2. | 起動ﾃﾞｨｽｸから立ち上げます。
3.必要ならば、ﾊﾟｰﾃｨｼｮﾝの切り直しを行います。
A:\>FDISK
4.ﾊｰﾄﾞ ﾃﾞｨｽｸをﾌｫｰﾏｯﾄします。
A:\>FORMAT C:
5.ﾊｰﾄﾞ ﾃﾞｨｽｸにｲﾝｽﾄｰﾙ ﾌｧｲﾙ保存ﾌｫﾙﾀﾞ(WIN2000)を作成します。
A:\>C:
C:\>MD WIN2000
6.作成したWIN2000ﾌｫﾙﾀﾞ下に元の保存ﾌｧﾙﾀﾞを作成します。
C:\>CD WIN2000
C:\WIN2000>MD I386
7.ﾊｰﾄﾞ ﾃﾞｨｽｸのI386ﾌｫﾙﾀﾞにｲﾝｽﾄｰﾙCDのI386ﾌｫﾙﾀﾞ下のﾌｧｲﾙを複写します。
C:\WIN2000>CD I386
C:\WIN2000\I386>D:
D:\>CD I386
D:\I386>COPY D:*.* C: /V
8. | 複写が終了したなら、PCｶｰﾄﾞを取り外します。 これはｲﾝｽﾄｰﾙ中の停止/中断を避けるためです。
9.ﾊｰﾄﾞ ﾃﾞｨｽｸのI386ﾌｫﾙﾀﾞからWINNT.EXEを起動します。
D:\I386>C:
C:\WIN2000\I386>WINNT
10. | Windows2000のｲﾝｽﾄｰﾙ終了後、画面のﾌﾟﾛﾊﾟﾃｨで解像度(800×600)と色数(16ﾋﾞｯﾄ)を設定します。
11. | 必要ならばPCｶｰﾄﾞ類のﾄﾞﾗｲﾊﾞ ｲﾝｽﾄｰﾙを行います。

注:HDDに対してDisk Managerを導入している場合、上記手順の 3.と4.は、Disk Manager導入時に行なってください。

既にWindows9x系が動作している場合には、上記手順の殆どが省略できます。

1. | ｲﾝｽﾄｰﾙCDのI386ﾌｫﾙﾀﾞでｺﾏﾝﾄﾞ行から WINNT32 /makelocalsource でｲﾝｽﾄｰﾙを開始します。
2. | ｲﾝｽﾄｰﾙ中の停止/中断を避けるため、最初の再起動でPCｶｰﾄﾞ類を全て取り去ります。
3. | 必要ならばPCｶｰﾄﾞ類のﾄﾞﾗｲﾊﾞ ｲﾝｽﾄｰﾙを行います。

ｲﾝｽﾄｰﾙ中に新規ｲﾝｽﾄｰﾙを選択すれば、現在のWindows9x系とのﾃﾞｭｱﾙﾌﾞｰﾄになります。 ﾃﾞｭｱﾙﾌﾞｰﾄ時の各OS起動方法や一般的な制限事項は注意事項をご覧ください。


Let's note mini AL-N4関係ﾌｧｲﾙの入手と注意

6.1 Let's note mini AL-N4関係ﾌｧｲﾙの入手と注意

関係ﾌｧｲﾙの入手

Let's note mini AL-N4へのWindows98SEｲﾝｽﾄｰﾙでは、PCｶｰﾄﾞ(PCMCIA)を正しく動作させるために、ﾚｼﾞｽﾄﾘ情報を追加/変更しなければなりません。 これはﾊﾞｯﾁ ﾌｧｲﾙとして存在します。 製造業者ｻｲﾄのLet's note mini AL-N4用Windows98ｱｯﾌﾟｸﾞﾚｰﾄﾞ ｷｯﾄ(TYPE1)内に、関係ﾌｧｲﾙが含まれています。 ﾀﾞｳﾝﾛｰﾄﾞ、解凍後の TYPE1\TYPE1\UTIL\PCCARD98 ﾌｫﾙﾀﾞ内の下記のﾌｧｲﾙを起動FD内の PCCARD98 ﾌｫﾙﾀﾞに保存します。

cbreg.exe
ﾚｼﾞｽﾄﾘ追加/変更ﾌﾟﾛｸﾞﾗﾑ
CHGCB
Chgcb.bat用PIF
Chgcb.bat
ｶｰﾄﾞ ﾊﾞｽ指定ﾊﾞｯﾁ
MACHINE2.EXE
機種認識ﾌﾟﾛｸﾞﾗﾑ

このﾊﾞｯﾁ内のﾊﾟｽが絶対ﾊﾟｽで記述されているため、最終的に、これらはC:ﾄﾞﾗｲﾌﾞの \UTIL\PCCARD98 ﾌｫﾙﾀﾞ内に存在しなければなりません。 従って、作業中に起動FDからﾊｰﾄﾞ ﾃﾞｨｽｸ(C:ﾄﾞﾗｲﾌﾞ)の正しいﾊﾟｽ上に複写します。

注意事項

■ ﾏﾙﾁﾌﾞｰﾄ

DOSを含むﾏﾙﾁﾌﾞｰﾄ構成にした場合、それらの起動方法とPCｶｰﾄﾞ ｲﾝﾀｰﾌｪｰｽの扱いに注意を要します。

Windows2000の起動

  1. BIOSでPCｶｰﾄﾞ ｲﾝﾀｰﾌｪｰｽがPCIC互換の場合、起動時に Press F1 for Setup でPCｶｰﾄﾞ ｲﾝﾀｰﾌｪｰｽをCard Busにします。
  2. OS選択ﾒﾆｭｰで Microsoft Windows 2000 professional を選択します。
  3. Enterｷｰを押下します。

Windows98SEの起動

  1. BIOSでPCｶｰﾄﾞ ｲﾝﾀｰﾌｪｰｽがPCIC互換の場合、起動時に Press F1 for Setup でPCｶｰﾄﾞ ｲﾝﾀｰﾌｪｰｽをCard Busにします。
  2. OS選択ﾒﾆｭｰで Microsoft Windows を選択します。
  3. Enterｷｰを押下します。
注:PCIC互換のままでWindows98SEを起動してしまった場合、Windows98SEｲﾝｽﾄｰﾙの手順11.を行なう必要があります。

MS-DOSの起動

  1. BIOSでPCｶｰﾄﾞ ｲﾝﾀｰﾌｪｰｽがCard Busの場合、起動時に Press F1 for Setup でPCｶｰﾄﾞ ｲﾝﾀｰﾌｪｰｽをPCIC互換にします。
  2. OS選択ﾒﾆｭｰで Microsoft Windows を選択します。
  3. Enterｷｰを押下後、1秒以内にF8ｷｰを押下します。
  4. Microsoft Windows 98 Startup Menu で 7. Previous version of MS-DOS を選択します。
  5. Enterｷｰを押下します。
注:MS-DOS使用完了後、誤動作防止のため、Card Busに戻すべきです。

■ 制限事項

  1. Windows98SEではLANｶｰﾄﾞが挿入されたままで再起動、終了が停止する場合があります。 この場合、約20s経過後に電源ｽｨｯﾁをOFFにしてください。 再起動の場合は、その後、5s後に電源ｽｨｯﾁをONにしてください。
  2. 活線挿抜が正常に行なわれない場合は、最新ﾄﾞﾗｲﾊﾞに更新してみてください。 認識されない場合、起動時に挿入されていれば認識される事があります。
  3. WindowsのDOS窓では基本的にPCｶｰﾄﾞが使用できません。


追補

■ Disk Manager
■ ｲﾝｽﾄｰﾙの自動化
■ 1ｿｹｯﾄでのﾄﾞﾗｲﾊﾞ追加


Disk Manager

追補 Disk Manager

Disk ManagerはKroll Ontrack社が販売するHDDｲﾝｽﾄｰﾙ ﾂｰﾙです。 現在、Kroll Ontrackから販売されているものは、既にWindowsが動作している環境にｲﾝｽﾄｰﾙする形式で、俗に言う母艦方式で新規HDDをｲﾝｽﾄｰﾙする事を主たる目的にしたものですが、Disk Managerを含むDR-DOS起動のFD 1枚を作成する機能を含んでいます。 OEM版などでは、この部分のみを別ﾌﾟﾛｸﾞﾗﾑとしても提供しています。

過去にはIBM(その後HGST)がOEM版として、FD版をDM955.EXE(Ver9.55)として、Windows版をDM_2000.EXE(Ver3.11.14等)として提供していました。 現在、製造業者ｻｲﾄからは既に入手できませんが、提供時の上記ﾌｧｲﾙ名で検索すれば、ﾈｯﾄ上から得られるでしょう。

本資料作成時点で、Disk Manager関係ﾌｧｲﾙはSeagate社のｻｲﾄよりﾀﾞｳﾝﾛｰﾄﾞが可能です。 FD版のDisk Manager Ver9.55は更新されたDisk Manager Ver9.56aがﾀﾞｳﾝﾛｰﾄﾞできます。 更にFD 2枚が必要ですが、VGAのWindows GUI化され、更新されたVer10.45.06がDiscWizard Starter Editionとしてﾀﾞｳﾝﾛｰﾄﾞできます。 またWindows版のDisk Manager 2000の更新版(Ver4.09.05)がDiscWizard for Windowsとしてﾀﾞｳﾝﾛｰﾄﾞできます。 DiskWizardには日本語版もあります。

これら全てに共通ですが、全てのHDDを扱える訳ではありません。 基本的にOEM版の場合、一部の機能はその製造業者用に特化されています。 従って、その部分に対して、他社製品はその機能を利用できません。 また、一部の機能はDisk Manager内に保持するHDD情報内でしか動作しません。 従って、HDDが新機種の場合、動作できない機能がある場合があります。

ここでは既に提供を終了したIBM(その後HGST) OEM版Disk Manager Ver9.55を基に記述します。

DM955.EXEはWindowsのｲﾝｽﾄｰﾗ形式でA:ﾄﾞﾗｲﾌﾞのFDに、DR-DOS起動ﾃﾞｨｽｸとしてDisk Managerをｲﾝｽﾄｰﾙします。 対象HDDが装着された目的ﾏｼﾝで、この作成されたFDから起動することで実際のHDD操作を行います。

概要

Disk Managerには種々の機能がありますが、一番有用なのがDDO(Dynamic Drive Overlay)機能です。 これはBIOSが認識可能な容量を超えるHDDの使用を可能にします。 HDDは(容量を表すCHSなどの)ｼﾞｵﾒﾄﾘ情報とその他の情報をEEPROM(不揮発性ﾒﾓﾘ)に持ちます。 HDDは電源投入時、その内容をRAM(揮発性ﾒﾓﾘ)に読み出し、初期設定を行ないます。 従って、このｼﾞｵﾒﾄﾘ情報はRAM値を変更することにより、通電中だけEEPROM値と異なるｼﾞｵﾒﾄﾘ値のHDDとして動作できます。 DDOはこれを利用して、EEPROM値をBIOSが認識可能な範囲の値とし、OSの起動直前にRAM値を本来(HDD総容量)値とすることで、大容量HDDの使用を可能にします。

BIOSはPOST(電源投入時自己検査)でﾊｰﾄﾞｳｪｱ関係を検査/認識し、FDやHDなどのﾌﾞｰﾄ ﾃﾞﾊﾞｲｽが利用可能であれば、BIOSで設定された優先順位に従って対応ﾃﾞﾊﾞｲｽからﾌﾞｰﾄを開始します。 従って、このﾌﾞｰﾄ作業完了時まで、BIOSが認識可能なHDD容量であれば良いことが判ります。 そこで、HDD先頭部に書き込まれるﾌﾞｰﾄﾛｰﾀﾞでHDD容量一時変更を行なうようにします。 しかし、これだけではBIOSのHD BIOSが、認識された容量以上を扱わないため、その後のﾌﾟﾛｸﾞﾗﾑでも、この容量になってしまいます。 このため、ﾌﾞｰﾄﾛｰﾀﾞでのHDD容量一時変更と同時に、HD BIOS(INT 13H)をﾌｯｸする拡張HD BIOSも読み込みます。 即ち本来のﾌﾞｰﾄﾛｰﾀﾞの機能に加えて、HDD容量一時変更と拡張HD BIOS設定を含めたﾌﾞｰﾄﾛｰﾀﾞをHDDに書き込むことになります。

 | 1. 電源ON
再起動→ | 2. BIOS HD認識
 | 3. FD優先/FDありでFD起動
 | 4. HDあり/有効でHD先頭のﾌﾞｰﾄﾛｰﾀﾞ読み込み実行
 | 5. ﾌﾞｰﾄﾛｰﾀﾞ OS読み込み実行

この方法では、再起動時に取得されるｼﾞｵﾒﾄﾘ値は変更後のRAM値になってしまいますので、BIOSで正常に認識されません。 従って、再起動時は常に電源OFF後のONを行なう必要があります。 このﾀｲﾐﾝｸﾞはBIOSﾒｯｾｰｼﾞ表示が確実に現れた後でなければなりません。

また、BIOS設定で起動順位がFD⇒HDとしている場合、上図の3.でFD起動となり、4.のDDO処置が行なわれていませんので、HDDはBIOSが認識したEEPROM値になってしまいます。 このため、本処置を行なった場合、4.での処置完了後、ｽﾍﾟｰｽ ｷｰでFD起動を行なえるﾒｯｾｰｼﾞが一瞬表れ、このﾀｲﾐﾝｸﾞによって大容量HDDｻﾎﾟｰﾄのFD起動を可能にしています。

上記2点の注意とﾊｰﾄﾞｳｪｱを直接制御するようなﾌﾟﾛｸﾞﾗﾑを除いて、通常と同様に使用できます。

起動FDでの起動

対象HDDを目的ﾏｼﾝに装着し、DM955.EXEを実行して作成したFDから起動します。 この起動ではDR-DOSが起動します。

Starting Caldra DR-DOS...

HIMEM.SYS 2.34

CD-ROM Device Driver for IDE/ATAPI, Ver 1.5 rev.016
Copyright (C) 1997.  All rights reserved.

 **Error: No CD-ROM drive found, please check power or cable.
 **Error: IDE CD-ROM device driver NOT installed!!

VDISK R1.1    Virtual Disk Driver
Copyright (c) 1988,1998 Caldera, Inc.  All rights reserved.
Virtual disk drive : D: (4096 kb, 512 bytes, 512 entries)

Caldera DR-DOS 7.04.17
Copyright (c) 1976, 1998 Caldera, Inc.  All rights reserved.

NWCDEX.EXE Version 2.81 CD-ROM file handler.
Copyright (c) 1992, 1997 Caldera Inc. All rights reserved.
A:\NMCDEX.EXE requires a Driver name to be specified.
DRMOUSE R1.1    Mouse driver for PS/2 mice
Copyright (c) Nagy Daniel. All Rights Reserved.
Copyright (c) Caldera, Inc. All Rights Reserved.
Type drmouse /h for help
Driver Mode: PS/2
Resolution: 3/3 times horizontally/vertically
Your RAM Disk is Z:\

続いて新規画面でﾒﾆｭｰ画面が表示されます。

                    IBM STD Disk Manager Boot Diskette

    1 - IBM DFT v2.10:         Drive Fitness Test (start in 10sec)
    2 - Disk Manager v9.55:    Hard Drive Installation
    3 - Exit to a DR-DOS Prompt

Select an option [1,2,3]?

10秒以内に選択が行なわれなかった場合、1のDrive Fitness Testが実行されます。 Disk Managerを実行する場合には、10秒以内に 2 を押下してください。
注:入手先やDisk Managerによっては、ﾒﾆｭｰ内の並びや既定ﾌﾟﾛｸﾞﾗﾑが異なります。

DR-DOSが英語版のため、ｷｰﾎﾞｰﾄﾞ配列は日本語ではなく英語になり、一部ｷｰ位置が異なります。

Disk Manager

Disk Managerが起動されるとIBMﾛｺﾞに続いて次が表示されます。

                                  I B M   S T D
                       Disk Manager   Version 9.55

                        Welcome to Disk Manager
              Disk Manager Hard Disk Installation Software
        Copyright(c) 1984-2001 ONTRACK Data International, Inc.

This Software is Licensed under the terms and conditions of the License
Agreement contained in the Online Manual.  Press F1 to view the
License Agreement.

If you have read the License Agreement and agree to the terms and
conditions therein press ENTER to continue.  Press any other key to exit.

Please register this Software.  See the Online Manual for details.

これはF1ｷｰ押下で表示される契約を許諾する場合は、Enterｷｰ押下で次へ進み、許諾しない場合はその他のｷｰ押下で本ﾌﾟﾛｸﾞﾗﾑを抜けなさいと言う事が記述されています。 Enterｷｰを押下すると、次の画面が表示されます。 左部分にはﾒﾆｭｰが表示されます。

Main Menu

  Disk Manager Main Menu

  Disk Manager 主ﾒﾆｭｰ
--------------------------
--------------------------

(E)asy Disk Instation
(E)ﾃﾞｨｽｸ簡易ｲﾝｽﾄｰﾙ
(A)dvanced Options
(A)詳細任意選択設定
(V)iew/Print Online Manual
(V)ｵﾝﾗｲﾝ ﾏﾆｭｱﾙ表示/印刷
Exit Disk Manager
Disk Manager終了

最下行には操作ｷｰが表示されます。

F1=Help
↑↓=Choose
<┘=Select
ESC=Previous
F1=ﾍﾙﾌﾟ
↑↓=選択
<┘=決定
ESC=戻る

上下ｶｰｿﾙ ｷｰにより目的の項目を選択し、Enterｷｰで決定します。 項目選択に応じて、画面右側には簡単な参照情報が表示されます。

(E)asy Disk Instation選択時Quick Reference:

          Quick Reference

          即時参照
---------------------------------------
------------------------------

 Easy Disk installation
 簡単ﾃﾞｨｽｸ ｲﾝｽﾄｰﾙ
    Disk Manager will make all the
    Disk Managerがあなたのﾃﾞｨｽｸの
    neccesary decisions to install
    全容量をｲﾝｽﾄｰﾙするために必要な

    your drive to full capacity.
    全てを決定します。

(A)dvanced Options選択時Quick Reference:

          Quick Reference

          即時参照
---------------------------------------
------------------------------

 Advanced Options
 詳細任意選択設定
    ･ Advanced Disk Installation
    ･ ﾃﾞｨｽｸ詳細ｲﾝｽﾄｰﾙ
    ･ Maintaenance Options
    ･ 保守任意選択機能
        Create Ontrack Boot Diskette
        Ontrack ﾌﾞｰﾄ ﾃﾞｨｽｹｯﾄ作成
        Install/Remove support drivers
        支援ﾄﾞﾗｲﾊﾞのｲﾝｽﾄｰﾙ/削除
        Run diagnodtiocs
        診断実行
    ･ Upgrade Disk Manager
    ･ Disk Manager更新

(V)iew/Print Online Manual選択時Quick Reference:

          Quick Reference

          即時参照
---------------------------------------
------------------------------

 View/Print Online Manual
 ｵﾝﾗｲﾝ ﾏﾆｭｱﾙ表示/印刷
    ･ Drive Jumper settings
    ･ ﾄﾞﾗｲﾌﾞ ｼﾞｬﾝﾊﾟ設定
    ･ Registration
    ･ ﾕｰｻﾞ登録
    ･ Supprt
    ･ ｻﾎﾟｰﾄ
    ･ Installation
    ･ ｲﾝｽﾄｰﾙ
    ･ Troubleshooting
    ･ 障害対策

1. (E)asy Disk Instation選択時

この機能ではﾄﾞﾗｲﾌﾞ、ﾌｧｲﾙ ｼｽﾃﾑの順で選択を行い、そのﾄﾞﾗｲﾌﾞ(HDD)に対してDDOを組み込んでﾊﾟｰﾃｨｰｼｮﾝ作成、ﾌｫｰﾏｯﾄを行います。 主ﾒﾆｭｰで(E)asy Disk Instationが選択されると、画面左側に次のﾒﾆｭｰが表示されます。

1-(1) (E)asy Disk Instation - ﾄﾞﾗｲﾌﾞ選択画面

(E)asy Disk Instationを選択/決定すると画面右側に現在操作可能なHDD一覧と画面左側にそのHDD一覧の確認入力が表示されます。

画面右側確ﾄﾞﾗｲﾌﾞ一覧部:

                 Drive List

----------------------------------------------

 1) IBM-DDLA-21620

画面左側確認入力部:

Disk Manager found 1 drive.

Disk Managerは1つのﾄﾞﾗｲﾌﾞを見つけました。

Is the drive list correct?
ﾄﾞﾗｲﾌﾞ一覧は正しいですか?
---------------------------
------------------------------------

           (Y)ES
                (Y)はい
           (N)O
                (N)いいえ

一般的に目的ﾏｼﾝに接続されているHDDは1台ですので、上記のような表示になります。 複数台のHDDが接続されている場合は、一覧に操作可能なHDD全てが表示され、その中から操作対象のHDDを選択することになります。

1-(2) (E)asy Disk Instation - ﾄﾞﾗｲﾌﾞ選択⇒OS(ﾌｧｲﾙ ｼｽﾃﾑ)選択画面

操作対象のHDDが決定されると、次の画面が表示されます。

OS(ﾌｧｲﾙ ｼｽﾃﾑ)選択画面:

         Select the operating system you

         あなたがｲﾝｽﾄｰﾙに使用または計画している

          are using or plan to install.
         ｵﾍﾟﾚｰﾃｨﾝｸﾞ ｼｽﾃﾑを選択してください。
--------------------------------------------------
-----------------------------------------------

Windows 95, 95A, 95 OSR1 (FAT16)
Windows 95, 95A, 95 OSR1 (FAT16)
Windows 95 OSR2, 98, 98SE, Me, 2000 (FAT 16 or 32)
Windows 95 OSR2, 98, 98SE, Me, 2000 (FAT16またはFAT32)

Windows NT 3.51 (or earler)
Windows NT 3.51 (またはそれ以前)
Windows NT 4.0 (or later) or OS/2
Windows NT 4.0 (またはそれ以降) またはOS/2
DOS/Windows 3.1x (FAT16)
DOS/Windows 3.1x (FAT16)
Other Operating System
他のｵﾍﾟﾚｰﾃｨﾝｸﾞ ｼｽﾃﾑ
Return to previous menu
直前のﾒﾆｭｰに戻る

目的のOSを選択し、Enterｷｰで決定すると、既に対象HDDが認識可能な何らかのOSで使用されているかによって次の画面が異なります。

1-(3) 既存ﾊﾟｰﾃｨｰｼｮﾝあり時画面:

認識可能なﾊﾟｰﾃｨｰｼｮﾝが存在する場合は、次の画面を表示します。

            | Hard Disk Selected: IBM-DDLA-21620 |
 WARNING! Disk Manager has detected existing partition on this
 harf disk.

 If you decide to continue with the installation, all existing
 DATA on this disk will be lost! Make absolutely sure you want
 to continue with the corrently selected disk.

 At this point you have 2 options:
    1) Press ALT-C to continue DISK MANAGER with this condition.
    2) Press any other key to cancel the installation.
                | 選択ﾊｰﾄﾞ ﾃﾞｨｽｸ: IBM-DDLA-21620 |
 警告! Disk Managerはこのﾊｰﾄﾞ ﾃﾞｨｽｸ上に既存ﾊﾟｰﾃｨｰｼｮﾝを検出しました。

 ｲﾝｽﾄｰﾙ継続を決めた場合、このﾃﾞｨｽｸ上の全ての既存ﾃﾞｰﾀが失われます。
 現在の選択ﾃﾞｨｽｸで継続するか充分に注意してください。

 この時点で2つの選択があります。
    1) この条件でDisk Managerを継続するにはALT-Cを押下してください。
    2) ｲﾝｽﾄｰﾙを取り消すには他のｷｰを押下してください。

Alt+Cｷｰを押下すると、Disk Manager情報表示へ進みます。

1-(4) 既存ﾊﾟｰﾃｨｰｼｮﾝなしの選択時画面:

認識可能な既存ﾊﾟｰﾃｨｰｼｮﾝが未存在で、ﾌｧｲﾙ ｼｽﾃﾑが選択可能な場合は次の画面が表示されます。 本例は上記のOS選択画面でWindows 95 OSR2, 98, 98SE, Me, 2000 (FAT 16 or 32)を選択した場合です。

Disk Manager can format your hard drive using the 32-Bit FAT file system.

            Would you like to install this drive using FAT32?
-------------------------------------------------------------------------

                                  (Y)ES
                                  (N)O
Disk Managerは32ﾋﾞｯﾄFATﾌｧｲﾙ ｼｽﾃﾑを使用してﾊｰﾄﾞ ﾄﾞﾗｲﾌﾞをﾌｫｰﾏｯﾄできます。
            FAT32を使用して、このﾄﾞﾗｲﾌﾞをｲﾝｽﾄｰﾙしますか?
-------------------------------------------------------------------------

                                       (Y)はい
                                       (N)いいえ

(Y)ESを選択すると、次へ進みます。

1-(5) (E)asy Disk Instation - ﾄﾞﾗｲﾌﾞ選択⇒OS(ﾌｧｲﾙ ｼｽﾃﾑ)選択⇒Disk Manager情報画面

画面上部でDisk Managerのｲﾝｽﾄｰﾙ情報を表示します。

Disk Manager情報画面:

                        Disk Manager Status
-------------------------------------------------------------------

   Ready to install Disk 1, IBM-DDLA-20620.
   It was a formatted capacity of 1.624GB
   There will be: 1 partition with 1.624GB
   This is your last chance to cancel the installtion process.
                            Disk Manager情報
-------------------------------------------------------------------

   ﾃﾞｨｽｸ1 IBM-DDLA-20620ｲﾝｽﾄｰﾙの準備ができました。
   これはﾌｫｰﾏｯﾄ後容量1.624Gﾊﾞｲﾄです。
   これは1.624Gﾊﾞｲﾄの1ﾊﾟｰﾃｨｰｼｮﾝです。
   ここはｲﾝｽﾄｰﾙ処理を取り消す最後の機会です。

画面下部に指示を求める画面が表示されます。

1-(6) ｲﾝｽﾄｰﾙ実行確認画面:

You are about to erase all data on this disk!

     Are you sure you want to continue?
---------------------------------------------

                    (Y)ES
                    (N)O
このﾃﾞｨｽｸ上の全ﾃﾞｰﾀを削除するところです!
     本当に続けますか?
---------------------------------------------

                       (Y)はい
                       (N)いいえ

(Y)ESを選択すると、ｲﾝｽﾄｰﾙが実行され、完了後に次の画面が表示されます。

1-(7) ｲﾝｽﾄｰﾙ完了画面:

         | DISK 1 has been successfully installed! |
 The partitions that have been created are now formatted.
 Each partition will be accessible as a logical drive letter
 after rebooting.
         | ﾃﾞｨｽｸ1 ｲﾝｽﾄｰﾙ成功 |
 作成されたﾊﾟｰﾃｨｰｼｮﾝは既にﾌｫｰﾏｯﾄされています。
 各ﾊﾟｰﾃｨｰｼｮﾝは再起動後、論理ﾄﾞﾗｲﾌﾞ文字でｱｸｾｽできます。

Enterを押下すると、次の画面が表示されます。

              | Disk Manager Status |
 Remove the diskette from drive A: and when ready...

        Press RESET or CTRL-ALT-DEL to exit.
                 | Disk Manager情報 |
 ﾄﾞﾗｲﾌﾞAからFDを取り去り、準備ができたなら、

         抜け出すにはRESETかCTRL-ALT-DELを押下してください。

このｲﾝｽﾄｰﾙがBIOSのHDD容量制限回避の目的で行なわれ、既に固定的なHDD容量書き換えを行なっている場合、上記のﾘｾｯﾄ操作では目的を達しません。 書き換えたHDD容量でBIOS認識を行なわせるには、一度電源をOFFに、再度電源をONにする必要があります。

2. (A)dvanced Options選択時

この機能では任意指定によるﾄﾞﾗｲﾌﾞ(HDD)へのDDO組み込み、ﾊﾟｰﾃｨｰｼｮﾝ作成、ﾌｫｰﾏｯﾄや、HDDの各種保守を行います。 主ﾒﾆｭｰで(A)dvanced Optionsが選択されると、画面左側に次のﾒﾆｭｰが表示されます。

■ (A)dvanced Options ﾒﾆｭｰ画面

      Advanced Options

    詳細機能選択
-----------------------------
------------------

(A)dvanced Disk installation
(A)ﾃﾞｨｽｸ詳細ｲﾝｽﾄｰﾙ
(M)aintanance Options
(M)保守任意選択機能

(U)pgrade Disk Manager
(U)Disk Manager更新
Return to previous menu
直前のﾒﾆｭｰに戻る

項目選択に応じて、画面右側には簡単な参照情報が表示されます。

(A)dvanced Options⇒(A)dvanced Disk installation選択時Quick Reference:

            Quick Reference

            即時参照
---------------------------------------
------------------------------

 Advanced Disk installation
 ﾃﾞｨｽｸ詳細ｲﾝｽﾄｰﾙ
    Create partitions base on
    予め定義された容量、または
    predefined sizes or custom sizes
    選択した任意容量を基に

    of your choice.
    ﾊﾟｰﾃｨｼｮﾝを作成。

(A)dvanced Options⇒(M)aintanance Options選択時Quick Reference:

            Quick Reference

            即時参照
---------------------------------------
------------------------------

 Maintanance Options
 保守任意選択機能
    ･ Create Ontrack Boot Diskette
    ･ Ontrack ﾌﾞｰﾄFD作成
    ･ Manually install, remove or
    ･ 手動ｲﾝｽﾄｰﾙ、削除、または
      upgrade any Ontrack driver
      Ontrackﾄﾞﾗｲﾊﾞの更新

(A)dvanced Options⇒(U)pgrade Disk Manager選択時Quick Reference:

            Quick Reference

            即時参照
---------------------------------------
------------------------------

 Upgrade Disk Manager
 Disk Manager更新
    Automatically Upgrade Disk Manager
    Disk ManagerとOntrack
    and any Ontrack support drivers.
    支援ﾄﾞﾗｲﾊﾞの自動更新

2-1. (A)dvanced Options⇒(A)dvanced Disk installation選択時

(A)dvanced Disk installationを選択すると、主ﾒﾆｭｰでの(E)asy Disk Instation選択時と同様のﾄﾞﾗｲﾌﾞ選択画面が表示されます。 ここで(Y)ESを選択すると、ﾌｧｲﾙ ｼｽﾃﾑ選択画面が表示されます。 ﾌｧｲﾙ ｼｽﾃﾑを決定すると、ﾊﾟｰﾃｨｰｼｮﾝが未存在でﾌｧｲﾙ ｼｽﾃﾑが選択可能な場合、FAT16とFAT32の選択画面が表示されます。 この選択を終えると、ﾊﾟｰﾃｨｰｼｮﾝ選択画面が表示されます。

2-1-(1) ﾊﾟｰﾃｨｰｼｮﾝ選択画面:

    Select a Partition Options

    ﾊﾟｰﾃｨｰｼｮﾝ任意選択
----------------------------------
----------------------------------

 Option (A)
 選択 (A)
    1 partition with 1.624GB
    1.624Gﾊﾞｲﾄの1つのﾊﾟｰﾃｨｰｼｮﾝ
 Option (B)
 選択 (B)
    2 partitions with 542.9MB each
    542.9Mﾊﾞｲﾄの2つのﾊﾟｰﾃｨｰｼｮﾝと
    1 partition with 538.8MB
    538Mﾊﾞｲﾄの1つのﾊﾟｰﾃｨｰｼｮﾝ
 Option (C)  Define your own
 選択 (C)  あなた自身の定義
----------------------------------
----------------------------------

Return to previous menu
直前のﾒﾆｭｰに戻る

Option (A)またはOption (B)を選択した場合で、認識可能なﾊﾟｰﾃｨｰｼｮﾝが存在すると、主ﾒﾆｭｰでの(E)asy Disk Instation選択時と同様の警告画面が表示されます。 認識可能なﾊﾟｰﾃｨｰｼｮﾝが存在しない場合は、主ﾒﾆｭｰでの(E)asy Disk Instation選択時と同様のDisk Manager情報画面以下が実行されます。

Option (C)を選択すると、次のﾊﾟｰﾃｨｰｼｮﾝ指定画面が表示されます。

2-1-(2) ﾊﾟｰﾃｨｰｼｮﾝ指定画面:

   Enter size of partition in MB (F1=HELP)

Mﾊﾞｲﾄ単位でﾊﾟｰﾃｨｰｼｮﾝ容量を入力してください。(F1=ﾍﾙﾌﾟ)

----------------------------------------------
-----------------------------------------------

(Maximum capacity of this partition = 1.624GB)
          (本ﾊﾟｰﾃｨｰｼｮﾝの最大容量=1.624GB)
                    1625
                        1625
               (ESC to CANCEL)
                 (取り消すにはESC)

第1ﾊﾟｰﾃｨｰｼｮﾝから希望する容量をMﾊﾞｲﾄ単位で入力し、Enterｷｰで指定します。 各ﾊﾟｰﾃｨｰｼｮﾝ情報が入力毎に表示されます。

               | Patition 2 |

               | ﾊﾟｰﾃｨｰｼｮﾝ 2 |

----------------------------------------------
-----------------------------------------------

Type......: Extended      Size.....: 1.123GB
形式....: 拡張          容量.....: 1.123GB
Formatted.: NO            Bootable.: NO
ﾌｫｰﾏｯﾄ..: 未            起動.....: なし
Start CHS.: 243   0     1
開始CHS.: 243   0     1
End CHS...: 786   63    63
終了CHS.: 786   63    63

全容量に対してﾊﾟｰﾃｨｰｼｮﾝ割り当てが終了すると、ﾊﾟｰﾃｨｰｼｮﾝ割り当て画面が表示されます。 この例は1625MﾊﾞｲﾄのHDDを500Mﾊﾞｲﾄ、500Mﾊﾞｲﾄ、残りと、3つのﾊﾟｰﾃｨｰｼｮﾝ指定を行なった場合です。 実際の割り当て容量はｼﾘﾝﾀﾞ単位で行なわれるため、入力値はｼﾘﾝﾀﾞ単位で最も近い数値に置き換えられます。

2-1-(3) ﾊﾟｰﾃｨｰｼｮﾝ割り当て画面:

画面左側に基本/拡張ﾊﾟｰﾃｨｰｼｮﾝ指定が表示されます。

Partition        Cylinder

ﾊﾟｰﾃｨｰｼｮﾝ        ｼﾘﾝﾀﾞ

## type          start end   Size
No 形式          開始  終了  容量

------------------------------------
-------------------------------

1   DOS-FAT12/16 0     242   501.6MB
1   DOS-FAT12/16 0     242   501.6MB

2   EXTENDED     243   786   1.123GB
2   EXTENDED     243   786   1.123GB

3
3
4
4
Save and Continue
保存と継続

この画面内で各ﾊﾟｰﾃｨｰｼｮﾝを選択すると、対応する上記のﾊﾟｰﾃｨｰｼｮﾝ情報が表示されます。 EXTENDED(拡張)ﾊﾟｰﾃｨｰｼｮﾝを選択すると、画面右側に拡張ﾊﾟｰﾃｨｰｼｮﾝ内の論理ﾊﾟｰﾃｨｰｼｮﾝ情報が表示されます。

Logical Volume   Cylinder

ﾊﾟｰﾃｨｰｼｮﾝ        ｼﾘﾝﾀﾞ

## type          start end   Size
No 形式          開始  終了  容量

------------------------------------
-------------------------------

1   DOS-FAT12/16 243   485   501.6MB
1   DOS-FAT12/16 243   485   501.6MB

2   DOS-FAT32    486   786   621.3MB
2   DOS-FAT32    486   786   621.3MB

画面最下段のﾒﾆｭｰでﾊﾟｰﾃｨｰｼｮﾝの編集やﾎﾞﾘｭｰﾑ名指定ができます。

F1=Help
↑↓=Choose
DEL=Delete
N=New
TAB=Volumes
END=Done
ESC=Previous
F1=ﾍﾙﾌﾟ
↑↓=選択
DEL=削除
N=新規
TAB=ﾎﾞﾘｭｰﾑ名
END=実行
ESC=戻る

画面左側でSave and Continueを選択すると、認識可能なﾊﾟｰﾃｨｰｼｮﾝが存在する場合、主ﾒﾆｭｰでの(E)asy Disk Instation選択時と同様の警告画面が表示されます。 認識可能なﾊﾟｰﾃｨｰｼｮﾝが存在しない場合は、主ﾒﾆｭｰでの(E)asy Disk Instation選択時と同様のDisk Manager情報画面以下が実行されます。

2-2. (A)dvanced Options⇒(M)aintanance Options選択時

詳細機能選択ﾒﾆｭｰで(M)aintanance Optionsが選択されると、画面左側に次のﾒﾆｭｰが表示されます。

■ Maintanance Options ﾒﾆｭｰ画面

     Maintenance Options

     保守任意選択機能
------------------------------
----------------------

(C)reate Ontrack Boot Diskette
(C)OntrackﾌﾞｰﾄFD作成
(D)ynamic Drive Overlay
(D)ﾀﾞｲﾅﾐｯｸ ﾄﾞﾗｲﾌﾞ ｵｰﾊﾞｰﾚｲ

(M)aster Boot Record
(M)ﾏｽﾀ ﾌﾞｰﾄ ﾚｺｰﾄﾞ
(W)indows 3.1x Drivers
(W)indows 3.1x ﾄﾞﾗｲﾊﾞ
(O)NTRACKD.SYS Driver
(O)NTRACKD.SYS ﾄﾞﾗｲﾊﾞ
Display Drive (I)nfomation
(I)ﾄﾞﾗｲﾌﾞ情報表示
(U)tilities
(U)ﾕｰﾃｨﾘﾃｨ
Return to previous menu
直前のﾒﾆｭｰに戻る

項目選択に応じて、画面右側には簡単な参照情報が表示されます。

(A)dvanced Options⇒(M)aintanance Options⇒(C)reate Ontrack Boot Diskette選択時Quick Reference:

            Quick Reference

            即時参照
---------------------------------------
------------------------------

 Create Ontrack Boot Diskette
 OntrackﾌﾞｰﾄFD作成
    Add Dynamic Drive Overlay to:
    次にﾀﾞｲﾅﾐｯｸ ﾄﾞﾗｲﾌﾞ ｵｰﾊﾞｰﾚｲ追加

    ･ Boot diskette
    ･ ﾌﾞｰﾄFD
    ･ Copy of a boot diskette
    ･ ﾌﾞｰﾄFDのｺﾋﾟｰ

(A)dvanced Options⇒(M)aintanance Options⇒(D)ynamic Drive Overlay選択時Quick Reference:

            Quick Reference

            即時参照
---------------------------------------
------------------------------

 Dynamic Drive Overlay
 ﾀﾞｲﾅﾐｯｸ ﾄﾞﾗｲﾌﾞ ｵｰﾊﾞｰﾚｲ
    ･ Update Dynamic Drive Overlay
    ･ ﾀﾞｲﾅﾐｯｸ ﾄﾞﾗｲﾌﾞ ｵｰﾊﾞｰﾚｲ更新と

      and change settings
      設定変更
    ･ Remove Dynamic Drive Overlay
    ･ ﾀﾞｲﾅﾐｯｸ ﾄﾞﾗｲﾌﾞ ｵｰﾊﾞｰﾚｲ削除

(A)dvanced Options⇒(M)aintanance Options⇒(M)aster Boot Record選択時Quick Reference:

            Quick Reference

            即時参照
---------------------------------------
------------------------------

 Master Boot Record
 ﾏｽﾀ ﾌﾞｰﾄ ﾚｺｰﾄﾞ
    ･ Update MBR boot code
    ･ MBRのﾌﾞｰﾄ ｺｰﾄﾞ更新
    ･ Replace MBR with backup copy
    ･ ﾊﾞｸｱｯﾌﾟ ｺﾋﾟｰでMBR置換

(A)dvanced Options⇒(M)aintanance Options⇒(W)indows 3.1x Drivers選択時Quick Reference:

            Quick Reference

            即時参照
---------------------------------------
------------------------------

 Windows 3.1x Drivers
 Windows 3.1x ﾄﾞﾗｲﾊﾞ
    ･ Install Enhanced 32-Bit Disk
    ･ 32ﾋﾞｯﾄ ｱｸｾｽ 強化ﾃﾞｨｽｸ

      Access driver
      ﾄﾞﾗｲﾊﾞのｲﾝｽﾄｰﾙ
    ･ Remove Enhanced 32-Bit Disk
    ･ 32ﾋﾞｯﾄ ｱｸｾｽ 強化ﾃﾞｨｽｸ
      Access driver
      ﾄﾞﾗｲﾊﾞの削除

(A)dvanced Options⇒(M)aintanance Options⇒(O)NTRACKD.SYS Driver選択時Quick Reference:

            Quick Reference

            即時参照
---------------------------------------
------------------------------

 ONTRACKD.SYS Driver
 ONTRACKD.SYSﾄﾞﾗｲﾊﾞ
    ･ Install/Update ONTRACKD.SYS
    ･ ONTRACKD.SYSのｲﾝｽﾄｰﾙ/更新
    ･ Remove ONTRACKD.SYS
    ･ ONTRACKD.SYSの削除

(A)dvanced Options⇒(M)aintanance Options⇒Display Drive (I)nfomation選択時Quick Reference:

            Quick Reference

            即時参照
---------------------------------------
------------------------------

 Display Drive Infomation
 ﾄﾞﾗｲﾌﾞ情報表示
    Display details about a hard drive
    ｼｽﾃﾑ内のﾊｰﾄﾞ ﾃﾞｨｽｸ ﾄﾞﾗｲﾌﾞ
    in your system.
    についての詳細表示

(A)dvanced Options⇒(M)aintanance Options⇒(U)tilities選択時Quick Reference:

            Quick Reference

            即時参照
---------------------------------------
------------------------------

 Utilities
 ﾕｰﾃｨﾘﾃｨ
    ･ Zero fill drive
    ･ ﾄﾞﾗｲﾌﾞ全域0書き込み
    ･ Low level format drive
    ･ ﾄﾞﾗｲﾌﾞ低ﾚﾍﾞﾙ ﾌｫｰﾏｯﾄ

2-2-1. (A)dvanced Options⇒(M)aintanance Options⇒(C)reate Ontrack Boot Diskette選択時

保守任意選択機能ﾒﾆｭｰで(C)reate Ontrack Boot Disketteが選択されると、画面左側に次のﾒﾆｭｰが表示されます。

■ Create Ontrack Boot Diskette ﾒﾆｭｰ画面

               Create Ontrack Boot Diskette

     OntrackﾌﾞｰﾄFD作成
-----------------------------------------------------------
-------------------------------------

(M)ake existing boot diskette an Ontrack Boot Diskette
(M)既存ﾌﾞｰﾄFDでOntrackﾌﾞｰﾄFD作成
(C)opy bootable diskette to create an Ontrack Boot Diskette
(C)OntrackﾌﾞｰﾄFD作成のため、ﾌﾞｰﾄ可能FDｺﾋﾟｰ

Return to previous menu
直前のﾒﾆｭｰに戻る

これは起動FDにHDDのDDO機能を組み込む機能です。 通常、(C)opy bootable diskette to create an Ontrack Boot Disketteで既存起動FDのｺﾋﾟｰを作成し、そのｺﾋﾟｰに対して(M)ake existing boot diskette an Ontrack Boot DisketteでHDDのDDO機能を組み込みます。 これによって作成されたFDから起動すると、HDDにDDOが組み込まれていないHDDに対してもDDOが機能します。 しかし、現在、このような使用自体が殆ど存在せず、また間違いの元となるため、この機能が使用されることは殆どないでしょう。

2-2-2. (A)dvanced Options⇒(M)aintanance Options⇒(D)ynamic Drive Overlay選択時

保守任意選択機能ﾒﾆｭｰで(D)ynamic Drive Overlayが選択されると、画面左側に次のﾒﾆｭｰが表示されます。

■ Dynamic Drive Overlay ﾒﾆｭｰ画面

    Dynamic Drive Overlay

   ﾀﾞｲﾅﾐｯｸ ﾄﾞﾗｲﾌﾞ ｵｰﾊﾞｰﾚｲ
------------------------------
-------------------------

(U)pdate Dynamic Drive Overlay
(U)ﾀﾞｲﾅﾐｯｸ ﾄﾞﾗｲﾌﾞ ｵｰﾊﾞｰﾚｲ更新

(R)emove Dynamic Drive Overlay
(R)ﾀﾞｲﾅﾐｯｸ ﾄﾞﾗｲﾌﾞ ｵｰﾊﾞｰﾚｲ削除

Return to previous menu
直前のﾒﾆｭｰに戻る

項目選択に応じて、画面右側には簡単な参照情報が表示されます。

(A)dvanced Options⇒(M)aintanance Options⇒(D)ynamic Drive Overlay⇒(U)pdate Dynamic Drive Overlay選択時Quick Reference:

            Quick Reference

            即時参照
---------------------------------------
----------------------------

 Update Dynamic Drive Overlay
 ﾀﾞｲﾅﾐｯｸ ﾄﾞﾗｲﾌﾞ ｵｰﾊﾞｰﾚｲ更新
    Upgrade Dynamic Drive Overlay
    ﾀﾞｲﾅﾐｯｸ ﾄﾞﾗｲﾌﾞ ｵｰﾊﾞｰﾚｲ更新と
    and change command line switches.
    ｺﾏﾝﾄﾞ行ｽｨｯﾁ変更

(A)dvanced Options⇒(M)aintanance Options⇒(D)ynamic Drive Overlay⇒(R)emove Dynamic Drive Overlay選択時Quick Reference:

            Quick Reference

            即時参照
---------------------------------------
----------------------------

 Remove Dynamic Drive Overlay
 ﾀﾞｲﾅﾐｯｸ ﾄﾞﾗｲﾌﾞ ｵｰﾊﾞｰﾚｲ削除
    Uninstall Dynamic Drive Overlay
    指定ﾄﾞﾗｲﾌﾞからﾀﾞｲﾅﾐｯｸ ﾄﾞﾗｲﾌﾞ

    from a specific drive.
    ｵｰﾊﾞｰﾚｲを削除

これはHDDに対してDDO機能のみを組み込み/更新/削除する機能です。 通常、DDO機能はHDDｲﾝｽﾄｰﾙの一連の処理中に含まれ、また削除する場合は他の設定で再ｲﾝｽﾄｰﾙとなる場合が多いため、個別に使用される場合は稀です。 唯一存在するとすれば、DDO更新のみと考えられますが、一旦動作してしまえば、更新の必要もあまりないと思えますので、ここでの機能を使用する機会は殆どないでしょう。

2-2-2-1. (A)dvanced Options⇒(M)aintanance Options⇒(D)ynamic Drive Overlay⇒(U)pdate Dynamic Drive Overlay選択時

ﾀﾞｲﾅﾐｯｸ ﾄﾞﾗｲﾌﾞ ｵｰﾊﾞｰﾚｲ ﾒﾆｭｰで(U)pdate Dynamic Drive Overlayが選択されると、画面中央に次の入力画面が表示されます。

                     Dynamic Drive Overlay Switches
-----------------------------------------------------------------------
       Enter desired switches.  Press F1 for switch information.
 /M
                            (ESC to CANCEL)
                        ﾀﾞｲﾅﾐｯｸ ﾄﾞﾗｲﾌﾞ ｵｰﾊﾞｰﾚｲ ｽｨｯﾁ
-----------------------------------------------------------------------
       希望するｽｨｯﾁを入力してください。 ｽｨｯﾁ情報についてはF1を押下してください。
 /M
                             (ESCで取り消し)

F1ｷｰ押下で表示されるﾍﾙﾌﾟは次の通りです。

You can control certain features provided by the Dynamic Drive Overlay by adding
or removing command line switches that are writen with the Dynamic Drive
Overlay. The following switches are valid. See the Online Manual for detailed
information regarding there switches:

/C  force CHS IO Mode
    Syntax: /C

/E  Enable IDE/ATA Power Management
    Syntax: /E
        or
            /E={1-16}

/L= Set Memory Relocation
    Syntax: /L={0|1|2}

/M  Enable Read/Write Multiple
    Syntax: /M
        or
            /M={drive_1_value}[,drive_2_value][,drive_3_value][,drive_4_value]

/P- Disable Fast ATA Mode
    Syntax: /P-

/R= Disable Read Multiple
    Syntax: /R={0|1}[,0|1][,0|1][,0|1]

/S  Disable Secondary Support
    Syntax: /S

/V= Verbose Mode
    Syntax: /V={0|1|2}

/W= Disable Write Multiple
    Syntax: /W={0|1}[,0|1][,0|1][,0|1]
ﾀﾞｲﾅﾐｯｸ ﾄﾞﾗｲﾌﾞ ｵｰﾊﾞｰﾚｲと共に書き込まれた追加/削除するｺﾏﾝﾄﾞ行ｽｨｯﾁによって
ﾀﾞｲﾅﾐｯｸ ﾄﾞﾗｲﾌﾞ ｵｰﾊﾞｰﾚｲで提供される機能を制御できます。 以下のｽｨｯﾁが有効です。
これらのｽｨｯﾁに関する詳細情報についてはｵﾝﾗｲﾝ ﾏﾆｭｱﾙをご覧ください。

/C  CHS入出力動作強制
    書式: /C

/E  IDE/ATA電力管理許可
    書式: /E
    または
          /E={1-16}

/L= ﾒﾓﾘ再配置設定
    書式: /L={0|1|2}

/M  複数読み書き許可
    書式: /M
    または
          /M={drive_1_value}[,drive_2_value][,drive_3_value][,drive_4_value]

/P- 高速ATA動作禁止
    書式: /P-

/R= 複数読み込み禁止
    書式: /R={0|1}[,0|1][,0|1][,0|1]

/S  Secondaryｻﾎﾟｰﾄ禁止
    書式: /S

/V= 冗長動作
    書式: /V={0|1|2}

/W= 複数書き込み禁止
    書式: /W={0|1}[,0|1][,0|1][,0|1]

ｽｨｯﾁを指定し、Enterｷｰを押下すると、更新が実行され、画面中央に以下が表示されます。

          | Disk Manager Status |

               | Disk Manager情報|
-------------------------------------------
--------------------------------------------

Dynamic Drive Overlay successfully written.
ﾀﾞｲﾅﾐｯｸ ﾄﾞﾗｲﾌﾞ ｵｰﾊﾞｰﾚｲは成功裏に書き込まれました。

            (Any key to continue)
                (何れかのｷｰで継続)

これはDDO機能組み込み済みのHDDに対してDDO機能を更新する機能です。 一旦動作してしまえば、更新の必要もあまりないと思えますので、この機能を使用する機会は殆どないでしょう。

2-2-2-2. (A)dvanced Options⇒(M)aintanance Options⇒(D)ynamic Drive Overlay⇒(R)emove Dynamic Drive Overlay選択時

ﾀﾞｲﾅﾐｯｸ ﾄﾞﾗｲﾌﾞ ｵｰﾊﾞｰﾚｲ ﾒﾆｭｰで(R)emove Dynamic Drive Overlayが選択されると、即座にDDO削除が実行され、画面中央に次の画面が表示されます。

                        | Disk Manager Status |
 Changes have already been made to your system.
 You must reboot your system before using ths maintenance option.
                       (Any key to continue)
                           Disk Manager情報
 変更はｼｽﾃﾑに対して既に行なわれました。
 保守任意選択機能を使用する前に、ｼｽﾃﾑを再起動しなければなりません。
                              (何れかのｷｰで継続)

その後、主ﾒﾆｭｰからDisk Managerを終了するとき、次の画面が表示されます。

           | IMPORTANT INFORMATION - PLEASE READ CAREFULLY! |
 Each time you boot from diskette you must follow the three steps below.
 If you do not follow this procedure, your operating system (OS) will be
 unable to access the hard drive correctly and OS installation will fail.

   1) Remove the diskette form drive A:, if present.
   2) Boot the system from the hard drive and press the SPACEBAR as soon
      as the blue Ontrack banner appears.
   3) When prompted, insert the boot diskette in drive A: and press the
      SPACEBAR.

 As an alternative, you can create an Ontrack Boot Diskette. Press F1 or
 see the Online Manual for more information.

 To create an Ontrack Boot Diskette, press ALT-C.
 Press any other key to skip diskette creation.
             | 重要情報 - 注意してお読みください。 |
 FDから起動する度毎に、以下の3手順に従わなければなりません。
 この手順に従わない場合、OSがﾊｰﾄﾞ ﾄﾞﾗｲﾌﾞへ正しくｱｸｾｽできなくなり、
 OSｲﾝｽﾄｰﾙは失敗するでしょう。

   1) 存在するなら、A:ﾄﾞﾗｲﾌﾞからFDを取り除きます。
   2) HDからｼｽﾃﾑをﾌﾞｰﾄし、青色のOntrackﾊﾞｰﾅｰが現れたら直ぐにｽﾍﾟｰｽを押下します。
   3) 指示されたとき、A:ﾄﾞﾗｲﾌﾞにﾌﾞｰﾄFDを挿入して、ｽﾍﾟｰｽを押下します。

 代替としてOntrackﾌﾞｰﾄFDを作成できます。
 より多くの情報についてはF1押下またはｵﾝﾗｲﾝ ﾏﾆｭｱﾙをご覧ください。

 OntrackﾌﾞｰﾄFDを作成するにはALT-Cを押下してください。
 FD作成を飛ばすには、他の何れかのｷｰを押下してください。

上記の説明はBIOSのHDD認識が通過し、HDDのﾌﾞｰﾄが行なわれるとの前提の記述です。 その他の場合は基本的に電源のOFF/ONで再起動しなければならず、更にBIOSのHDD認識で停止する場合もあります。 これらを避けるには、Ontrack起動FDを作成して、FD起動させる必要があります。

Alt+Cｷｰを押下すると、次の画面が現れ、ﾌﾞｰﾄFDを作成します。

 Insert a copy of your operationg system startup
 diskette or a bootable diskette into drive A:.
             (Any key to continue)
 OSの起動FDか、またはﾌﾞｰﾄ可能なFDをA:ﾄﾞﾗｲﾌﾞに挿入してください。
                   (何れかのｷｰで継続)

最終的にDisk Managerｲﾝｽﾄｰﾙ時と同じ抜け出し画面が表示されます。

2-2-3. (A)dvanced Options⇒(M)aintanance Options⇒(M)aster Boot Record選択時

保守任意選択機能ﾒﾆｭｰで(M)aster Boot Recordが選択されると、画面左側に次のﾒﾆｭｰが表示されます。

■ Master Boot Record ﾒﾆｭｰ画面

      Master Boot Record

   ﾏｽﾀ ﾌﾞｰﾄ ﾚｺｰﾄﾞ
------------------------------
-------------------------

(W)rite MBR Boot Code
(W)MBRﾌﾞｰﾄ ｺｰﾄﾞ書き込み

(R)estore MBR with Backup Copy
(R)ﾊﾞｯｸｱｯﾌﾟ ｺﾋﾟｰでMBR書き戻し

Return to previous menu
直前のﾒﾆｭｰに戻る

項目選択に応じて、画面右側には簡単な参照情報が表示されます。

(A)dvanced Options⇒(M)aintanance Options⇒(M)aster Boot Record⇒(W)rite MBR Boot Code選択時Quick Reference:

            Quick Reference

            即時参照
---------------------------------------
----------------------------

 Write MBR Boot Code
 MBRﾌﾞｰﾄ ｺｰﾄﾞ書き込み
    Update sytem boot code by
    MBRのﾌﾞｰﾄ ｺｰﾄﾞの再書き込
    rewriting the boot code of
    みによりｼｽﾃﾑ ﾌﾞｰﾄ ｺｰﾄﾞを
    the MBR.
    更新

(A)dvanced Options⇒(M)aintanance Options⇒(M)aster Boot Record⇒(R)estore MBR with Backup Copy選択時Quick Reference:

            Quick Reference

            即時参照
---------------------------------------
----------------------------

 Restore MBR with Backup Copy
 ﾊﾞｯｸｱｯﾌﾟ ｺﾋﾟｰでMBR書き戻し
    Restore boot code if corrupted
    ｳｨﾙｽや他のﾌﾟﾛｸﾞﾗﾑにより不正

    by a virus or another program.
    になった場合ﾌﾞｰﾄ ｺｰﾄﾞを復旧

これはﾏｽﾀ ﾌﾞｰﾄ ﾚｺｰﾄﾞ(MBR)の保守機能です。 一般的な使用でMBRのみが破壊されることはあまり考えられません。 通常、MBRが破壊されている場合、HDD内ﾃﾞｰﾀの一部または全部の破壊を伴います。 この場合は最悪低ﾚﾍﾞﾙ ﾌｫｰﾏｯﾄからのHDD再ｲﾝｽﾄｰﾙが必要になります。 従って、この機能を単独で使用する機会は稀でしょう。

2-2-4. (A)dvanced Options⇒(M)aintanance Options⇒(W)indows 3.1x Drivers選択時

保守任意選択機能ﾒﾆｭｰで(W)indows 3.1x Driversが選択されると、画面左側に次のﾒﾆｭｰが表示されます。

■ Windows 3.1x Drivers ﾒﾆｭｰ画面

  Windows 3.1x Drivers

Windows 3.1xﾄﾞﾗｲﾊﾞ

-----------------------
----------------

(I)nstall Drivers
(I)ﾄﾞﾗｲﾊﾞ ｲﾝｽﾄｰﾙ
(R)emove Drivers
(R)ﾄﾞﾗｲﾊﾞ削除
Return to previous menu
直前のﾒﾆｭｰに戻る

項目選択に応じて、画面右側には簡単な参照情報が表示されます。

(A)dvanced Options⇒(M)aintanance Options⇒(W)indows 3.1x Drivers⇒(I)nstall Drivers選択時Quick Reference:

            Quick Reference

            即時参照
---------------------------------------
----------------------------

 Install Drivers
 ﾄﾞﾗｲﾊﾞ ｲﾝｽﾄｰﾙ
    Install Enhanced 32-Bit Disk
    Windows 3.1x用32ﾋﾞｯﾄ
    Access Driver ONTRACKW.386
    ﾃﾞｨｽｸ ｱｸｾｽ強化ﾄﾞﾗｲﾊﾞ
    for Windows 3.1x.
    ONTRACKW.386をｲﾝｽﾄｰﾙ

(A)dvanced Options⇒(M)aintanance Options⇒(W)indows 3.1x Drivers⇒(R)emove Drivers選択時Quick Reference:

            Quick Reference

            即時参照
---------------------------------------
----------------------------

 Remove Drivers
 ﾊﾞｯｸｱｯﾌﾟ ｺﾋﾟｰでMBR書き戻し
    Remove Enhanced 32-Bit Disk
    Windows 3.1x用32ﾋﾞｯﾄ
    Access Driver ONTRACKW.386
    ﾃﾞｨｽｸ ｱｸｾｽ強化ﾄﾞﾗｲﾊﾞ
    for Windows 3.1x.
    ONTRACKW.386を削除

これはWindows 3.1x用Ontrackﾃﾞｨｽｸ ﾄﾞﾗｲﾊﾞ(ONTRACKW.386)のｲﾝｽﾄｰﾙと削除です。 現在、Windows 3.1xの使用自体がないと思われますので、この機能を使用する機会はないでしょう。

2-2-5. (A)dvanced Options⇒(M)aintanance Options⇒(O)NTRACKD.SYS Driver選択時

保守任意選択機能ﾒﾆｭｰで(O)NTRACKD.SYS Driverが選択されると、画面左側に次のﾒﾆｭｰが表示されます。

■ ONTRACKD DOS Driver ﾒﾆｭｰ画面

  ONTRACKD DOS Driver

ONTRACK DOSﾄﾞﾗｲﾊﾞ

------------------------------
-------------------------

(I)nstall ONTRACKD.SYS Driver
(I)ONTRACKD.SYSﾄﾞﾗｲﾊﾞ ｲﾝｽﾄｰﾙ

(R)emove ONTRACKD.SYS Driver
(R)ONTRACKD.SYSﾄﾞﾗｲﾊﾞ削除
Return to previous menu
直前のﾒﾆｭｰに戻る

項目選択に応じて、画面右側には簡単な参照情報が表示されます。

(A)dvanced Options⇒(M)aintanance Options⇒(O)NTRACKD.SYS Driver⇒(I)nstall ONTRACKD.SYS Driver選択時Quick Reference:

            Quick Reference

            即時参照
---------------------------------------
----------------------------

 Install ONTRACKD.SYS Driver
 ONTRACKD.SYSﾄﾞﾗｲﾊﾞ ｲﾝｽﾄｰﾙ
    Install/Update ONTRACKD.SYS
    必要ならば、ONTRACKD.SYS
    driver if needed.
    ﾄﾞﾗｲﾊﾞのｲﾝｽﾄｰﾙ/更新。
    ONTRACKD.SYS provides support for
    ONTRACKD.SYSはをDOS 5～6.xと

    drives over 8.4GB for DOS 5 to 6.x
    Windows 3.1xに対して8.4Gﾊﾞｲﾄ

    and Windows 3.1x.
    を越える駆動支援を提供。

(A)dvanced Options⇒(M)aintanance Options⇒(O)NTRACKD.SYS Driver⇒(R)emove ONTRACKD.SYS Driver選択時Quick Reference:

            Quick Reference

            即時参照
---------------------------------------
----------------------------

 Remove ONTRACKD.SYS Driver
 ONTRACKD.SYSﾄﾞﾗｲﾊﾞ削除
    Remove ONTRACKD.SYS from system.
    ｼｽﾃﾑからONTRACKD.SYS削除

    ONTRACKD.SYS provides support for
    ONTRACKD.SYSはをDOS 5～6.xと

    drives over 8.4GB for DOS 5 to 6.x
    Windows 3.1xに対して8.4Gﾊﾞｲﾄ

    and Windows 3.1x.
    を越える駆動支援を提供。

これはDOS5～6.xとWindows 3.1xのCONFIG.SYSに対してOntrackﾃﾞｨｽｸ ﾄﾞﾗｲﾊﾞ(ONTRACKD.SYS)を追加(ｲﾝｽﾄｰﾙ)または削除する機能です。 現在、これらのOS自体の使用が稀のため、この機能を使用する機会はないでしょう。

2-2-6. (A)dvanced Options⇒(M)aintanance Options⇒Display Drive (I)nfomation選択時

保守任意選択機能ﾒﾆｭｰでDisplay Drive (I)nfomationが選択されると、次のHDD情報画面を表示します。

  |  DISK MANAGER V9.55.09 - IDENTIFIED DATA FOR DISK 1  |

 Drive Model  :>IBM-DDLA-21620                           <
 Firmware Rev.: A20G40         S.M.A.R.T. Support: Disabled
 Serial Number:          H50H5245316

 Device Identify CHS...: 3152 x 16 x 63    = Size: 1.626GB
 LBA Sector count......: 3177216 sectors   = Size: 1.626GB
 Calculated CHS........: 3152 x 16 x 63    = Size: 1.626GB

 ATA-# Supported.: 3,2         IORDY Support...: YES
 R/W Multiple....: YES         Sectors/Int.....: 16
 MW DMA Support..: 0,1,2       MW DMA Active...: 2
 MW DMA CycleTime: 120ns       Min. Cycle/Word.: 120ns
 PIO Mode Support: 3,4         PIO Cycle Time..: 120ns

                    (Any key to continue)

何れかのｷｰを押下すると、複数のHDDが認識されている場合は、次のHDD情報を表示します。 最後のHDD情報表示でのｷｰ押下で直前のﾒﾆｭｰに戻ります。

2-2-7. (A)dvanced Options⇒(M)aintanance Options⇒(U)tilities選択時

保守任意選択機能ﾒﾆｭｰで(U)tilitiesが選択されると、画面左側にHDD選択画面が表示されます。

         Select a Disk

     ﾃﾞｨｽｸ選択
-------------------------------
------------------

 1) IBM-DDLA-21620
 1) IBM-DDLA-21620
Return to previous menu
直前のﾒﾆｭｰに戻る

ここで選択されたﾄﾞﾗｲﾌﾞ情報が画面右側で表示されます。

| Disk 1  TRANSLATED |
 Cylinders...: 787
 Heads.......: 64
 Sectors.....: 63
 Size.....: 1.624GB

ﾄﾞﾗｲﾌﾞを選択すると、次の機能選択画面が表示されます。

■ Select Utility Option ﾒﾆｭｰ画面

 Select Utility Option

ﾕｰﾃｨﾘﾃｨ機能選択

-----------------------
-----------------

 Zero fill Drive
ﾄﾞﾗｲﾌﾞ全域0書き込み

 Low Level Format
低ﾚﾍﾞﾙ ﾌｫｰﾏｯﾄ
 Set Drive Size
ﾄﾞﾗｲﾌﾞ容量設定
Return to previous menu
直前のﾒﾆｭｰに戻る

目的項目を選択して、Enterｷｰを押下します。

2-2-7-1. (A)dvanced Options⇒(M)aintanance Options⇒(U)tilities⇒Zero fill Drive選択時

ﾕｰﾃｨﾘﾃｨ機能選択ﾒﾆｭｰでZero fill Driveが選択されると、次の警告画面が表示されます。

                     | Disk Manager Status |
 This operation will cause all partition information to be lost.
 As a result, all files and data will no longer be accessible.
 Press ALT-C to continue, or press any other key to abort
 this operation.

 At this point you have 2 options:
    1) Press ALT-C to continue DISK MANAGER with this condition.
    2) Press any other key to cancel the installation.
                       | Disk Manager情報 |
 本操作は全てのﾊﾟｰﾃｨｼｮﾝ情報消失を引き起こします。
 結果として、全てのﾌｧｲﾙとﾃﾞｰﾀがもはやｱｸｾｽできなくなります。
 本操作を継続するにはALT-Cを、中止するには他のｷｰを押下してください。

 この時点で2つの選択があります。
    1) この条件でDisk Managerを継続するにはALT-Cを押下してください。
    2) ｲﾝｽﾄｰﾙを取り消すには他のｷｰを押下してください。

継続するにはAlt+Cを押下し、以降、画面の指示に従ってください。

この機能はHDDを破棄する場合に、その内容を確実に消去するのに利用できます。

注:本機能はDisk Managerが保持しているHDD情報の制限を受けるため、新機種のHDDでｻﾎﾟｰﾄ外警告になる場合があります。

2-2-7-2. (A)dvanced Options⇒(M)aintanance Options⇒(U)tilities⇒Low Level Format選択時

ﾕｰﾃｨﾘﾃｨ機能選択ﾒﾆｭｰでLow Level Formatが選択されると、次の警告画面が表示されます。

                     | Disk Manager Status |
 This operation will cause all partition information to be lost.
 As a result, all files and data will no longer be accessible.
 Please contact your hard drive manufacturer for specific
 instruction before perfoming any low level format to an ATA
 hard drive.
 Press ALT-C to continue, or press any other key to abort
 this operation.

 At this point you have 2 options:
    1) Press ALT-C to continue DISK MANAGER with this condition.
    2) Press any other key to cancel the installation.
                       | Disk Manager情報 |
 本操作は全てのﾊﾟｰﾃｨｼｮﾝ情報消失を引き起こします。
 結果として、全てのﾌｧｲﾙとﾃﾞｰﾀがもはやｱｸｾｽできなくなります。
 ATAﾊｰﾄﾞ ﾄﾞﾗｲﾌﾞにどんな低ﾚﾍﾞﾙ ﾌｫｰﾏｯﾄを実行するのに先立ち、
 ﾊｰﾄﾞ ﾄﾞﾗｲﾌﾞ製造業者に問い合わせてください。
 本操作を継続するにはALT-Cを、中止するには他のｷｰを押下してください。

 この時点で2つの選択があります。
    1) この条件でDisk Managerを継続するにはALT-Cを押下してください。
    2) ｲﾝｽﾄｰﾙを取り消すには他のｷｰを押下してください。

継続するにはAlt+Cを押下し、以降、画面の指示に従ってください。

通常、本機能を使用しなければならない状態は稀ですが、HDDの障害状況によっては、本機能実行後に通常のﾊﾟｰﾃｨｰｼｮﾝ作成とﾌｫｰﾏｯﾄでHDDが再生する場合があります。 この機能はHDDを破棄する場合に、その内容を確実に消去するのに利用できます。

注:本機能はDisk Managerが保持しているHDD情報の制限を受けるため、新機種のHDDでｻﾎﾟｰﾄ外警告になる場合があります。

2-2-7-3. (A)dvanced Options⇒(M)aintanance Options⇒Set Drive Size選択時

ﾕｰﾃｨﾘﾃｨ機能選択ﾒﾆｭｰでSet Drive Sizeが選択されると、次の警告画面が表示されます。

           | Set the selected drive to a specified size: |
 This command will instruct the selected hard disk drive to
 report, during boot, a size smaller then this true capacity.

 In this condition the computer's BIOS will not support the drive
 to its full capacity, but it will allow a machine with a BIOS
 limitation to boot with the drive in the system instead of
 locking up during the Power on Self Test (POST).

 After rebooting, run Disk Manager to install the selected hard drive.
 Disk Manager will install a Dynamic Drive Overlay on the drive
 to support the drive to its true capacity.
   ･ Press "Enter" to continue
   ･ Press any other key to exit back to the Utility Menu
                      | 選択ﾄﾞﾗｲﾌﾞを指定容量に設定 |
 本命令はﾌﾞｰﾄ中、選択したﾊｰﾄﾞ ﾃﾞｨｽｸ ﾄﾞﾗｲﾌﾞに真の容量より小さな容量の報告を指示します。

 この状態でのｺﾝﾋﾟｭｰﾀのBIOSはﾄﾞﾗｲﾌﾞの全容量をｻﾎﾟｰﾄしませんが、電源投入時自己検査(POST)中の
 停止や異常なしにｼｽﾃﾑ内のﾄﾞﾗｲﾌﾞでのﾌﾞｰﾄをBIOS制限のあるﾏｼﾝに許します。

 再起動後、選択したﾊｰﾄﾞ ﾄﾞﾗｲﾌﾞをｲﾝｽﾄｰﾙするために、Disk Managerを実行してください。
 Disk Managerはﾄﾞﾗｲﾌﾞの真の容量をｻﾎﾟｰﾄするため、ﾀﾞﾅﾐｯｸ ﾄﾞﾗｲﾌﾞ ｵｰﾊﾞｰﾚｲをﾄﾞﾗｲﾌﾞにｲﾝｽﾄｰﾙします。
  ･ 本操作を継続するにはEnterを押下してください。
  ･ ﾕｰﾃｨﾘﾃｨ ﾒﾆｭｰへ戻るには他のｷｰを押下してください。

継続するためにEnterｷｰを押下すると、画面上部に選択したHDD情報が表示されます。

2-2-7-3-(1) ｾｸﾀ数(容量)入力画面:

         | Drive model: IBM-DDLA-21620 |

| ﾄﾞﾗｲﾌﾞ ﾓﾃﾞﾙ名: IBM-DDLA-21620 |
 Maximum Total Sectors.....:    3177216 = 1.626GB
最大合計ｾｸﾀ数..: 3177216 = 1.626GB

 Boot Time Reported Sectors:    3177216 = 1.626GB
ﾌﾞｰﾄ時報告ｾｸﾀ数: 3177216 = 1.626GB

 Suggested Total Sectors...:    3177216 = 1.626GB
推奨合計ｾｸﾀ数..: 3177216 = 1.626GB

本例のHDDは容量が1.6Gﾊﾞｲﾄなので、BIOS制限の8.4Gﾊﾞｲﾄ未満のため、推奨合計ｾｸﾀ数も同じ数値になっています。 実際に使用するHDD容量がBIOS制限を越えている場合は、この値がBIOS制限値以下で表示されます(通常はBIOS制限値)。 しかし、BIOSによっては一般的な制限値ではなく、より小さな容量しか認識しないものがあります。 BIOSは全てのHDDを認識できる訳ではありません。 BIOSが認識できる種類のHDD容量の上限が一般的な制限値を下回った場合に、この状態になります。 従って、ここで設定する容量値は、実際のBIOSで確実に認識する容量値でなければなりません。

画面中央にはHDD容量指定入力が表示されます。

                      - Set Drive Size -
----------------------------------------------------------------
  Press "Enter" to use suggested value or enter your own value
  New total sector:      3177216
                       (ESC to CANCEL)
                      - ﾄﾞﾗｲﾌﾞ容量設定 -
----------------------------------------------------------------
  推奨値または入力値を使用するには"Enter"を押下してください。
  新合計ｾｸﾀ数:             3177216
                       (取り消しはESC)

入力するｾｸﾀ数の512倍がﾊﾞｲﾄ数です。 DDOを組み込む場合、この容量値は単にﾊﾟｿｺﾝ起動時のHDD BIOS認識のためだけに使用されます。 従って、目的HDDがBIOSで認識される最大指定容量が不明の場合には、適当に小さな値を指定しても構いません。 例えば、2Gﾊﾞｲﾄ(=4000000)などです。 指定値はｼﾘﾝﾀﾞ単位に整列されるため、指定値と若干異なる場合があることに注意してください。

ここでEnterｷｰを押下すると、次の警告画面が表示されます。

2-2-7-3-(2) 警告画面:

    | Please Confirm Set Drive Size to 3177216 sectors = 1.626GB |
 Warning! Use of this command on a drive that is already partitioned and
 formatted may lead to data loss and/or corruption now or in the future.
 ･ Only use this command to overcome a BIOS lockup condition
 ･ Only use this command prior to installing the drive with Disk Manager
 ***  Press ALT-C to execute this command - or any other key to exit  ***
             | 3177216ｾｸﾀ=1.626Gﾊﾞｲﾄへのﾄﾞﾗｲﾌﾞ容量設定を確認してください。 |
 警告!  既にﾊﾟｰﾃｨｰｼｮﾝが作成されﾌｫｰﾏｯﾄされているﾄﾞﾗｲﾌﾞでの本命令の
 使用は、現在または将来でのﾃﾞｰﾀ消失や不正ﾃﾞｰﾀを引き起こすかもしれません。
 ･ BIOSの停止や異常に対処するためだけに本命令を使用してください。
 ･ Disk Managerでのﾄﾞﾗｲﾌﾞのｲﾝｽﾄｰﾙだけに本命令を使用してください。
 ***  本命令を実行するにはALT-Cを、抜け出すには他のｷｰを押下してください。  ***

ALT+Cを押下すると、この指定値で設定が行なわれます。 そして、次の画面が表示されます。

2-2-7-3-(3) 終了画面:

        | New reported drive size:  1.626GB |
 The hard drive has been successfully programmed
 to report the Total Sectors value you entered.

 If the drive is not currently on the computer you
 intend to install it on, move it to that computer
 prior to performing this steps:

 1) Reboot
 2) Enter your System Setup
 3) Change the settings for this drive to "AUTO"-"AUTO"
 4) Exit System Setup and reboot
 5) Run Disk Manager to complete the drive installation
                 (Any key to continue)
            | 新しく報告されたﾄﾞﾗｲﾌﾞ容量: 1.626Gﾊﾞｲﾄ |
 ﾊｰﾄﾞ ﾄﾞﾗｲﾌﾞは入力された合計ｾｸﾀ数を報告するよう、成功裏に設定されました。

 このﾄﾞﾗｲﾌﾞがｲﾝｽﾄｰﾙを予定しているｺﾝﾋﾟｭｰﾀ上に現在ないなら、
 次の段階を実行する前にそのｺﾝﾋﾟｭｰﾀへ移設してください。

 1) 再起動してください。
 2) ｼｽﾃﾑ設定へ移行してください。
 3) このﾄﾞﾗｲﾌﾞに対する設定を"AUTO"に変更してください。
 4) ｼｽﾃﾑ設定を抜け、再起動してください。
 5) ﾄﾞﾗｲﾌﾞのｲﾝｽﾄｰﾙを完了するためにDisk Managerを実行してください。
                    (何れかのｷｰで継続)

2つ目の文章は、俗に言う母艦方式などで、実際に使用するﾊﾟｿｺﾝ以外で本命令を実行している場合の注意です。 1) ～5) の手順は実機上で行なう必要があります。

本命令(容量変更)を実機で行なった場合、1) の再起動はBIOSで正常認識させるために電源のOFF/ONで行なわなければなりません。 1) ～4) の手順はBIOS設定を意味しています。 BIOSでのHDD認識をAUTO(自動)設定にして、再起動します。 一般的に、この設定はAUTO(自動)になっているため、通常、この設定操作は必要ありません。

5) のDisk Managerの実行は、(E)asy Disk Instationか、または(A)dvanced Options⇒(A)dvanced Disk installation実行を意味します。

2-3. (A)dvanced Options⇒(U)pgrade Disk Manager選択時

この機能ではDDOを実現する全てのﾄﾞﾗｲﾊﾞや関連部分を更新します。 主ﾒﾆｭｰで(U)pgrade Disk Managerが選択されると、画面上部に次が表示されます。

更新機能説明画面:

                  | Upgrade Features |
 ･ Upgrade the Dynamic Drive Overlay (DDO) on all drives
 ･ Update MBR on all drives
 ･ Install the latest Enhanced 32-Bit Disk Access Driver
 ･ Update ONTRACKD.SYS if requireed
                        | 更新機能 |
 ･ 全ﾄﾞﾗｲﾌﾞのﾀﾞｲﾅﾐｯｸ ﾄﾞﾗｲﾌﾞ ｵｰﾊﾞｰﾚｲ(DDO)更新
 ･ 全ﾄﾞﾗｲﾌﾞのMBR更新
 ･ 32ﾋﾞｯﾄ ﾃﾞｨｽｸ ｱｸｾｽ強化ﾄﾞﾗｲﾊﾞ最終版のｲﾝｽﾄｰﾙ
 ･ 必要ならばONTRACKD.SYSの更新

画面中央には実行の可否を問う表示が現れます。

実行可否問い合わせ画面:

Are you sure you want to upgrade Disk Manager?

本当にDisk Managerを更新しますか?

----------------------------------------------
-----------------------------

                    (Y)ES
            (Y)はい
                    (N)O
            (N)いいえ

これはDisk Managerの新版を入手した場合に用いられますが、現在既に動作している場合には特に必要はありません。

Disk Manager導入後の動作

Disk Managerが導入されたHDDからﾌﾞｰﾄすると、BIOS画面後に次の画面が表示されます。

Starting ONTRACK...
-------------------------------------------------------------
                               I B M
        Dynamic Drive Overlay V9.55
        Copyright(c).ONTRACK Data International, Inc.
-------------------------------------------------------------
Press spacebar to boot from diskette...

これはDDOが実行されていることを示します。 何もしないと、約2秒後に通常のOSﾌﾞｰﾄﾛｰﾀﾞが実行されます。 DDO機能が有効なままでFDから起動する場合には、この時間中にｽﾍﾟｰｽ ｷｰを押下します。 ｽﾍﾟｰｽ ｷｰが押下されると、前の表示に続いて、次が表示されます。

To install an operationg system via diskett:  Insert the
installation diskette in drive A: now.  Press SPACEBAR.

To install an operating system via CD-ROM: Insert your
system diskette and press SPACEBAR to boot from diskette,
your hard drive by typing (for example) SYS C:, install
drivers, reboot and run SETUP from your CD-ROM.

これはOSｲﾝｽﾄｰﾙに関してで、FDから行なう場合には、A:ﾄﾞﾗｲﾌﾞにFDを挿入してｽﾍﾟｰｽ ｷｰを押下、CD-ROMから行なう場合には、一旦FDからﾌﾞｰﾄするためにｼｽﾃﾑFDを挿入してｽﾍﾟｰｽ ｷｰを押下後、例えばSYS C:でHDDにｼｽﾃﾑを複写し、必要なﾄﾞﾗｲﾊﾞをｲﾝｽﾄｰﾙして再起動(実際には電源のOFF/ON)後にCD-ROMからOSｲﾝｽﾄｰﾙを開始する旨の表示です。

何らかの理由でHDDの全容量認識状態でFDから起動する場合には、ここのｽﾍﾟｰｽ ｷｰ操作で行います。 最初のｽﾍﾟｰｽ ｷｰ認識時間が短いため、表示直後に素早く行なう必要があります。


ｲﾝｽﾄｰﾙの自動化

追補 ｲﾝｽﾄｰﾙの自動化

Windows9xのｲﾝｽﾄｰﾙは、自動化することが可能です。 但し、Card (PCMCIA)経由のｲﾝｽﾄｰﾙを行う場合には、1手順のみ手操作が介在します。 この自動化を行うためには、以下の3項目が必要です。 これらの3項目は、関連がありませんので、実際に処理した項目の部分が自動化され、3項目全部の処理で全自動化が行われます。

■ ｼｽﾃﾑ ﾌﾞｰﾄ

ｲﾝｽﾄｰﾙ開始時はDOSで起動します。 このため、Windowsｲﾝｽﾄｰﾙ ﾃﾞｨｽｸにｼｽﾃﾑが存在し、ﾌﾞｰﾄ ﾃﾞｨｽｸとして作成されていて、BIOSがﾌﾞｰﾄ可能なﾃﾞﾊﾞｲｽにWindowsｲﾝｽﾄｰﾙ ﾃﾞｨｽｸが含まれている場合には、Windowsｲﾝｽﾄｰﾙ ﾃﾞｨｽｸからの起動が可能です。 CD-Rなどの書き込み時にｼｽﾃﾑ ﾌｧｲﾙを含めて、ﾌﾞｰﾄ ﾃﾞｨｽｸとして作成すれば、ﾃﾞｨｽｸとしての条件は満たします。 通常、BIOSのﾌﾞｰﾄ ﾄﾞﾗｲﾌﾞの設定は、A:→C:などになっている例が多いと思いますが、これをWindowsｲﾝｽﾄｰﾙ ﾃﾞｨｽｸを使用するﾄﾞﾗｲﾌﾞを含めるように変更します。 古いBIOSでは、ﾌﾛｯﾋﾟｰ ﾃﾞｨｽｸとﾊｰﾄﾞ ﾃﾞｨｽｸ以外は選択できないものもありますので、この場合はBIOSの更新も必要になります。

更に、AUTOEXEC.BATの最後に起動するﾌﾟﾛｸﾞﾗﾑを指定します。標準のｲﾝｽﾄｰﾙを行う場合は、次の2行を追加します。

例
CD WIN98
SETUP

次に示すﾊﾞｯﾁ処理を行う場合は、次の2行を追加します。

例
CD WIN98
SETUP MSBATCH.INF

■ ｲﾝｽﾄｰﾙ ﾊﾞｯﾁ処理

ｲﾝｽﾄｰﾙ中に発生する問い合わせ関係は、ﾊﾞｯﾁ処理で自動化することができます。 このﾊﾞｯﾁ ﾌｧｲﾙを作成するﾂｰﾙがWindowsｲﾝｽﾄｰﾙ ﾃﾞｨｽｸ内に用意されています。 このﾌﾟﾛｸﾞﾗﾑはﾏｼﾝにｲﾝｽﾄｰﾙする形式です。

1. | Windowsｲﾝｽﾄｰﾙ ﾃﾞｨｽｸの\Tools\Reskit\BatchﾌｫﾙﾀﾞのSetup.exeをﾀﾞﾌﾞﾙｸﾘｯｸし、Batch98をｲﾝｽﾄｰﾙします。
2. | ｽﾀｰﾄ ﾒﾆｭｰからBatch98を起動します。
3. | 収集開始ﾎﾞﾀﾝをｸﾘｯｸします。 これは現在のﾏｼﾝ設定を取得します。
4. | 必要ならば、ﾍﾙﾌﾟを参考に各項目を設定します。
5. | 設定をINFﾌｧｲﾙに保存するﾎﾞﾀﾝをｸﾘｯｸします。
6. | Batch98を終了します。

以上の操作でMSBATCH.INFというﾌｧｲﾙが作成されます。 このﾌｧｲﾙをｲﾝｽﾄｰﾙ時のSetup.exeのﾊﾟﾗﾒｰﾀとして指定すれば、先程の設定でｲﾝｽﾄｰﾙされます。 このINFﾌｧｲﾙの位置は任意で、Setup.exeのﾊﾟﾗﾒｰﾀ指定時に正確なﾊﾟｽを指定します。 本ﾍﾙﾌﾟではWindowsｲﾝｽﾄｰﾙ ﾃﾞｨｽｸの\WIN98ﾌｫﾙﾀﾞに存在するとして説明しています。

■ ﾄﾞﾗｲﾊﾞ変更,追加処理

Windowsが標準でｻﾎﾟｰﾄするﾄﾞﾗｲﾊﾞの更新や新規ﾄﾞﾗｲﾊﾞの追加が行えます。 これを行うﾌﾟﾛｸﾞﾗﾑもWindowsｲﾝｽﾄｰﾙ ﾃﾞｨｽｸ内に用意されています。 このﾌﾟﾛｸﾞﾗﾑはWindowsｲﾝｽﾄｰﾙ ﾃﾞｨｽｸから直接起動できます。

1. | Windowsｲﾝｽﾄｰﾙ ﾃﾞｨｽｸの\Tools\Reskit\InfinstﾌｫﾙﾀﾞのInfinst.exeを起動します。
2. | 追加するINFﾌｧｲﾙ欄で変更/追加するﾄﾞﾗｲﾊﾞの場所を指定します。
3. | Windows SETUP.EXE欄で\Win98ﾌｫﾙﾀﾞのSetup.exeを指示します。
4. | INFの追加ﾎﾞﾀﾝをｸﾘｯｸします。
5. | 変更/追加が複数の場合は、上記操作を繰り返します。
6. | Infinstを終了します。

以上の操作でﾄﾞﾗｲﾊﾞが追加になり、\WIN98ﾌｫﾙﾀﾞにCUSTOM.INFﾌｧｲﾙが作成されます。 この処理の結果、Windowsの標準ｻﾎﾟｰﾄ ﾄﾞﾗｲﾊﾞに処理したﾄﾞﾗｲﾊﾞが追加され、以降の新規ﾊｰﾄﾞｳｪｱ検出でこれらのﾄﾞﾗｲﾊﾞが標準ｻﾎﾟｰﾄになります。

注:この処理では、Windowsｲﾝｽﾄｰﾙ ﾃﾞｨｽｸに書き込みますので、CD-ROM上では行えません。 ﾊｰﾄﾞ ﾃﾞｨｽｸやMOなどに\WIN98ﾌｫﾙﾀﾞ以下をｺﾋﾟｰして、上記の3.Windows SETUP.EXE指定でこのｺﾋﾟｰを指示します。 この編集後の\WIN98ﾌｫﾙﾀﾞ以下をCD-Rで書き込むと更新されたWindowsｲﾝｽﾄｰﾙCD-ROM相当になります。


単一Card(PCMCIA)ｿｹｯﾄでのﾄﾞﾗｲﾊﾞ追加

追補 単一Card(PCMCIA)ｿｹｯﾄでのﾄﾞﾗｲﾊﾞ追加

ﾏｼﾝ、ﾏｼﾝ構成によっては、Card(PCMCIA)ｿｹｯﾄが1つしか無く、他にCD-ROMなどのWindowsｲﾝｽﾄｰﾙ ﾃﾞｨｽｸをｱｸｾｽできるﾄﾞﾗｲﾌﾞが無い場合、唯一のｿｹｯﾄに新しいｶｰﾄﾞを挿入する場合は問題となります。

■ Windowsのﾄﾞﾗｲﾊﾞ ｲﾝｽﾄｰﾙ手順

Windowsは新規ﾊｰﾄﾞｳｪｱを検出すると、\Windows\Infﾌｫﾙﾀﾞ内の各ﾌｧｲﾙから作成したﾄﾞﾗｲﾊﾞ情報ﾍﾞｰｽを検索し、該当するﾊｰﾄﾞｳｪｱのﾄﾞﾗｲﾊﾞ情報ﾌｧｲﾙ(ｲﾈｰﾌﾞﾗ)から、必要なﾄﾞﾗｲﾊﾞとその所在場所を得てｲﾝｽﾄｰﾙを行います。 Windowsｲﾝｽﾄｰﾙ時のﾄﾞﾗｲﾌﾞが存在しないなどの場合は、ﾄﾞﾗｲﾊﾞの場所を要求するﾀﾞｲｱﾛｸﾞが表示され、使用者が指示します。

新規ﾊｰﾄﾞｳｪｱのｲﾝｽﾄｰﾙでは、大別すると次の2つの結果となります。

① | Windowsがｻﾎﾟｰﾄするｶｰﾄﾞでﾄﾞﾗｲﾊﾞをｲﾝｽﾄｰﾙします。
② | Windows未ｻﾎﾟｰﾄで、ｶｰﾄﾞ付属などのﾄﾞﾗｲﾊﾞをｲﾝｽﾄｰﾙします。

②の場合、ﾌﾛｯﾋﾟｰ ﾃﾞｨｽｸが使用できれば、ﾄﾞﾗｲﾊﾞのｲﾝｽﾄｰﾙ時にﾃﾞｨｽｸ使用ﾎﾞﾀﾝでﾌﾛｯﾋﾟｰ ﾃﾞｨｽｸからｲﾝｽﾄｰﾙすれば問題はありません。 ﾌﾛｯﾋﾟｰ ﾃﾞｨｽｸが使用できない場合は、必要なﾌｧｲﾙをﾊｰﾄﾞ ﾃﾞｨｽｸの適当な場所にｺﾋﾟｰすれば、ﾌﾛｯﾋﾟｰ ﾃﾞｨｽｸ使用時と同様な結果となります。

①の場合、既に存在するﾄﾞﾗｲﾊﾞで充分な場合などを除いて、Windowsｲﾝｽﾄｰﾙ ﾃﾞｨｽｸからﾄﾞﾗｲﾊﾞをｲﾝｽﾄｰﾙしようとします。 しかし、ｿｹｯﾄが1つですので同時にSCSIｶｰﾄﾞなどを使用することができません。 この場合の対処方法を次に示します。

■ ﾄﾞﾗｲﾊﾞのｲﾝｽﾄｰﾙ手順

この方法は、上記②同様にするための手順です。

① | 唯一のｿｹｯﾄに新規ｶｰﾄﾞを挿入します。
② | ﾄﾞﾗｲﾊﾞのｲﾝｽﾄｰﾙが開始されWindows 98のCD-ROMを挿入してくださいのﾒｯｾｰｼﾞとなりますので、OKﾎﾞﾀﾝをｸﾘｯｸします。
③ | ｴﾗｰとなり、ﾌｧｲﾙのｺﾋﾟｰ元を指示するﾒｯｾｰｼﾞとなりますので、詳細ﾎﾞﾀﾝをｸﾘｯｸします。
④ | 表示されるｴﾗｰの詳細ﾀﾞｲｱﾛｸﾞの受け側ﾌｧｲﾙの行の=以降のCABﾌｧｲﾙ名を記録し、OKﾎﾞﾀﾝをｸﾘｯｸします。
⑤ | ｽｷｯﾌﾟﾎﾞﾀﾝをｸﾘｯｸします。
⑥ | 以降、終了まで③～⑤を繰り返します。
⑦ | 新規ｶｰﾄﾞを抜き、Windowsｲﾝｽﾄｰﾙ ﾃﾞｨｽｸをｱｸｾｽできるｶｰﾄﾞに差し替えます。
⑧ | Windowsｲﾝｽﾄｰﾙ ﾃﾞｨｽｸの\WIN98ﾌｫﾙﾀﾞ内から、④で記録したCABﾌｧｲﾙをﾊｰﾄﾞ ﾃﾞｨｽｸの適当な場所にｺﾋﾟｰします。
⑨ | ｶｰﾄﾞを新規ｶｰﾄﾞに入れ替えると、①からと同様になりますが、③の手順では、⑧でｺﾋﾟｰしたﾊｰﾄﾞ ﾃﾞｨｽｸ上の場所を指示してOKﾎﾞﾀﾝをｸﾘｯｸします。
⑩ | ｲﾝｽﾄｰﾙが終了したら、⑧でｺﾋﾟｰしたCABﾌｧｲﾙを削除します。